E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking Forum by BimmerWorld

Suspension & Braking Forum by BimmerWorld
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!
Sponsored by BimmerWorld

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 11-07-2010, 06:22 PM   #1
blackbeam05
Registered User
 
Join Date: Aug 2006
Location: My House
Posts: 549
My Ride: 2004 325i
Brakes Grinding!! Need help!

Last week I noticed this grinding in my rear passenger rotor and I thought it was the pads wearing down or the rotors ending their life so me and another fanatic put new brakes on today....and the grinding is still there! Its there when I apply the brake or if I let go and it goes away when I turn. I am thinking it is the caliper but can anyone put any insight in??

Also the dcs light kicked on after the new brakes too, and its not the fluid.
__________________
blackbeam05 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-07-2010, 10:03 PM   #2
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,385
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
I would check the REAR Wheel Bearing...

-TrippinBimmer
TrippinBimmer is offline   Reply With Quote
Old 11-08-2010, 06:55 AM   #3
blackbeam05
Registered User
 
Join Date: Aug 2006
Location: My House
Posts: 549
My Ride: 2004 325i
I had the wheel bearing changed about 6 months ago
__________________
blackbeam05 is offline   Reply With Quote
Old 11-08-2010, 10:01 AM   #4
blackbeam05
Registered User
 
Join Date: Aug 2006
Location: My House
Posts: 549
My Ride: 2004 325i
It was the wheel bearing. I had it changed but the nut wasnt tightened right so it came off causing the bearing to go bad again..thanks for the help
__________________
blackbeam05 is offline   Reply With Quote
Old 11-08-2010, 11:45 AM   #5
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,385
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
NO Problem

-TrippinBimmer
TrippinBimmer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use