E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > BAVSOUND Mobile Electronics Forum

BAVSOUND Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by BAVSOUND

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-11-2016, 08:31 AM   #1
Marked Man
Registered User
 
Join Date: Jul 2014
Location: Albuquerque
Posts: 11
My Ride: 2001 M3
More Power need suggestions on sound solution

I have a basket case 01 M3 Vert. I had to rewire the factory amp since prior owner had subbed out a Rockford vintage one just laying in the trunk.
I wanted to add BT, and Aux and USB support so I took and have adapted a Kenwood BTC-592X with steering wheel control ASWC-1 adapter and all to get it to work.
It all works except two things:
1) ASWC-1 has a known issue with the R/T signal (set for source changing on the head unit in this case) causing the source to change 5 seconds after car is started. I plan to try and remap this button to eliminate a response to whatever "ready" signal the car is sending at startup. Anyone have this issue and resolve it?????

2) Sound sucks. Very weak as you have to turn head unit up to really get sound and at that level right channel is distorting.

I have a couple front mid-tweets that need attention but if I cut the sub out the Mid-Bass signal going to the speakers just has no umph!

I have replaced the rear seat speakers with some nice 6" Kicker 2ways.
The fronts appear to be factory.

What is the best way to improve the frequency distribution out of the amp to get stronger bass and mid to the 4 mains?

Is is better to boost the line level coming out of head unit to drive the amp better or am I just pissing in the wind and need to replace factory amp with something that fits in that hole by the rear seat?

Thanks
Marked Man is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use