E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-29-2010, 10:16 AM   #1
Travis2388
Registered User
 
Join Date: Nov 2010
Location: NJ
Posts: 2
My Ride: 2002 330i
Exclamation **Many issues? Or just electrical??

Ok I apologize for this long post but I don't know where else to turn but you guys...I have a 2002 330i with over 120k. The car runs great and I have never had any real issues. Since I have had the car (4yrs) it has always had issues with the taillights, sometimes they would go out(non bulb related), sometimes the dash indicator would display the light out on the left but the right side was out. It was determined that the Ground was bad on both sides. It was fixed and have had no further issues with the tails.

1. Recently I had my driver's side corner marker light go out, replaced the bulb, worked fine for 2 days, then it was back out. Then randomly it comes back on and off so it is clearly not a bulb. The very next day my xenon bulb goes out on my passenger side(it had been purple for 2 weeks). I had an extra bulb so i replaced it and it wouldn't come back on. Then randomly starting the car up at night a few days back it came on, then seconds later was out again.(read on this forum it could be a bad ballast or ignitor but have not checked yet)

>>>Possible bad ground in the car?? I found on this forum a list of main grounds to check so I will be doing that ASAP.
>>>If not a bad ground could I just be having a series of things crashing at one time?


2. Next day I get out of the car and lock the car with the remote(my locking mechanism in the drivers door is broke so it just free spins all I use to get in is my remote). When later trying to unlock the car it would not respond to the remote unlock-trunk did not open/lights did not come on/doors did not unlock. Pressed it a bunch of times then bang it just worked. I have since tried it once with the same result..took a bunch of attempts to get it to respond.

>>>Possible FZV Antenna Amplifier? (gas door locks when car locks and visa versa)


PLEASE NOTE my car has not had the computer wiped/cleaned in the 4years i have owned it. I do not take it to the stealer for oil changes and regular maintenance.

ANY thoughts next to blowing the car up would be a great help and much appreciated guys
Travis2388 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-29-2010, 12:48 PM   #2
jgold47
Registered User
 
Join Date: Sep 2010
Location: Imported from Detroit
Posts: 1,261
My Ride: 2004 X5 3.0
I mean, it could be a GM module issue - search for that. a lot of locking/unlocking issues are related to that. Also, I assume you tried other keys?

As for the lights going on and off, especially that you live in Jersey, I would consider corrosion and bad grounds to be a potential culprit, but search for that, I am not familiar (havent been doing this that long) of that specific issue happening on our cars. Good luck.
__________________
Religion, Politics, and which oil is the best to use. Three things never to be discussed in polite company...

my about me link
http://forum.e46fanatics.com/showthread.php?t=791566

jgold47 is offline   Reply With Quote
Old 11-29-2010, 02:22 PM   #3
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 6,954
My Ride: 2004 M3, 2001 325i
Well, it could be the grounds. But I honestly think thats unlikley.

Have you ever rust-proofed the car? I've heard terror stories where this has led to major electrical failures much like you are describing
ac_2007 is offline   Reply With Quote
Old 11-29-2010, 06:27 PM   #4
Travis2388
Registered User
 
Join Date: Nov 2010
Location: NJ
Posts: 2
My Ride: 2002 330i
Thanks for the quick responses guys. I have a second key that I split in half to check the battery voltage(which was fine) then put back together and re programmed it to the car and now my keyless entry is working fine. Very odd because my main key--which I also broke open and checked the voltage and it was also full--is still not working even after resync. This solves one problem knowing now that its not a GM module or the FZV.

Still having lighting issues--the corner light worked half of today then went back out. The xenon has not come on at all today. After some research I have come to the conclusion it has to be the balast or ignitor. Any ideas on how hard it is to replace those? Do they come in a package? Difficulty of install? I looked at prices for just a new assembly and decided instantly I need to find a DIY repair
Travis2388 is offline   Reply With Quote
Reply

Tags
electrical, help needed, issue, new member, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use