E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-26-2011, 07:55 PM   #1
DeltaAir
Registered User
 
Join Date: May 2004
Location: Lakeland, FL
Posts: 59
My Ride: '04 BMW 330ci ZHP
Stock Coupe LED Problem

All,

This one has me stumped and I hope I am in the right place. My driver side rear LED turn signal is out and giving me the dreaded "bulb sign of death" on my instrument cluster.

Since LEDs are supposed to last longer then I live, what the heck do I do from here? It probably has to be some loose wire or something.
__________________
DeltaAir is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-26-2011, 11:43 PM   #2
E46M3Dream
Registered User
 
Join Date: Nov 2010
Location: USA, California
Posts: 80
My Ride: 02' E46 M3
replace the bulb..?
E46M3Dream is offline   Reply With Quote
Old 01-28-2011, 11:26 PM   #3
drumbum624
Registered User
 
Join Date: Dec 2010
Location: Baltimore, MD/DC
Posts: 652
My Ride: 325xi
Send a message via AIM to drumbum624
I have the Eagle Eyes LED tails and actually just recently had my bulb out go off. All I did was turn the flashers on and off a couple times and it went back to normal cause I was pretty sure my LED didnt go out. Unfortunately BMW wiring for their lights can be a little funky and sometimes you might just have to turn the car on and off a couple times and that will do the trick (happens with my highbeams every now and then, dont ask why). I feel like your issue is a little more serious though and has been going on for a little while now? If so I'd suggest disconnecting the taillights (leaving them installed), and plugging in your oem ones. turn the car on and see if the blinkers work properly than go back and try your leds again. If you only have the LEDs to work with than just disconnect and reconnect. Maybe try cleaning out the harness with some air duster?
drumbum624 is offline   Reply With Quote
Old 01-30-2011, 06:36 AM   #4
daki_bmw
Registered User
 
Join Date: Jul 2009
Location: Serbia
Posts: 817
My Ride: 330Ci
Quote:
Originally Posted by E46M3Dream View Post
replace the bulb..?
daki_bmw is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use