E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-09-2011, 12:07 PM   #1
FreddyMags
Registered User
 
Join Date: Aug 2010
Location: NY
Posts: 14
My Ride: 2001 325ci
ABS, Brake, and Traction Control Fault

The ABS, Brake, and Traction fault lights have illuminated recently. I have since noticed that the Brake fault light will start off yellow and when I step on the brake they pulse (believe ABS kicks in) until I apply more pressure. The light then turns red and I have normal brake power, however the lights stay on and sometimes the speedometer fails and will stay at zero regardless of my speed. I experienced this same exact problem a few months ago and was instructed to replaced the evaporator control valve. I replaced this valve because it was indicated on my service engine code but I didnt think it had anything to do with the ABS. Miraculously enough when I did replace the valve the ABS issue went away but to return again now. Can anyone shed some insight on what is causing this issue? Thank you.


Last edited by FreddyMags; 02-09-2011 at 12:21 PM.
FreddyMags is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-09-2011, 12:39 PM   #2
330ciandr6
Registered User
 
Join Date: May 2007
Location: .
Posts: 6,606
My Ride: .
Send a message via AIM to 330ciandr6 Send a message via Yahoo to 330ciandr6
read here

http://forum.e46fanatics.com/showthr...648&highlight=
__________________
Have a oil or coolant leak? Click here!:http://forum.e46fanatics.com/showthr...732&highlight=
ABS/DSC/Brake/Airbag light on?? Click here!:http://forum.e46fanatics.com/showthr...648&highlight=
330ciandr6 is offline   Reply With Quote
Old 02-09-2011, 03:10 PM   #3
Tymm
Registered User
 
Join Date: Dec 2010
Location: Sweden
Posts: 150
My Ride: 320ci E46, 325i E92,
ts your rear left abs/speed sensor that you need to check 1st
__________________


2000 BMW 320ci 2.2ltr
Tymm is offline   Reply With Quote
Old 02-09-2011, 03:37 PM   #4
Another BM
Registered User
 
Join Date: Jul 2007
Location: Toronto
Posts: 461
My Ride: 330ci
Quote:
Originally Posted by Tymm View Post
ts your rear left abs/speed sensor that you need to check 1st
+1

thats what i was gonna say
__________________
Another BM is offline   Reply With Quote
Old 02-10-2011, 08:12 AM   #5
FreddyMags
Registered User
 
Join Date: Aug 2010
Location: NY
Posts: 14
My Ride: 2001 325ci
Well now it has gotten much worse. The Transmission warning light (exclaimation point inside a gear) came on last night followed by the service engine light and the car appears to be stuck in 3rd gear. When I shift to Reverse or Neutral the transmission jerks the car into gear. I was going to try and drive it over to a independent BMW mechanic to check all the codes but I didnt want to risk burning up the tranny. I just had the transmission replaced 3 years ago after the first one did something very similar.

Last edited by FreddyMags; 02-10-2011 at 08:13 AM.
FreddyMags is offline   Reply With Quote
Old 02-10-2011, 08:13 AM   #6
330ciandr6
Registered User
 
Join Date: May 2007
Location: .
Posts: 6,606
My Ride: .
Send a message via AIM to 330ciandr6 Send a message via Yahoo to 330ciandr6
probably gonna need a trans...get the codes read first.
__________________
Have a oil or coolant leak? Click here!:http://forum.e46fanatics.com/showthr...732&highlight=
ABS/DSC/Brake/Airbag light on?? Click here!:http://forum.e46fanatics.com/showthr...648&highlight=
330ciandr6 is offline   Reply With Quote
Old 02-10-2011, 12:13 PM   #7
FreddyMags
Registered User
 
Join Date: Aug 2010
Location: NY
Posts: 14
My Ride: 2001 325ci
Is it possible that these problems are being caused by the MAF Sensor? Was thinking maybe my car switched to limp mode.
FreddyMags is offline   Reply With Quote
Old 02-10-2011, 01:06 PM   #8
Tymm
Registered User
 
Join Date: Dec 2010
Location: Sweden
Posts: 150
My Ride: 320ci E46, 325i E92,
I have just about 2 hours ago replaced my rear left abs/speed sensor and now I have speedo and NO lights on the dash WOO HOO! I managed to get a salvage 1 for about 15 only took 30mins to do
__________________


2000 BMW 320ci 2.2ltr
Tymm is offline   Reply With Quote
Old 02-10-2011, 02:24 PM   #9
FreddyMags
Registered User
 
Join Date: Aug 2010
Location: NY
Posts: 14
My Ride: 2001 325ci
Did you experience the same issue with your transmission (limp mode)?
FreddyMags is offline   Reply With Quote
Old 02-10-2011, 03:35 PM   #10
g4LLiT0
Registered User
 
Join Date: Aug 2009
Location: Aruba
Posts: 366
My Ride: 99 Bmw
it maybe the asc/abs control unit, or transmission output sensor aka pulse generator..
__________________
g4LLiT0 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use