E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-07-2011, 11:43 PM   #1
cardsfan007
Registered User
 
Join Date: Apr 2010
Location: Missouri
Posts: 460
My Ride: 2002 330xi
Problems

Unfortunately i am having a couple problems with my 330xi again. I think i know what the solution is on some of them, but would like some input. First i have noticed my ride getting harsher and more bouncy after a bump. Also, when i get to the end of my driveway when backing out, when my front left tire goes down the bump there is kind of a clunk. Am i in need of new suspension? Also, i have noticed that sometimes when i first let off the brake it kind of grinds/clunks as well, suspension or brake issue? Another thing i have noticed is i have been idling extremely low, ie about 500 rpms? In addition i cant glide as well or when im going really slow speeds like backing out of parking spots i have to use my gas a lot more. I used to not have to at all. Hopefully its just the cold weather, but unfortunately i rather doubt it. Still having the whistlng problem, havent gotten a chance to try anything to fix that because of the weather. Last thing, in need of new tires very soon. The continental extreme contace are highest on my list but would love peoples input (yes i have read many reviews on here but would like the opnion of xi's because ours are very different)
Tia for the info
cardsfan007 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-07-2011, 11:46 PM   #2
cardsfan007
Registered User
 
Join Date: Apr 2010
Location: Missouri
Posts: 460
My Ride: 2002 330xi
Forgot to add that i have about 75500 miles on the car and i believe original shocks and possibly belts, dont know for sure on the belts
cardsfan007 is offline   Reply With Quote
Old 02-08-2011, 10:35 AM   #3
thurston512
Registered User
 
Join Date: Oct 2010
Location: Bloomington, IN
Posts: 56
My Ride: 2003 325XI Wagon
Same Clunking in my XI, only front right. I just pulled the wheel off last night and checked everything, seems that everything is tight and right, must be the strut as I have 100K now.
thurston512 is offline   Reply With Quote
Old 02-08-2011, 11:06 AM   #4
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,390
My Ride: 2003 325xi
Jack up the wheels and shake them to check all the ball joints.

Bouncy ride sounds like struts- push down on each corner a few times to see if they rebound ok.

Clunking is probably ball joints or sway bar end link.

Low idle could be a lot of things- how is your gas mileage? I would search for the videos that show you how to check the DISA valve.

The AC and serpentine belt should probably be changed- check the inside for small cracks in the grooves. I would throw a waterpump and possibly a thermostat at it with new belts and change your coolant as well. brake fluid and the 4 driveline fluids should be changed too.

Last edited by Kubica; 02-08-2011 at 09:17 PM.
Kubica is offline   Reply With Quote
Old 02-11-2011, 06:18 PM   #5
cardsfan007
Registered User
 
Join Date: Apr 2010
Location: Missouri
Posts: 460
My Ride: 2002 330xi
thanks for all the info, my gas mileage has dropped, but i know that that is also due to the cold weather. and im planning on getting new belts, just havent had the time or weather to do it.
cardsfan007 is offline   Reply With Quote
Old 02-11-2011, 08:19 PM   #6
62RDSTR
Registered User
 
Join Date: Feb 2008
Location: Madison, AL
Posts: 17
My Ride: 2001 330xi
I had similar issue with some clunk/rattle pulling out of driveway and going over small bumps. Replaced the sway bar links and that care of the issue.
62RDSTR is offline   Reply With Quote
Old 02-12-2011, 10:43 PM   #7
jcarpfishman
Registered User
 
Join Date: Nov 2010
Location: Beavercreek, OH
Posts: 102
My Ride: '01 330xi
For the low idle, check that your O2 sensors are functioning properly, check for air leaks, and do vanos seals if they've never been done.

When my fuel economy tanked (15 mpg driving conservatively), I did all this and I cleaned the DISA, fixed the air leak around the DISA, cleaned the ICV, and the throttle body. Collectively, all of that fixed my low idle / bouncing idle / rough idle and got my fuel economy back where it needed to be.
jcarpfishman is offline   Reply With Quote
Old 02-16-2011, 02:21 AM   #8
cardsfan007
Registered User
 
Join Date: Apr 2010
Location: Missouri
Posts: 460
My Ride: 2002 330xi
bump
cardsfan007 is offline   Reply With Quote
Old 02-16-2011, 11:37 AM   #9
infinite012
Registered User
 
Join Date: Jul 2004
Location: Richmond, VA
Posts: 1,239
My Ride: White '08 STI
Replacing your suspension will not get rid of that clunk! Ask me how I know...

Check your bushings. That seems to be the consensus.
infinite012 is offline   Reply With Quote
Old 02-16-2011, 04:54 PM   #10
LittleChrist12
Registered User
 
Join Date: Jan 2010
Location: Albany, NY
Posts: 533
My Ride: 2003 BMW 325xi
The whistle/low idle will be fixed by replacing your lower intake boot. The boot rips and changes the air flow into the engine past the MAF.

As for the clunk, I replaced my upper strut mounts and solved the problem.

Sent from my DROIDX using Bimmer App
__________________
2003 BMW 325xi
2010 BMW M3 Sedan
LittleChrist12 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use