E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-15-2011, 11:32 PM   #1
nukeboy
Registered User
 
Join Date: Mar 2011
Location: Washington
Posts: 2
My Ride: BMW 325 xi
Unhappy Severe vibration Rt side of XI only going uphill.

Hello E46'rs,
My 2005 325 XI is vibrating and shaking only when I travel at highway speeds and only uphill (those 2 parameters must be met in order to notice it). Feels like it is coming from the Right side. There is also some increased outer wear on the Right tire as opposed to the left. Also, the alignment of the vehicle is clearly off as it pulls to the left. Any ideas?
nukeboy is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-16-2011, 05:21 AM   #2
My white xi
Registered User
 
Join Date: Nov 2010
Location: Montreal,Canada
Posts: 66
My Ride: 2004 330xi
Grease your 2 front axel and you will delite your problem...the 2 boot close to front difff are out of grease...but chek all 4 of them..
My white xi is offline   Reply With Quote
Old 03-16-2011, 07:25 AM   #3
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,390
My Ride: 2003 325xi
Sounds like an FCAB or ball joint issue.

Jack up the front right and shake the hell out of it to see if there's any play.
Kubica is offline   Reply With Quote
Old 03-16-2011, 12:12 PM   #4
nukeboy
Registered User
 
Join Date: Mar 2011
Location: Washington
Posts: 2
My Ride: BMW 325 xi
Thanks

Thanks Kubica and My white xi, I will check that out.
nukeboy is offline   Reply With Quote
Old 03-17-2011, 09:25 AM   #5
pjo33us
Registered User
 
Join Date: Jun 2009
Location: Colorado
Posts: 207
My Ride: 03 330xi
In addition to the above...you might take a look at your right side motor mount.
__________________
pjo33us is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use