E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-30-2014, 09:08 PM   #1
GA_M3_2b
Registered User
 
Join Date: Jun 2014
Location: Lawrnceville GA
Posts: 14
My Ride: 2004 M3 JB Cinn Conv
///AVIN AVANT 2 install

2004 M3 convertible with factory navigation.

I spent time today installing my new AVANT 2 head unit. It took me longer because it turns out someone had been into my car before. So there were wires I had to trace to see where they went and remove a bunch of stuff. I purchased the car in May of 2014 and have slowly been upgrading it here and there. Well I have a 10 hour trip coming up soon and couldn't really stand the stereo system that was in it. The oem headunit had some dead pixels and the sound was rather poor. Well I think I now know why it was poor, all the junk I had to rip out.

Rewind to last night, I started to disassemble the trim and the dash. I found a bunch of stuff I didn't recognize. Some aftermarket internal antenna, an iSimple ipod thingy, some messed up antenna wiring, a Rockford Fosgate amp and bass in the trunk (the amp had some blue wire that was run from the trunk to the front passenger side floor then was just paying there). I knew the amp and enclosure were there but decided to call it a night before physically tracking and removing stuff.

Once I got all that tracked down and taken out I could look at installing the new unit. Once I located the connector in the trunk, ran the wires under the carpet and through the dash I test fired it up. The head unit powered right up. So I pulled out my iphone, paired it with my AVANT 2 and listened to a few tunes via bluetoth. It sounds SO much better.

Tomorrow I will button up the trunk, under the dash and the trim. Then I will put all my pictures together and write a quick DIY in the coming days. So far so good though. I am liking it a lot.

Plus Tommy took good care of me, I ordered it (EASY), it shipped and got delivered (FAST) plus I got an OBD plug in module (FREE). What more can I ask for.

I will be getting a wifi hotspot from T Mobile to keep in the car but in the meantime I will use my home wireless to test everything once I put it all back together.

Last edited by GA_M3_2b; 08-30-2014 at 09:11 PM.
GA_M3_2b is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-31-2014, 08:07 PM   #2
GA_M3_2b
Registered User
 
Join Date: Jun 2014
Location: Lawrnceville GA
Posts: 14
My Ride: 2004 M3 JB Cinn Conv
Everything is pretty much buttoned up. The AVANT 2 works really well. It connected to the OBD2 reader and my home network so I was able to download Torque Pro. Now I just need to learn to work Android and get my mobile hotspot from my cell provider. I am happy though and I really like it.
GA_M3_2b is offline   Reply With Quote
Old 08-31-2014, 08:33 PM   #3
GA_M3_2b
Registered User
 
Join Date: Jun 2014
Location: Lawrnceville GA
Posts: 14
My Ride: 2004 M3 JB Cinn Conv
Here is all the junk I had to remove (not including the bass and the box enclosure).
[IMG] photo IMG_1251.jpg[/IMG]

Here was the funky antenna wire I came across. I tracked them back to the trunk and they were simply extensions that were male/female, so I removed the soldered pieces and connected the short pieces that went up into the rear area where the antenna is in the body.

[IMG] photo IMG_1210a.jpg[/IMG]
GA_M3_2b is offline   Reply With Quote
Old 08-31-2014, 08:44 PM   #4
jeffb325@NavigationSolutions
J&T Distributing
 
jeffb325@NavigationSolutions's Avatar
 
Join Date: Jun 2010
Location: Fresno, CA
Posts: 2,728
My Ride: BMW
It's always an adventure when you start taking things apart and realize somebody has already been in there!
__________________
USE COUPON CODE FANATICS AT CHECKOUT TO GET A $50 FORUM DISCOUNT ON THE NEW DYNAVIN N6 UNITS!



LATEST DYNAVIN INFO: http://forum.e46fanatics.com/showthread.php?t=1044105
DYNAVIN FAQ:http://www.jandtdistributing.com/pages/faq-links
///AVIN INFO: http://forum.e46fanatics.com/showthread.php?t=1015704
TO BUY http://jandtdistributing.com
jeffb325@NavigationSolutions is offline   Reply With Quote
Old 08-31-2014, 08:47 PM   #5
GA_M3_2b
Registered User
 
Join Date: Jun 2014
Location: Lawrnceville GA
Posts: 14
My Ride: 2004 M3 JB Cinn Conv
In the trunk it is as simple as unplugging the antenna and the wire harness from the BMW business unit. For me I needed the AVIN spade connector end. Plug in the adapter, the AVIN wire harness and the AVIN antenna extension.

[IMG] photo e30f304d-524c-4f55-81b7-9446e291baec.jpg[/IMG]

Then run the AVIN harness and extension from the trunk to the dash. I routed mine along the drivers side.

[IMG] photo 6fd916ec-14c6-4e5f-ac19-d2c0736d7d1e.jpg[/IMG]

[IMG] photo IMG_1249.jpg[/IMG]

Once you get those 2 things to where the head unit is all you need to do is plug it in. Then power it up to make sure it's all good. Then button everything up and ENJOY.

Last edited by GA_M3_2b; 08-31-2014 at 08:53 PM.
GA_M3_2b is offline   Reply With Quote
Old 08-31-2014, 08:48 PM   #6
GA_M3_2b
Registered User
 
Join Date: Jun 2014
Location: Lawrnceville GA
Posts: 14
My Ride: 2004 M3 JB Cinn Conv
Quote:
Originally Posted by jeffb325@NavigationSolutions View Post
It's always an adventure when you start taking things apart and realize somebody has already been in there!


It was an ADVENTURE. I hate cases of "bad mechanic".
GA_M3_2b is offline   Reply With Quote
Old 09-01-2014, 09:32 AM   #7
Walter_
Registered User
 
Join Date: Mar 2014
Location: Antwerp, Belgium
Posts: 49
My Ride: 2004 325 SMG coupé
Nice work, did the unit came with the latest updates?
Walter_ is offline   Reply With Quote
Old 09-01-2014, 11:29 AM   #8
GA_M3_2b
Registered User
 
Join Date: Jun 2014
Location: Lawrnceville GA
Posts: 14
My Ride: 2004 M3 JB Cinn Conv
I am not a techie but as far I know it did. Tommy sent me an email saying it did when he thanked me for my purchase. I just need to learn how to use it now. ; )
GA_M3_2b is offline   Reply With Quote
Old 09-05-2014, 01:16 PM   #9
raichean
Registered User
 
Join Date: Feb 2013
Location: Maple Valley WA
Posts: 387
My Ride: 2004 e46 M3 cabrio
Ouch.. looks like you had to clean up someone else's mess too while doing the install. Great job though! I spun up an install guide for the Avin and rear camera as well if you need it, linked in my sig. 8)

Great job!
raichean is offline   Reply With Quote
Old 09-05-2014, 09:52 PM   #10
GA_M3_2b
Registered User
 
Join Date: Jun 2014
Location: Lawrnceville GA
Posts: 14
My Ride: 2004 M3 JB Cinn Conv
Quote:
Originally Posted by raichean View Post
Ouch.. looks like you had to clean up someone else's mess too while doing the install. Great job though! I spun up an install guide for the Avin and rear camera as well if you need it, linked in my sig. 8)

Great job!
Thank you. I purchased a mobile hotspot today for my car. We will see how that works out. But so far I'm loving it.
GA_M3_2b is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use