E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-27-2012, 05:12 PM   #1
swiss1
Registered User
 
Join Date: Aug 2012
Location: Tampabay
Posts: 4
My Ride: BMW
top wont go up

Hi all i am sorry i did not introduce myself propery yet but i have this E46 that drives me nuts . I am new to the forum and i live in the Tampabay .

Here is what happened ;

Ok friday here in Florida was a great day so naturally i had to get to work with the top down however arriving at work it was stuck Down!

Working on it all day saturday still i can not get it back up automatically.

The things i have done wrong :

Few weeks ago i used a coupe m3 cluster that had a functioning temp gauge , according to my friend it was wrong ,...as the cluster will give the switch power and controls functions .

Anyway i went and we reinstalled the old one .

These are the things i have done to it :

- Checked all fuses , under the dash
- No hydro leaks
- manually retracted the roof and reset the system , at this time all functions worked up and down just prior to completly lowering to the point wher it is completely stowed away. all worked except if i fully lowered the top it would not come back up.

It is just weird sometimes hall sensors do respond and sometimes they will not . Also noticed driving that the top light on the top switch came back on until i switched the ignition off and then back on.

The switch works everthing works until i fully lower and lock the top then it is stuck down .

I guess i start chasing broken wires next

Stumped ?! What am i missing is there another solenoid or simple switch fault?

Thanks for reading
swiss1 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-01-2012, 08:09 AM   #2
94583
Registered User
 
Join Date: Aug 2012
Location: San Francisco Bay Area
Posts: 35
My Ride: E39
Sounds like you may have some damaged wires. I would inspect All of the pivot points/hinges of the top on the drivers side. There are torx screws that hold plastic covers on. Remove the covers and I'm certain that you'll find wires holding on by one strand.

Good Luck!
94583 is offline   Reply With Quote
Old 09-01-2012, 09:18 AM   #3
swiss1
Registered User
 
Join Date: Aug 2012
Location: Tampabay
Posts: 4
My Ride: BMW
Thanks a bunch , and your are right ;
the first find was that the trunk wiring was crunched right side had 3 wires that made the trunk " dead Lock " the top After fixing that i went after the drivers side wiring in the top. Guess what you are right it has been fixed once and lousy exposed and badly insulated . Also when you look down the bottom hinch on the drivers side there are some cheap fixed points . Wiggling and messing with it it works again ! I will go after all the wires and repair them as good as i can . Until i find a new solution or good harness .Or order a new one.
The other question left is did the gauge cluster have something to do with BMW part numbers on coupes and verts are the same and it does not specify the any difference except the visual light on the dash any ideas ?

Again thanks i post some pictures regarding the new Improved wiring harness once i am done .
swiss1 is offline   Reply With Quote
Old 09-01-2012, 09:39 AM   #4
94583
Registered User
 
Join Date: Aug 2012
Location: San Francisco Bay Area
Posts: 35
My Ride: E39
Good find. In regards to your cluster. Instrument clusters on all BMW are not supposed to be interchanged, and actually in many states it is illegal due to mileage.

Clusters are coded VIN specific. In short your friend is correct. Clusters on E46's act as a hub for all CAN communications. So if the cluster is out of a hardtop, the top will not operate. You may also notice that on the M3 cluster there may be a red dot next to the odometer. That would be a manipulation dot indicating that the mileage does not match with DME and EWS.
Long story short, your M3 cluster is now a paper weight.
94583 is offline   Reply With Quote
Old 09-01-2012, 10:02 AM   #5
swiss1
Registered User
 
Join Date: Aug 2012
Location: Tampabay
Posts: 4
My Ride: BMW
Thanks , i guess i have one of the nicest paper weight in the area ,
the whole thing with the cluster started with the temp gauge not working and beeing for 100's of miles in the red . I know it is not not overheating as i have every update including metal waterpump etc . but would be a nice indication if something goes wrong ,...

The cluster did operate for about 4 weeks prior to the wires going bad guess there are only so many CAN messages or indications it can take and it will sooner or later INOP again

Thanks
swiss1 is offline   Reply With Quote
Old 09-01-2012, 10:09 AM   #6
swiss1
Registered User
 
Join Date: Aug 2012
Location: Tampabay
Posts: 4
My Ride: BMW
BTW i really appreciate the time you spend trying to help me , have a great weekend , and i found a harness and a bunch of other stuff i needed this morning they are a Bone Yard and New and Used partshouse for Euro cars only , giant yard packed with porsches beemers benzes if it is from europe it s most likely there looks like my new saturday morning hangout
swiss1 is offline   Reply With Quote
Old 09-02-2012, 09:48 AM   #7
94583
Registered User
 
Join Date: Aug 2012
Location: San Francisco Bay Area
Posts: 35
My Ride: E39
No problem! Hope you have it all figured out.
94583 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use