E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-24-2012, 12:52 PM   #1
navid9
Registered User
 
Join Date: Mar 2011
Location: Maryland
Posts: 3
My Ride: 00 328ci
Exclamation Batter light on, steering wheel stiff can't turn

hey guys,

i searched the forums, and saw the typical issues and things i should check but need a bit more help.

Yesterday i took out my rear speakers, and haven't placed the new ones in yet.
today while i was driving on the highway the batter-light came on and the steering-wheel got really stiff. i have been listening to music. the battery was changed a month ago. belts, voltage, and alternator is good. is there anything else i should be concerned about?

its a 2000 BMW 328ci 100k on it.

Thanks for all the help
navid9 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-24-2012, 01:09 PM   #2
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,940
My Ride: '94 325iC & '00 323i
You lost the main belt that drives the water pump, alternator, and power steering. You saw the alternator go south because the battery light came on -- really a Charging System Failure light -- and you felt the power steering go away because the steering got heavy. You completely missed the steam from under the hood and the red light that came on at the right hand end of the temp gauge.

COMPLETELY FORGET THE STUFF THAT WAS GOOD A MONTH AGO, open the hood and look at what isn't good today. You say the voltage is good, but that is not possible. Well, it is possible that it's good NOW, but it won't be good for long. Odds are good that the voltage will be good longer than the temps are managable. But the voltage will go away eventually if you can't get the charging system light to turn off.
jdstrickland is offline   Reply With Quote
Old 04-24-2012, 01:13 PM   #3
navid9
Registered User
 
Join Date: Mar 2011
Location: Maryland
Posts: 3
My Ride: 00 328ci
Yes, you are right i should look under the hood more often. i just did a another careful look it is a belt. firs look didn't find anything bc it was too dark and not enough light. The belt is ripped off. is there a specific name for the belt? i will go purchase today and have my friend come replace it, since he got the right tools.

i appreciate your help jdstrickland, and everyone else.
navid9 is offline   Reply With Quote
Old 04-24-2012, 01:14 PM   #4
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
your serpentine belt has snapped.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 04-24-2012, 01:15 PM   #5
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,781
My Ride: M54B30
See sig. Do it. Thank me later.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 04-24-2012, 04:06 PM   #6
Wolrab
Registered User
 
Join Date: Jan 2009
Location: Houston
Posts: 485
My Ride: 330Ci MT, 545i SMG
Send a message via Skype™ to Wolrab
You might want to see if you can identify why the belt failed - such as a frozen deflection pulley, maybe. No point putting a new belt on a bad pulley. Possible it was just old, but if it's 12 years / 100k miles old, there's a bunch of other stuff to change out, including pulleys. See the "Cooling System Guide" shortcut in Mango's post.
Wolrab is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use