E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-11-2011, 07:59 PM   #1
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,324
My Ride: BMW's
HPF Guys, what plugs are you running?

So.. i'm having issues with the car running a bit rich, carbon build up on the plugs and eventually leading to what I believe to be high resistence and spark/ignition issues after about 1500mi.

What plugs are you guys running? I'm running the NGK Racing plugs, rated at a 10 for coldness.

Is it possible the plugs are just to cold and I should be running the Denso Iridium's that the 2.75/other guys are running, or do I just need to have my tune adjusted?

Here is a plug after 250mi or so w/no meth/race gas.. and almost no boosting:



Here they are after about 1500mi with plenty of boosting, race gas, 91, meth, etc..



At the point the plugs get to where they look like the above the car begins to misfire (feels just like traction control) at about 4krpm.
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22


Last edited by MarcusLSB; 05-11-2011 at 08:01 PM.
MarcusLSB is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-11-2011, 08:03 PM   #2
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,324
My Ride: BMW's
They're NGK-R R2525-10's.. I'm wondering if R2525-9's wouldn't be better?
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote
Old 05-11-2011, 08:27 PM   #3
503Alex
Registered User
 
Join Date: Jul 2009
Location: Portland, Oregon
Posts: 83
My Ride: S30
We should get some other Stage 3 guys to pull theirs and show us what they look like.
__________________
503Alex is offline   Reply With Quote
Old 05-11-2011, 08:28 PM   #4
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,324
My Ride: BMW's
That would be incredibly helpful. I'm pretty sure I'm running rich though, at mid 12's at idle.
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote
Old 05-11-2011, 08:58 PM   #5
AirFrcd
Registered User
 
Join Date: Jan 2007
Location: Mexico
Posts: 954
My Ride: Mfizzle, and GT-R
I will have Aaron (my personal mechanic) pull one for you next week.
I am running the "stock" stage 3 plugs that HPF built the car with; zero issues.
__________________
I can do everything through Christ who gives me strength.
Philippians 4:13

AirFrcd is offline   Reply With Quote
Old 05-11-2011, 09:05 PM   #6
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,324
My Ride: BMW's
Quote:
Originally Posted by AirFrcd View Post
I will have Aaron (my personal mechanic) pull one for you next week.
I am running the "stock" stage 3 plugs that HPF built the car with; zero issues.
Sweet. You've got about the same miles on yours as I do on the one high res one I pictured above. Maybe you have a little more now.. but it would be a great comparison. I'm not sure if you can see the numbers on the plug indicating if its a R2525-10 or R2525-9 but that would be helpful as well. Unless you're running Denso's, or some other variant.
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote
Old 05-11-2011, 09:08 PM   #7
AirFrcd
Registered User
 
Join Date: Jan 2007
Location: Mexico
Posts: 954
My Ride: Mfizzle, and GT-R
Quote:
Originally Posted by MarcusLSB View Post
Sweet. You've got about the same miles on yours as I do on the one high res one I pictured above. Maybe you have a little more now.. but it would be a great comparison. I'm not sure if you can see the numbers on the plug indicating if its a R2525-10 or R2525-9 but that would be helpful as well. Unless you're running Denso's, or some other variant.

So true, lol.

Side note, are you coming to Bfest? You can ride shotgun with me in the M5.
I just got all my upgrades installed today, including the ESS software tune; WOW, what a BEAST she is now - seriously!!!! I am STOKED!
__________________
I can do everything through Christ who gives me strength.
Philippians 4:13


Last edited by AirFrcd; 05-11-2011 at 09:10 PM.
AirFrcd is offline   Reply With Quote
Old 05-11-2011, 09:18 PM   #8
faelar
Big Pimpin'
 
Join Date: Aug 2009
Location: Houston
Posts: 1,113
My Ride: M3
Quote:
Originally Posted by MarcusLSB View Post
At the point the plugs get to where they look like the above the car begins to misfire (feels just like traction control) at about 4krpm.
Something like this?

__________________
Billet PT6765, ProEFI, SAAD Racing, 805 WHP 692 WTQ


Quote:
Originally Posted by Saad@SaadRacing View Post
Chad's car is being taken care of and I can tell you when it comes back he and his car will be your worst f***ing nightmare.
faelar is offline   Reply With Quote
Old 05-11-2011, 09:20 PM   #9
TaZaM3
Psshhhht M3
 
Join Date: Dec 1969
Location: Cali
Posts: 5,940
My Ride: E46 M3
Ixu27's here and they work pretty well for me. Changed them once so far after I noticed a small stuttering issue. I actually tried those plugs you have and my car would not run well at all.
TaZaM3 is offline   Reply With Quote
Old 05-11-2011, 09:26 PM   #10
Evil Twin Rob
Registered User
 
Join Date: Aug 2007
Location: Spokane Wa.
Posts: 1,086
My Ride: 2004 M3
Not sure if the built motors take a different plug, but I was told to not use anything but Denso. I believe they tested the NGK and they just did not perform well. Of course, there is absolutely no place in my town that sells the Denso.
__________________
HPF 2.5
Evil Twin Rob is offline   Reply With Quote
Old 05-11-2011, 09:38 PM   #11
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,324
My Ride: BMW's
Quote:
Originally Posted by AirFrcd View Post

So true, lol.

Side note, are you coming to Bfest? You can ride shotgun with me in the M5.
I just got all my upgrades installed today, including the ESS software tune; WOW, what a BEAST she is now - seriously!!!! I am STOKED!
I wish I could but I have a photoshot with the car on Saturday and I might have to go to Boston friday night for a few hours. So I can't commit

Quote:
Originally Posted by faelar View Post
Something like this?

Identical issue. Pull your plugs.. check em out.. bet they look the same.

Quote:
Originally Posted by TaZaM3 View Post
Ixu27's here and they work pretty well for me. Changed them once so far after I noticed a small stuttering issue. I actually tried those plugs you have and my car would not run well at all.
Did you try the R2525-10's or 9's? Is 10 just to cold?

Quote:
Originally Posted by Evil Twin Rob View Post
Not sure if the built motors take a different plug, but I was told to not use anything but Denso. I believe they tested the NGK and they just did not perform well. Of course, there is absolutely no place in my town that sells the Denso.
Thats what I've seen all the 1-2.75 guys running.. maybe I should try those?
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote
Old 05-11-2011, 09:50 PM   #12
TaZaM3
Psshhhht M3
 
Join Date: Dec 1969
Location: Cali
Posts: 5,940
My Ride: E46 M3
Quote:
Originally Posted by MarcusLSB View Post


Did you try the R2525-10's or 9's? Is 10 just to cold?
I tried the 9's, no good for me. Don't play too much with plugs tho, they are sensitive. The ixu27's have been good to me, my car runs alittle rich as well. These cars love fuel! Btw, I wouldn't listen to people on other forums with no experience.
TaZaM3 is offline   Reply With Quote
Old 05-11-2011, 10:02 PM   #13
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,324
My Ride: BMW's
Quote:
Originally Posted by TaZaM3 View Post
I tried the 9's, no good for me. Don't play too much with plugs tho, they are sensitive. The ixu27's have been good to me, my car runs alittle rich as well. These cars love fuel! Btw, I wouldn't listen to people on other forums with no experience.
Jason has to have put a good 500-1000 miles on his car driving around the west coast. I wonder what he's running. Same w/MyTran.s
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote
Old 05-11-2011, 10:37 PM   #14
02black330ci
Registered User
 
Join Date: Mar 2005
Location: ^^ E46FANATICS ^^
Posts: 1,814
My Ride: spaceship
Quote:
Originally Posted by Evil Twin Rob View Post
Not sure if the built motors take a different plug, but I was told to not use anything but Denso. I believe they tested the NGK and they just did not perform well. Of course, there is absolutely no place in my town that sells the Denso.
Same here, Stage 2, I am running Denso Iridium IXU24. I had an issue breaking up, but mine was mainly under load at WOT. It turned out to be my stock coil packs, at the end of the day I just upgraded to the Okadas.

Looking at the video, symptoms are definitely not the same and you guys are good since Stage 3+ includes the Okadas. Also I am not putting nearly the same whp you guys are
__________________







Last edited by 02black330ci; 05-11-2011 at 10:38 PM.
02black330ci is offline   Reply With Quote
Old 05-11-2011, 10:43 PM   #15
dallasberry
Registered User
 
Join Date: Jul 2010
Location: Edmonton
Posts: 1,140
My Ride: ///M3
Quote:
Originally Posted by 02black330ci View Post
Also I am not putting nearly the same whp you guys are

You could
__________________
Custom Turbo Build By Lab22

Borgwarner S467/Custom Twinscroll Tubular Manifold/Lab22-Radium E85 Fuel System/Brembo
792whp @ 555wtq 15psi E98

dallasberry is offline   Reply With Quote
Old 05-11-2011, 10:50 PM   #16
02black330ci
Registered User
 
Join Date: Mar 2005
Location: ^^ E46FANATICS ^^
Posts: 1,814
My Ride: spaceship
Quote:
Originally Posted by dallasberry View Post
You could
LOL, agree, Stage 2.75 or 3 will be in my future, got other projects going on though
__________________






02black330ci is offline   Reply With Quote
Old 05-11-2011, 10:53 PM   #17
dallasberry
Registered User
 
Join Date: Jul 2010
Location: Edmonton
Posts: 1,140
My Ride: ///M3
Quote:
Originally Posted by 02black330ci View Post
LOL, agree, Stage 2.75 or 3 will be in my future, got other projects going on though
I know how you feel lol. Damn women
__________________
Custom Turbo Build By Lab22

Borgwarner S467/Custom Twinscroll Tubular Manifold/Lab22-Radium E85 Fuel System/Brembo
792whp @ 555wtq 15psi E98

dallasberry is offline   Reply With Quote
Old 05-11-2011, 11:12 PM   #18
leletyM3
Registered User
 
Join Date: Aug 2004
Location: Bay Area
Posts: 1,573
My Ride: 05 M3
Quote:
Originally Posted by AirFrcd View Post

So true, lol.

Side note, are you coming to Bfest? You can ride shotgun with me in the M5.
I just got all my upgrades installed today, including the ESS software tune; WOW, what a BEAST she is now - seriously!!!! I am STOKED!
Great to hear that you got more mods for the M5! Have you got the Eisenmann installed?

Mhhh taking the beast M5 instead of your monster M3? I think your M3 needs to stretch her legs


Marcus,

Yeah your car is running rich for sure....that is a lot of build up. My car idles at 14.2-14.6 afr which should be normal
__________________
05 BMW ///M3 SMG - Jet Black/Gray

HPF Stg2 Turbo 640rwhp, Eisenmann Race 83mmx4, Volk TE37 TA, Toyo T1R, Brembo BBK 380mm 6pots & 345, 6k HID, 6K HID Fogs, Depo Smoked Corners, Strassentech Front Lip, V-CSL Bootlid, V-CSL Diffuser


Last edited by leletyM3; 05-11-2011 at 11:14 PM.
leletyM3 is offline   Reply With Quote
Old 05-11-2011, 11:12 PM   #19
InDiGlOM3
Registered User
 
Join Date: Jan 2006
Location: Copperas Cove
Posts: 1,442
My Ride: HPF M3 stg 2.5
Send a message via AIM to InDiGlOM3 Send a message via Yahoo to InDiGlOM3
Ixu27's here, I tried the race plugs you had but they fouled up really fast.
__________________
InDiGlOM3 is online now   Reply With Quote
Old 05-11-2011, 11:16 PM   #20
TaZaM3
Psshhhht M3
 
Join Date: Dec 1969
Location: Cali
Posts: 5,940
My Ride: E46 M3
Quote:
Originally Posted by InDiGlOM3 View Post
Ixu27's here, I tried the race plugs you had but they fouled up really fast.
Exactly!
TaZaM3 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use