E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-20-2011, 08:41 PM   #1
Brandar
Registered User
 
Join Date: Jun 2011
Location: Bremerton, WA
Posts: 28
My Ride: 2000 323 ci
Brand New 328 Ci owner...... Need support.

Hello,

I am new to the BMW scene. I just purchased a 2000 328ci. This is a beautiful car, for being my first BMW. It has over 141,000 miles on it. I was wondering if there are some things I should have checked on it before I try to open her up and let her have fun. The CEL comes on and the Oil light turns on for about 30 seconds when I turn her on. Can anyone give me some support to keep her running strong and not ****ing her up?
Brandar is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-20-2011, 09:10 PM   #2
Brandar
Registered User
 
Join Date: Jun 2011
Location: Bremerton, WA
Posts: 28
My Ride: 2000 323 ci
Forgot the pics, here you go.
Attached Thumbnails
Click image for larger version

Name:	IMAG0311.jpg
Views:	54
Size:	125.4 KB
ID:	407029   Click image for larger version

Name:	IMAG0312.jpg
Views:	44
Size:	86.3 KB
ID:	407030   Click image for larger version

Name:	IMAG0313.jpg
Views:	45
Size:	81.4 KB
ID:	407031   Click image for larger version

Name:	IMAG0316.jpg
Views:	38
Size:	96.2 KB
ID:	407032  

Click image for larger version

Name:	IMAG0317.jpg
Views:	40
Size:	102.6 KB
ID:	407033   Click image for larger version

Name:	IMAG0318.jpg
Views:	37
Size:	86.4 KB
ID:	407034  
Brandar is offline   Reply With Quote
Old 06-20-2011, 10:10 PM   #3
Brandar
Registered User
 
Join Date: Jun 2011
Location: Bremerton, WA
Posts: 28
My Ride: 2000 323 ci
I feel Epically Retarded, I have a 2000 323ci, not a 328ci....I apologize for looking like a complete ass.
Brandar is offline   Reply With Quote
Old 06-21-2011, 08:56 AM   #4
CylonRed
Registered User
 
Join Date: Jun 2010
Location: SW Ohio
Posts: 784
My Ride: '01 E46 330i sport
This would be the best place to look, search and ask: http://forum.e46fanatics.com/forumdisplay.php?f=4
CylonRed is offline   Reply With Quote
Old 06-21-2011, 12:53 PM   #5
Bimmer>All
Registered User
 
Join Date: Jan 2011
Location: Atlanta, Georgia
Posts: 199
My Ride: 2004 325ci
Just wondering, I like the woodgrain, Is that shifter knob OEM? And congrats and welcome. As for the lights coming on.... when the accessory is turned on and not the engine all of the lights come on, not sure if that's what you mean.
__________________
2004 325ci ZSP
Bimmer>All is offline   Reply With Quote
Old 06-21-2011, 12:55 PM   #6
Handsome Kev
Registered User
 
Join Date: Oct 2007
Location: NoVa
Posts: 238
My Ride: 328
If you yellow oil light stays on for about 30 seconds. It is your oil level sensor. Its a real easy diy that you can do with your next oil change

Sent from my T-Mobile G2 using Bimmer App
Handsome Kev is online now   Reply With Quote
Old 06-21-2011, 01:16 PM   #7
cyclists5er
Account Under Review
 
Join Date: Aug 2009
Location: Alhambra CA
Posts: 17
My Ride: 80' 320i
the best thing to do to rid yourself of the light is to replace the oil level sensor. good luck and welcome to the forum!
cyclists5er is offline   Reply With Quote
Old 06-22-2011, 12:00 AM   #8
Brandar
Registered User
 
Join Date: Jun 2011
Location: Bremerton, WA
Posts: 28
My Ride: 2000 323 ci
The Shifter Knob is stock. I dont have much knowledge on the parts yet so I am not sure if it is OEM or not. And I will be getting the Oil Changed very soon so hopefully that gets everything fixed.
Brandar is offline   Reply With Quote
Old 06-22-2011, 02:00 AM   #9
rg1bmw
Registered User
 
Join Date: Aug 2006
Location: USA
Posts: 1,464
My Ride: 2002 Infiniti Q45
Welcome
__________________

2002 BMW 530i

Black Leather/5 Speed/Sport Package
rg1bmw is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use