E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 13 votes, 5.00 average. Display Modes
Old 09-05-2011, 12:29 PM   #21
Swish
Registered User
 
Join Date: Apr 2005
Location: NorCal
Posts: 285
My Ride: 2004 M3 Vert
Is there any way you can do a full DIY write up of this (to include detailed pics for us electronic illiterate people) and tell us where we can get the parts from for this (including part numbers)? Would really appreciate... Thanks for the info so far!
__________________

"If you want to move past racism, you have to STOP LABELING EVERYTHING BY RACE / 2000_328CI"
Swish is offline   Reply With Quote
Old 09-09-2011, 01:09 AM   #22
phoenixbmw
Registered User
 
Join Date: Aug 2011
Location: Phoenix
Posts: 2
My Ride: Phoenix
What was the wattage resistor you used? Where did you get it?
phoenixbmw is offline   Reply With Quote
Old 09-09-2011, 05:05 PM   #23
shinbo
Registered User
 
Join Date: Sep 2008
Location: Philly
Posts: 16
My Ride: 03 M3
Quote:
Originally Posted by Swish View Post
Is there any way you can do a full DIY write up of this (to include detailed pics for us electronic illiterate people) and tell us where we can get the parts from for this (including part numbers)? Would really appreciate... Thanks for the info so far!
Agreed, detailed DIY Please for this electrical noob. Maybe also a place to purchase high quality heat resistant resistors.

THANKS, so close to a fix.
shinbo is offline   Reply With Quote
Old 09-17-2011, 11:24 PM   #24
wa6lie
Registered User
 
Join Date: Mar 2011
Location: Salinas, Ca.
Posts: 10
My Ride: '04 M3 Carbon Black
Quote:
Originally Posted by 03DinanS2 View Post
There are many many issues that can arise with the SMG/SMGII. This thread is aimed at one specific, common issue that leaves many SMG owners timid to drive on hot days.

Here are the symptoms:

On hot days with little air flow through the engine bay IE traffic situations, the SMG and SES light illuminate and soon after, the gears drop out into 0 or nuetral. Very dangerous situation at times and for many is guaranteed to happen daily while others only happens a couple times a year.


EDIT:
CNTRVSY's Thread on M3F: http://www.m3forum.net/m3forum/showthread.php?t=372262
Hello All...

I have a '04 M3 with a SMGII.
Bought with 90K on it and runs great!
Take it to the track quite often and run the snot out of it!

I had this over heating issue as described. (never on the track though..)
When it happened to me it was 92 degrees outside and got stuck in stop and no go traffic. My SMG warning cog came on, but all was still running normally. Once cooled down I was not sweating it as much on a mountain pass. Also, the service engine soon light was on (normal with SMG failures) I pulled off to take a break for 10 minutes. All was Normal, no warning lights. Had a feeling it was a temp sensor causing the failure, and guess I was right by reading this thread! I will have to try the 500 to 1,000 OHM resistor trick. Have many laying around. (not 3,300 or 3.3K OHM) as in another reply to this thread.

Here is my additional SMGII problem nobody seems to know about how to solve.
Cold or intermittent problems.
On 2 occasions now when cold I got the SMG cog. I had to turn off, wait 5 seconds or so and try again. I have had to do this several times!
You MUST turn OFF the ignition and WAIT 5 seconds or more after the dashboard goes dead before attempting to start the engine. Really sucks when you successfully back up, then you can't shift to first gear! Have to sit there and turn off the engine and reset the computer to see if it will now engage in gear.
I do have to take my shoes off to count how many SMG failures I have had in the past 3 months! The mechanical side of everything is just fine! Damn computers!

Any ideas on what the problem is?
I am thinking electrical issue or sensor going bad.
Maybe the Salmon colored relay??
Need to get the fault codes to see what the computer says it is, but I have no reader for this.

Thanks in advance...

Scott
Salinas, Ca.
'04 E46 M3 Carbon Black SMGII
wa6lie is offline   Reply With Quote
Old 09-18-2011, 01:10 PM   #25
cntrvrsy
Registered User
 
Join Date: Feb 2006
Location: NY
Posts: 439
My Ride: ///M3
^^ What does the gear indicator display show when your car is acting up where you have to shut it off for 5 mins? Example, when you back the car up and try to select 1st gear, does the display show 1st or is it still in R? I would try the salmon colored relay first and see if that fixes the gear change issue. If it doesn't, then you'll have to try and find a shop or local member that can read out the SMG codes for you.
__________________
cntrvrsy is offline   Reply With Quote
Old 09-18-2011, 02:25 PM   #26
wa6lie
Registered User
 
Join Date: Mar 2011
Location: Salinas, Ca.
Posts: 10
My Ride: '04 M3 Carbon Black
Quote:
Originally Posted by cntrvrsy View Post
^^ What does the gear indicator display show when your car is acting up where you have to shut it off for 5 mins? Example, when you back the car up and try to select 1st gear, does the display show 1st or is it still in R? I would try the salmon colored relay first and see if that fixes the gear change issue. If it doesn't, then you'll have to try and find a shop or local member that can read out the SMG codes for you.
The gear indicator will flash N and not go into R or 1.

I am not into replacing stuff until I find the right part. That is why I posted here first.

Thank you for your reply!

Scott
wa6lie is offline   Reply With Quote
Old 09-24-2011, 10:01 AM   #27
Jeffspayne
Registered User
 
Join Date: Sep 2011
Location: Puyallup, WA
Posts: 1
My Ride: 02 M3 SMG
Thank you so much for this fix! All good so far...now my wife can drive the car again without being stuck in the middle of an intersection in nuetral!
Jeffspayne is offline   Reply With Quote
Old 09-27-2011, 02:24 PM   #28
Rudymontana
Registered User
 
Join Date: Sep 2011
Location: London
Posts: 11
My Ride: E46 M3
Light came back on today and it came out of gear about 5 times on the way home it's been just under 3 weeks since I changed salmon relay I've heard they go quite a bit but could it of gone this quick thanks.
Rudymontana is offline   Reply With Quote
Old 09-27-2011, 02:38 PM   #29
BLACKED-OUTM3
Registered User
 
Join Date: Sep 2011
Location: PASADENA, MD
Posts: 43
My Ride: 2005 M3 VERT
nice thread
__________________
2005 ///M3 vert...SMG with all options....



MPACTEAST.COM<---click here
BMW and Exotic Car Festival
Camden Yards Sports Complex
9/14/2013




BLACKED-OUTM3 is offline   Reply With Quote
Old 10-23-2011, 07:43 PM   #30
03DinanS2
Registered User
 
Join Date: Jun 2011
Location: Florida
Posts: 30
My Ride: 2003 M3 Dinan Stage4
Quote:
Originally Posted by Rudymontana View Post
Light came back on today and it came out of gear about 5 times on the way home it's been just under 3 weeks since I changed salmon relay I've heard they go quite a bit but could it of gone this quick thanks.
The salmon relay is a mythical fix for alot of SMG issues. Too good to be true? YES!! (most of the time
__________________


2003 Dinan Stage4, 1996 Maxima GLE 3.0, 1999 F-350 Dually 7.3, 2004 VTX1300, 2008 CBR1000RR, 2004 CBR1000RR

Last edited by 03DinanS2; 10-23-2011 at 07:55 PM.
03DinanS2 is offline   Reply With Quote
Old 10-23-2011, 07:54 PM   #31
03DinanS2
Registered User
 
Join Date: Jun 2011
Location: Florida
Posts: 30
My Ride: 2003 M3 Dinan Stage4
Quote:
Originally Posted by wa6lie View Post
Hello All...

I have a '04 M3 with a SMGII.
Bought with 90K on it and runs great!
Take it to the track quite often and run the snot out of it!

I had this over heating issue as described. (never on the track though..)
When it happened to me it was 92 degrees outside and got stuck in stop and no go traffic. My SMG warning cog came on, but all was still running normally. Once cooled down I was not sweating it as much on a mountain pass. Also, the service engine soon light was on (normal with SMG failures) I pulled off to take a break for 10 minutes. All was Normal, no warning lights. Had a feeling it was a temp sensor causing the failure, and guess I was right by reading this thread! I will have to try the 500 to 1,000 OHM resistor trick. Have many laying around. (not 3,300 or 3.3K OHM) as in another reply to this thread.

Here is my additional SMGII problem nobody seems to know about how to solve.
Cold or intermittent problems.
On 2 occasions now when cold I got the SMG cog. I had to turn off, wait 5 seconds or so and try again. I have had to do this several times!
You MUST turn OFF the ignition and WAIT 5 seconds or more after the dashboard goes dead before attempting to start the engine. Really sucks when you successfully back up, then you can't shift to first gear! Have to sit there and turn off the engine and reset the computer to see if it will now engage in gear.
I do have to take my shoes off to count how many SMG failures I have had in the past 3 months! The mechanical side of everything is just fine! Damn computers!

Any ideas on what the problem is?
I am thinking electrical issue or sensor going bad.
Maybe the Salmon colored relay??
Need to get the fault codes to see what the computer says it is, but I have no reader for this.

Thanks in advance...

Scott
Salinas, Ca.
'04 E46 M3 Carbon Black SMGII
Scott,

Sounds like your accumulator sometimes doesn’t charge. The salmon relay i the "link" for that engagement. I'd try that definitely. Especially if it intermittent. That how relays typically fail. Also, make sure your car had the relay bulletin done by BMW.
__________________


2003 Dinan Stage4, 1996 Maxima GLE 3.0, 1999 F-350 Dually 7.3, 2004 VTX1300, 2008 CBR1000RR, 2004 CBR1000RR
03DinanS2 is offline   Reply With Quote
Old 01-17-2012, 06:37 PM   #32
xsxpxhx
Registered User
 
Join Date: Feb 2008
Location: Los Angeles, CA
Posts: 254
My Ride: 2002 M3
has anyone new done this mod?
xsxpxhx is offline   Reply With Quote
Old 01-18-2012, 01:07 AM   #33
zShowtimez
Registered User
 
Join Date: Nov 2011
Location: Los Angeles
Posts: 22
My Ride: BMW M3 E46
i love you , i thought this was going to be a pricey fix up, im too scared to play with wires i dont really have a delicate touch so ima let a good friend do this for me hopefully it works thanks alot we will you tube it to save some trouble for future users
zShowtimez is offline   Reply With Quote
Old 01-18-2012, 06:52 AM   #34
zac5
Registered User
 
Join Date: Jun 2010
Location: Beijing, China
Posts: 60
My Ride: Turbo M3
I did it around 500 miles ago, and the smg warning light has gone for good...not for good maybe, but so far so good. I can finally enjoy the bright side of smg. xp
zac5 is offline   Reply With Quote
Old 01-18-2012, 07:45 AM   #35
travisn
Registered User
 
Join Date: Jul 2008
Location: RIT, CCA# 455278
Posts: 206
My Ride: 01 325i
Has anyone considered putting a heat shield and/or heat reflective tape around the sensor? You'd be amazed at what a little air gap can do...
travisn is offline   Reply With Quote
Old 04-04-2012, 10:16 AM   #36
ChristopherCosmo
Registered User
 
Join Date: Apr 2012
Location: Tampa, FL
Posts: 1
My Ride: 2005 M3 Conv.
can anyone clarify the resistors exact wattage and resistance?
ChristopherCosmo is offline   Reply With Quote
Old 05-12-2012, 11:01 PM   #37
kevro
Registered User
 
Join Date: Jan 2009
Location: Tempe, Az
Posts: 138
My Ride: e36,e36,325it.
in an effort to thank the e46 fanatics community (and because I was gonna have to pay $10 to ship these $1 items) I bought several of these. PM me and I will simply send you one. Free. No strings. If this fixes my m3 it will be the first time I have been able to fix any issues on this car for less than $300. So hit me up, I got 10 to give.
Kevin
910 Ohm 10W Resistor Wire Wound 5% Tolerance
Part Number: 016-910
kevro is offline   Reply With Quote
Old 05-13-2012, 10:01 AM   #38
98BellaM3
Registered User
 
Join Date: May 2012
Location: Dallas
Posts: 3
My Ride: E36 M3 Sedan
All of this "good news" is prompting me closer and closer to buying that car I've got my eye on...its absolutely beautiful but I'm hyper-sensitive right now about dumping the $22k to bring it home due to all the issue with SMG...is $22k a fair price for an '05 w/ 71k miles, SMG or should I price seller down??
98BellaM3 is offline   Reply With Quote
Old 05-13-2012, 12:26 PM   #39
illestminimike
Registered User
 
Join Date: Jan 2012
Location: West Covina CA
Posts: 4,038
My Ride: Project Drama
Definitely bring him down at least to $20k
__________________
-2005 SMG ZCP Coupe
-1967 Mini Cooper
illestminimike is offline   Reply With Quote
Old 05-24-2012, 08:52 AM   #40
bmw809
Registered User
 
Join Date: Feb 2012
Location: Miami, FL
Posts: 73
My Ride: 04 M3 Vert
Quote:
Originally Posted by 98BellaM3 View Post
All of this "good news" is prompting me closer and closer to buying that car I've got my eye on...its absolutely beautiful but I'm hyper-sensitive right now about dumping the $22k to bring it home due to all the issue with SMG...is $22k a fair price for an '05 w/ 71k miles, SMG or should I price seller down??

I recently paid 21K (before taxes) for an 04 M3 / Vert / SMG w/ 61K on it. No navi
bmw809 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use