E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-13-2011, 02:49 AM   #1
qetadgzcb
Registered User
 
Join Date: Jul 2011
Location: Dubai
Posts: 1
My Ride: '03 E46 325i
Opinions on weird A/C problem (Mechanic fraud possible?)(very long & detailed post)

Hi everyone,

I'm driving a 2003 325i which I had fallen in love with the moment I saw the car 4months ago but after all the problems it has caused me now makes me feel sad even when I look at her..

There's one specific issue I'm facing with my A/C which is driving me mental.. I'll be providing as much detail as possible and will be looking forward to all the opinions as I need to understand was I being ripped off by my current mechanic.

All of a sudden my A/C stopped cooling properly around 2months back.. Now we're in an environment where during the day it's around 40-45 degrees Celsius and around 35 degrees Celsius at night. So when there's even a slight change in A/C performance you feel it right away. Anyway I avoided it for about a week when things started getting crazy. The temperature of air left two vents blow were noticeably lower compared to my 2 right vents. Basically 2 right vents were blowing air around 4-6degrees higher than the right 2 vents. This in no time turned into right 2 vents blowing 40 degrees Celsius hot air whereas my right 2 vents were blowing around 25 (while A/C was set to 16). (Btw the car the climate control, not the basic A/C).

Time to take a trip to my mechanic. So they hook up the AutoLogic and AUC sensor & Solar Sensor produced errors. So they changed these 2 parts but the problem was not solved. At every change they drain and re-fill the A/C gas btw. The car would blow acceptable air for half a day or 2 maybe (but the temperature difference was always there) then get worse again. Then they tried replacing the Final Stage Unit and pressure switch but the results were same. In the meantime they also did a couple of pressure tests and confirmed that there was no leak at all (they had a manual machine for these tests not the automatic one). They also said they checked the drainage water and it was clear not milky pointing out that there isn't a leak whatsoever from the evaporator. During further investigation, they noticed that the condenser fan (I think a.k.a. auxiliary fan) would sometimes work and sometimes just stay still. Couple of tries re-starting the engine and observing and yes, the fan sometimes started running and sometimes it just didn't and after a while it would or it would stay the same for 20mins. They decided to change that as well. They were pretty sure my problem would be solved after this. But no, still my A/C would run on it's free will.. They told me that changing the expansion valve and A/C receiver/drier canister would solve the problem once and for all now. But having been told every single time that "yes this will solve the problem" but never really solving it I have had enough.

Decided to take it to another mechanic finally. Told him the whole story and what he did was he took a look at the evaporator using those fancy spy cam kind of thing as there's no other way he can reach that place. And wow, there was fungus growth on my evaporator and he said it was leaking. He had the automatic machine for testing the A/C and when he drained the gas we saw that I was missing 400gr gas. Also he pulled out quite a lot of water from the system blaming the other mechanic's manual machine which could have caused this. Anyway he's pretty certain (but I just can't decide on what to believe after my past experiences) that once he replaces the evaporator along with the expansion valve and cabin microfilter my A/C will be back to normal. He also showed the drainage water from my car which was milky and what he got from a car next to mine which was clear. It's I think kind of impossible for the other garage mechanics to not notice this as they told me it was fine. This new mechanic is guessing that they re-did a couple of times the pressure tests which could have enlarged the leak on the evaporator and it's clearly visible now.

Now let me tell you what's the final situation with my A/C.

After I got my car from the second mechanic (btw, he had drained all the water from the system and re-filled the gas to full) the temperature difference from vents were nearly none. As I got the car running it was working fine. I parked the car outdoors (but under shade) and started again after a few hours when the external temperature was showing 43 degrees Celsius. For 4 minutes the 2 left vents blew normal-warm air whereas 2 right vents blew extremely hot air. From the 4th minute I started getting slightly colder air from the 2 left vents but 2 right vents were still burning hot. 3 more minutes on top of that and the left 2 vents were blowing freezing cold air and right 2 were very very close to that. I drove for around an hour and 3 times the air from 2 left vents became warmer (maybe around 25) and 2 right vents hot (maybe around 35) for maybe 2-3 minutes and then went back to normal again.

This morning when I first started the car (car was parked in underground parking for the night) external temperature was around 37 degrees Celsius for the first 2 minutes I had quite an ok air blowing (around 25 degrees maybe) and right at the end of the 2minutes it was freezing cold again. I drove for around 25minutes and it wall all the same no changes this time.

Now this evening when I leave the office I'm going to record the situation again and post it here as an update but in the meantime;

- Can my solar sensor, AUC sensor, final stage unit, pressure switch and condenser fan been changed for no reason. According to this second mechanic even if you completely remove the AUC sensor and solar sensor and throw them away the A/C would still work fine if rest of the system doesn't have any problems. He also thinks that the condenser fan might not have been working properly due to the gas pressure fluctuations (though when we noticed the fan wasn't working properly they'd just refilled the gas). What are the opinions on these?

I'm going to have a word with the old mechanic as I still haven't paid him quite lots of money on all these A/C repairs and I just want to make sure before I go harsh on him about not paying for any of the unnecessary replacements and their labor charges.

I'll really appreciate all the help in advance!

Cheers!!
qetadgzcb is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-13-2011, 07:13 AM   #2
Sansho
OEM ///Member
 
Sansho's Avatar
 
Join Date: Jun 2010
Location: CT
Posts: 1,814
My Ride: 2001 325i
See if this discussion will provide some information: http://www.e46fanatics.com/forum/sho...d.php?t=575316
__________________
.
Sansho is offline   Reply With Quote
Old 07-13-2011, 12:03 PM   #3
AJV
Registered User
 
Join Date: Oct 2010
Location: Cincinnati, Ohio
Posts: 245
My Ride: 164 Quadrifoglio
The evaporator costs a foolish amount to replace due to it's location. I'm having repeated issues with the AC in my car (likely evaporator) and if it goes out again the car's getting put on Craigslist. A steptronic 325i is a nice car, but it's not fast/fun enough to warrant spending thousands to have the stupid air conditioner fixed. I do know that a lot of people seem to advocate changing the majority of the system when it gets crappy like ours are, so you've got a head start if it is the evaporator. I know you are in one of the hottest places in the world and air conditioning is a must-have, but just weigh the cost/benefit of fixing the car versus selling it and getting one that doesn't have the same issue. I hope all turns out well for you!
__________________
AJV is offline   Reply With Quote
Old 07-13-2011, 12:22 PM   #4
elanlyfestyle
Registered User
 
Join Date: Apr 2009
Location: Hyattsville Md
Posts: 346
My Ride: 03 325ci
vacum leak????causing the vents to open/close on one side and not the other and creating excess condensation within the system???
elanlyfestyle is offline   Reply With Quote
Old 07-13-2011, 05:02 PM   #5
dirsh
Hawaii 3.0
 
dirsh's Avatar
 
Join Date: Aug 2005
Location: Hawaii
Posts: 5,380
My Ride: sanbyaku sanjuu
wtf it sounds like the first mechanic was replacing random things
I don't even know what the solar or AUC sensors do, but I do know the final stage resistor has nothing to do with the a/c being hot or cold. It controls the blower fan speed. Once the right side vents start blowing warmer, you know you are low on refrigerant and may have a leak. If you put some dye in the system and no leaks are visible on any lines, the evaporator is mot likely the problem. My evap failed twice, so I know
__________________

Quote:
Hello dirsh it appears that you have not posted on our forums in several weeks, why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums?
dirsh is offline   Reply With Quote
Old 07-13-2011, 05:32 PM   #6
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
Quote:
Originally Posted by dirsh View Post
wtf it sounds like the first mechanic was replacing random things
I don't even know what the solar or AUC sensors do, but I do know the final stage resistor has nothing to do with the a/c being hot or cold. It controls the blower fan speed. Once the right side vents start blowing warmer, you know you are low on refrigerant and may have a leak. If you put some dye in the system and no leaks are visible on any lines, the evaporator is mot likely the problem. My evap failed twice, so I know
AUC WOULD NOT DO ANYTHING FOR AC. Solar sensor could cause ac issues.

Final stage again as long as the blower is working has nothing to do with it.

Sounds more like an incompetent mechanic than fraud
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use