E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-17-2011, 09:25 AM   #1
E46_330i_Stud
Registered User
 
Join Date: May 2010
Location: Wake Forest, NC
Posts: 1,888
My Ride: 2004 330ci ZHP 6MT
Need opinions! P0171 Code only. 281E on Peake tool.

Just some background, my CEL stays on because of my headers so every 2 weeks or so I hook up my scanner to make sure those are the only 2 codes. Last week I put my stock intake back on and a few other things cosmetic related. While I was in there I noticed the VCG has a tiny, tiny leak. When I ran the codes I got the normal 2 codes as well as a P0171 (lean bank 1). Hooked up my peake tool and got a table 20 code, 281E (air intake system:activation). I cleared the codes and it came back. I figured it was the leaky valve cover gasket, so last night I replaced that as well as my thermostat because it was randomly sticking open. No luck. The intake boots are fairly new and no cracks. Disa valve is fairly new but I suppose it could be the gasket leaking. I can hearing a sucking noise like a vacuum leak coming from near the and/or under it. I am stumped because it is only lean on 1 bank and not both. Any opinions or experience with this?
__________________


1995 325i 5mt ArcticGrey/Dove - SOLD
2004 330ci ZHP 6MT SilberGrau/Black - SOLD
2001 330i M-Sport 5MT StaulGrau/Grey - SOLD
1992 Accord LX Sedan 275k miles all original - DAILY
2002 Chevy Suburban LT Autoride - TOY HAULER
2005 GMC Sierra 2500HD SLT - RACE TRUCK!
E46_330i_Stud is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-17-2011, 09:47 AM   #2
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
It's not uncommon for a minor vac leak to trigger a code on only one bank. The sensor readings are never 100% identical in both banks, thus if you're just barely running lean enough for it trigger a code, one bank can reach that threshold before the other. Once it gets a little worse, it will trigger both banks.

However, it's also possible to have a leak at an injector o-ring, clogged injector, failing O2 sensor, etc that is truly causing it to be lean in only one bank. This is far less likely though than simply having a very minor leak somewhere in the intake tract (such as around the DISA where you think you might hear a leak).
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 11-17-2011, 09:50 AM   #3
E46_330i_Stud
Registered User
 
Join Date: May 2010
Location: Wake Forest, NC
Posts: 1,888
My Ride: 2004 330ci ZHP 6MT
Thanks! Yea it makes sense that it's a minor leak because I have no symptoms. It idles fine when cold and runs 100%. I'm going to pull the disa and reseal it

Edit: to test my O2 sensor I can just swap them at the connector, clear codes and see if it swaps to bank 2 correct? Or do I have to physically swap the whole sensor?
__________________


1995 325i 5mt ArcticGrey/Dove - SOLD
2004 330ci ZHP 6MT SilberGrau/Black - SOLD
2001 330i M-Sport 5MT StaulGrau/Grey - SOLD
1992 Accord LX Sedan 275k miles all original - DAILY
2002 Chevy Suburban LT Autoride - TOY HAULER
2005 GMC Sierra 2500HD SLT - RACE TRUCK!

Last edited by E46_330i_Stud; 11-17-2011 at 10:00 AM.
E46_330i_Stud is offline   Reply With Quote
Old 11-17-2011, 10:37 AM   #4
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
No, swapping O2 connectors will cause all kinds of problems (reference the countless posts around here of people doing this by accident when installing headers). I wouldn't worry about the O2s until you exhaust all other possibilities. Intake leak is still your most likely culprit.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 11-17-2011, 10:47 AM   #5
E46_330i_Stud
Registered User
 
Join Date: May 2010
Location: Wake Forest, NC
Posts: 1,888
My Ride: 2004 330ci ZHP 6MT
Quote:
Originally Posted by TxZHP04 View Post
No, swapping O2 connectors will cause all kinds of problems (reference the countless posts around here of people doing this by accident when installing headers). I wouldn't worry about the O2s until you exhaust all other possibilities. Intake leak is still your most likely culprit.
True, I knew I couldn't because I did that when I did headers. Just forgot lol. I will pull it apart this weekend.
__________________


1995 325i 5mt ArcticGrey/Dove - SOLD
2004 330ci ZHP 6MT SilberGrau/Black - SOLD
2001 330i M-Sport 5MT StaulGrau/Grey - SOLD
1992 Accord LX Sedan 275k miles all original - DAILY
2002 Chevy Suburban LT Autoride - TOY HAULER
2005 GMC Sierra 2500HD SLT - RACE TRUCK!
E46_330i_Stud is offline   Reply With Quote
Old 11-17-2011, 12:40 PM   #6
E46_330i_Stud
Registered User
 
Join Date: May 2010
Location: Wake Forest, NC
Posts: 1,888
My Ride: 2004 330ci ZHP 6MT
Update: I found on Endtuning.com that their definition of the 281E is "Disa Intake System Output Stage". Failing disa or is this referring to the leak?
__________________


1995 325i 5mt ArcticGrey/Dove - SOLD
2004 330ci ZHP 6MT SilberGrau/Black - SOLD
2001 330i M-Sport 5MT StaulGrau/Grey - SOLD
1992 Accord LX Sedan 275k miles all original - DAILY
2002 Chevy Suburban LT Autoride - TOY HAULER
2005 GMC Sierra 2500HD SLT - RACE TRUCK!
E46_330i_Stud is offline   Reply With Quote
Old 11-25-2011, 05:48 PM   #7
E46_330i_Stud
Registered User
 
Join Date: May 2010
Location: Wake Forest, NC
Posts: 1,888
My Ride: 2004 330ci ZHP 6MT
Fixed! Disa gasket was the culprit. Hope this thread helps anyone out in the future!
__________________


1995 325i 5mt ArcticGrey/Dove - SOLD
2004 330ci ZHP 6MT SilberGrau/Black - SOLD
2001 330i M-Sport 5MT StaulGrau/Grey - SOLD
1992 Accord LX Sedan 275k miles all original - DAILY
2002 Chevy Suburban LT Autoride - TOY HAULER
2005 GMC Sierra 2500HD SLT - RACE TRUCK!
E46_330i_Stud is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use