E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-27-2011, 10:26 PM   #1
silver 330zhp
Registered User
 
Join Date: Oct 2010
Location: Indiana
Posts: 6
My Ride: 2003 330 ZHP
Need advice -- engine light

Hi guys, So I recently bought back my old 330i ZHP... the car now has AA headers and full exhaust, dinan intake, and AA software, along with a few other things. The car has a "service engine" light on now... The code is for a cylinder 3 misfire and I am trying to figure out the source of the problem. I just replace all the plugs and that didnt really help... I dont know if it is electrical or fuel related... any input will be appreciated !
silver 330zhp is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-27-2011, 10:41 PM   #2
LivesNearCostco
Registered User
 
Join Date: Jan 2010
Location: Silicon Valley
Posts: 767
My Ride: 2003 ZHP 6MT
You could try swapping the cylinder 3 coilpack with another to see if the misfire moves. If yes, probably one bad coilpack. I'm assuming you cleared the misfire code after replacing the plugs and the same code came back, right?
__________________
Lowering my car's resale value one track day at a time...
LivesNearCostco is offline   Reply With Quote
Old 11-27-2011, 11:45 PM   #3
silver 330zhp
Registered User
 
Join Date: Oct 2010
Location: Indiana
Posts: 6
My Ride: 2003 330 ZHP
Quote:
Originally Posted by LivesNearCostco View Post
You could try swapping the cylinder 3 coilpack with another to see if the misfire moves. If yes, probably one bad coilpack. I'm assuming you cleared the misfire code after replacing the plugs and the same code came back, right?
Yes I reset the code but i havent re checked to make sure its the same one... I will try the coilpack and see if that is the problem, thanks for the help
silver 330zhp is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use