E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 4 votes, 5.00 average. Display Modes
Old 05-10-2013, 10:07 PM   #761
Sound Performance
Past Site Sponsor
 
Join Date: Feb 2011
Location: Well, Dick, here's the deal: I'm the best there is, plain and simple. I mean, I wake up in the morning and I piss excellence. You know, nobody can hang with my stuff.
Posts: 565
My Ride: Is very FAST
Its not like we are not trying guys! The tune is done, it just needs the vanos to work! I spent the entire day in the er with my mom today

Sent from my XT901 using Bimmer App
Sound Performance is offline   Reply With Quote
Old 05-10-2013, 10:40 PM   #762
E85head
Registered User
 
Join Date: Jun 2012
Location: Car
Posts: 178
My Ride: E46 M3
Quote:
Originally Posted by Sound Performance View Post
Its not like we are not trying guys! The tune is done, it just needs the vanos to work! I spent the entire day in the er with my mom today

Sent from my XT901 using Bimmer App
Reach out, use the forum. Maybe someone here can help.
E85head is offline   Reply With Quote
Old 05-10-2013, 10:50 PM   #763
Sound Performance
Past Site Sponsor
 
Join Date: Feb 2011
Location: Well, Dick, here's the deal: I'm the best there is, plain and simple. I mean, I wake up in the morning and I piss excellence. You know, nobody can hang with my stuff.
Posts: 565
My Ride: Is very FAST
If the bmw tech cant help, we will! Strange thing is the first time we put it together it was fine, now we keep getting too advanced or retarded errors

Sent from my XT901 using Bimmer App
Sound Performance is offline   Reply With Quote
Old 05-10-2013, 11:33 PM   #764
Commanderwiggin
Registered User
 
Join Date: Jun 2010
Location: Calgary, Canada
Posts: 3,870
My Ride: 900rwhp Turbo M3
Quote:
Originally Posted by Sound Performance View Post
If the bmw tech cant help, we will! Strange thing is the first time we put it together it was fine, now we keep getting too advanced or retarded errors

Sent from my XT901 using Bimmer App
I hope you get this figured out ASAP...my confidence is dwindling and I wish it wasn't.

And Tom deserves a 1000+rwhp Beast!
__________________

Last edited by Commanderwiggin; 05-10-2013 at 11:33 PM.
Commanderwiggin is offline   Reply With Quote
Old 05-10-2013, 11:48 PM   #765
Sound Performance
Past Site Sponsor
 
Join Date: Feb 2011
Location: Well, Dick, here's the deal: I'm the best there is, plain and simple. I mean, I wake up in the morning and I piss excellence. You know, nobody can hang with my stuff.
Posts: 565
My Ride: Is very FAST
Mine is too! I will certainly admit that the vanos system is quite a challenge but i think we will get it next week!

Sent from my XT901 using Bimmer App
Sound Performance is offline   Reply With Quote
Old 05-11-2013, 12:22 AM   #766
NikolaiD
Registered User
 
Join Date: Oct 2006
Location: Chicago, IL
Posts: 529
My Ride: 2002 M3C
Send a message via AIM to NikolaiD Send a message via MSN to NikolaiD Send a message via Yahoo to NikolaiD Send a message via Skype™ to NikolaiD
E-mail sent.
I'm local and could help you diagnose and fix the VANOS issues.
__________________
_______________________________________

My Ride: 2002 M3C

NikolaiD is offline   Reply With Quote
Old 05-11-2013, 01:37 AM   #767
BrokenM3
Registered User
 
Join Date: Nov 2010
Location: Chicago
Posts: 55
My Ride: E46 Coupe
Nice. If you end up helping, i suggest to remove the top speed limiter and add shift lights as well(if it's not done yet)
__________________
BrokenM3 is offline   Reply With Quote
Old 05-11-2013, 09:17 AM   #768
02black330ci
Registered User
 
Join Date: Mar 2005
Location: ^^ E46FANATICS ^^
Posts: 1,814
My Ride: spaceship
Quote:
Originally Posted by nikolaid View Post
e-mail sent.
I'm local and could help you diagnose and fix the vanos issues.
^ this!
__________________






02black330ci is offline   Reply With Quote
Old 05-11-2013, 11:14 AM   #769
Sound Performance
Past Site Sponsor
 
Join Date: Feb 2011
Location: Well, Dick, here's the deal: I'm the best there is, plain and simple. I mean, I wake up in the morning and I piss excellence. You know, nobody can hang with my stuff.
Posts: 565
My Ride: Is very FAST
Quote:
Originally Posted by NikolaiD View Post
E-mail sent.
I'm local and could help you diagnose and fix the VANOS issues.
Thank you so much Nik! Today unfortunately I have a funeral to go to. A couple of my mechanics are meeting with a local BMW tech today to try and sort out the VANOS issue. If they cannot get it would it be possible for you to come by one night after work any night this upcoming week? I really want to get Tom's car finished for him this week! Thanks again!!
Sound Performance is offline   Reply With Quote
Old 05-11-2013, 12:51 PM   #770
Twin_Turbo_S54
Registered User
 
Join Date: Nov 2012
Location: Istanbul
Posts: 684
My Ride: M3
Quote:
Originally Posted by Sound Performance View Post
Thank you so much Nik! Today unfortunately I have a funeral to go to. A couple of my mechanics are meeting with a local BMW tech today to try and sort out the VANOS issue. If they cannot get it would it be possible for you to come by one night after work any night this upcoming week? I really want to get Tom's car finished for him this week! Thanks again!!

I had a similar issue, replaced the intake cam sensor and exhaust cam sensor and solved the problem.

1- Did you try replacing the cam sensors?

2- Get a spare vanos unit, the main plastic covered vanos box. This part may have failed.

3- Check your vanos pressure tube and its piping. It might be clogged or bent...
__________________
E46 M3 Sedan All Wheel Drive Twin Turbo
0-100 km/h 2.91 seconds @ 15 psi

E46 M3 Coupe Turbo 60-130 mph 4,2 seconds (2011)
Twin_Turbo_S54 is offline   Reply With Quote
Old 05-11-2013, 09:46 PM   #771
NikolaiD
Registered User
 
Join Date: Oct 2006
Location: Chicago, IL
Posts: 529
My Ride: 2002 M3C
Send a message via AIM to NikolaiD Send a message via MSN to NikolaiD Send a message via Yahoo to NikolaiD Send a message via Skype™ to NikolaiD
Just came back from SP a couple of hours ago.
The vanos exhaust piston is not building pressure, the solenoid is fine, the cam sensors are fine. The first thing to try would be new seals on the vanos pump.
__________________
_______________________________________

My Ride: 2002 M3C

NikolaiD is offline   Reply With Quote
Old 05-11-2013, 10:07 PM   #772
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,366
My Ride: BMW's
Quote:
Originally Posted by NikolaiD View Post
Just came back from SP a couple of hours ago.
The vanos exhaust piston is not building pressure, the solenoid is fine, the cam sensors are fine. The first thing to try would be new seals on the vanos pump.
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote
Old 05-11-2013, 11:33 PM   #773
imapimp
Registered User
 
Join Date: Apr 2006
Location: Wisconsin
Posts: 227
My Ride: 2002.5 AV6 6MT 04M3
Quote:
Originally Posted by NikolaiD View Post
Just came back from SP a couple of hours ago.
The vanos exhaust piston is not building pressure, the solenoid is fine, the cam sensors are fine. The first thing to try would be new seals on the vanos pump.
imapimp is offline   Reply With Quote
Old 05-11-2013, 11:36 PM   #774
Commanderwiggin
Registered User
 
Join Date: Jun 2010
Location: Calgary, Canada
Posts: 3,870
My Ride: 900rwhp Turbo M3
Quote:
Originally Posted by NikolaiD View Post
Just came back from SP a couple of hours ago.
The vanos exhaust piston is not building pressure, the solenoid is fine, the cam sensors are fine. The first thing to try would be new seals on the vanos pump.
__________________
Commanderwiggin is offline   Reply With Quote
Old 05-11-2013, 11:45 PM   #775
323tom
Registered User
 
Join Date: Mar 2008
Location: toronto
Posts: 1,236
My Ride: 2 turbo e46's
Quote:
Originally Posted by NikolaiD View Post
Just came back from SP a couple of hours ago.
The vanos exhaust piston is not building pressure, the solenoid is fine, the cam sensors are fine. The first thing to try would be new seals on the vanos pump.
__________________
323tom is offline   Reply With Quote
Old 05-12-2013, 05:48 AM   #776
Dreikraft
Registered User
 
Join Date: Jun 2008
Location: Alaska :(
Posts: 692
My Ride: slow m3
try bav auto recycling. they give 6month warranty on used units. quicker and way cheaper than having dr vanos do it and still cheaper than getting a beisan kit because of all the additional special tools to DIY.
Dreikraft is offline   Reply With Quote
Old 05-12-2013, 09:57 AM   #777
323tom
Registered User
 
Join Date: Mar 2008
Location: toronto
Posts: 1,236
My Ride: 2 turbo e46's
Just checked bav autos site, couldn't find any s54 vanos units
__________________
323tom is offline   Reply With Quote
Old 05-12-2013, 10:02 AM   #778
dan avoN7
Registered User
 
Join Date: May 2009
Location: Danville, CA
Posts: 399
My Ride: A car
Quote:
Originally Posted by 323tom View Post
Just checked bav autos site, couldn't find any s54 vanos units
You might want to check out www.beisansystems.com if it's the seals or any vanos parts that need rebuilding. They just recently released a wider range of products to service the vanos unit.
dan avoN7 is online now   Reply With Quote
Old 05-12-2013, 10:04 AM   #779
MisterM
Registered User
 
Join Date: Jun 2009
Location: Seattle
Posts: 202
My Ride: 03 M3
The beisan seal kit is excellent. Highly recommend and a breeze to install with the excellent DIY procedure Raj provided.

Only fancy tool you need is a proper bench vise.
__________________
02' M3 Topaz/Cinnamon - CSL Box, Lid, & Roof, SSV1's, Morr VS8.2's, TTFS tune 322/249 SAE on 91 (stock head/cams) - Ported head, 288/280 cams coming soon.
11' X5d Jet Black/Oyster - Sport Activity, Technology, 214's, Tow Package, TTFS Diesel Tune (coming soon)
MisterM is offline   Reply With Quote
Old 05-12-2013, 10:44 AM   #780
Commanderwiggin
Registered User
 
Join Date: Jun 2010
Location: Calgary, Canada
Posts: 3,870
My Ride: 900rwhp Turbo M3
Could this be broken tabs for the exhaust hub?
__________________
Commanderwiggin is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use