E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 186 votes, 4.92 average.
Old 07-31-2012, 01:51 PM   #901
daxmax
Registered User
 
Join Date: Sep 2010
Location: Colombo
Posts: 9
My Ride: 320d E46
Scanner not working, "Privileged instruction"

Hi guys.

I have a 1999 E46 320d. I recently purchased the BMW Scanner 1.4 and connected it to the under-the-hood connector using a 16 pin-20 pin adapter. When I plug it in to the laptop, I dont see the green USB light being lit. The Orange light is lit from the time it's connected to the car. The computer says the USB device is working properly and the software detects the adapter (says adapter is plugged in and the little box is green).

However, that is as far as it goes. When I click the 'continue' button, error messages pop up. The first one says 'External exception C000001D' and then every second a new error message pops up saying 'Privileged instruction'.

I'm running the software on a Windows XP laptop. I even tried the regedit 'delete PAsoft' trick, but to no avail.

Have I been sold a lemon? Does the Green LED need to be lit continuously?

What do I need to do to get this software to run?

Cheers
daxmax is offline   Reply With Quote
Old 07-31-2012, 03:03 PM   #902
iowna330xi
Registered User
 
Join Date: Jul 2007
Location: Chi-town, IL.
Posts: 130
My Ride: is fast.
Tried to read all post but need a definite answer re: PPPPP on cluster

I recently used Carsoft 6.5 on a 99 323i, I just reset the airbag light but now my cluster shows PPPPP error code. Will PA 1.4 eliminate this code and restore my odometer reading. Btw everything works fine in the cluster except for the PPPPP on the lcd.
iowna330xi is offline   Reply With Quote
Old 07-31-2012, 11:20 PM   #903
daxmax
Registered User
 
Join Date: Sep 2010
Location: Colombo
Posts: 9
My Ride: 320d E46
BMW Scanner not working + error messages

Hi guys.

I have a 1999 E46 320d. I recently purchased the BMW Scanner 1.4 and connected it to the under-the-hood connector using a 16 pin-20 pin adapter. When I plug it in to the laptop, I dont see the green USB light being lit. The Orange light is lit from the time it's connected to the car. The computer says the USB device is working properly and the software detects the adapter (says adapter is plugged in and the little box is green

However, that is as far as it goes. When I click the 'continue' button, error messages pop up. The first one says 'External exception C000001D' and then every second a new error message pops up saying 'Privileged instruction'.

I'm running the software on a Windows XP laptop. I even tried the regedit 'delete PAsoft' trick, but to no avail.

Have I been sold a lemon? Does the Green LED need to be lit continuously?

What do I need to do to get this software to run?

Cheers
daxmax is offline   Reply With Quote
Old 08-01-2012, 07:11 AM   #904
SpoonerDee
Registered User
 
Join Date: Jun 2008
Location: Connecticut
Posts: 503
My Ride: 2005 E46
There is a huge giant thread on this topic. Ask in there.
SpoonerDee is offline   Reply With Quote
Old 08-01-2012, 07:45 AM   #905
daxmax
Registered User
 
Join Date: Sep 2010
Location: Colombo
Posts: 9
My Ride: 320d E46
Quote:
Originally Posted by SpoonerDee View Post
There is a huge giant thread on this topic. Ask in there.
I tried but didn't get any response, so thought there may be a better chance on an individual thread.
daxmax is offline   Reply With Quote
Old 08-01-2012, 08:06 AM   #906
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 6,954
My Ride: 2004 M3, 2001 325i
I don't recall how it works with the under hood connector, however my scanner has a red LED constantly on from the moment its plugged in the OBD2 port.

Try reinstalling on another laptop, make sure its running a 32-bit OS, and that your key is turned to position 2 (run).
__________________
ac_2007 is offline   Reply With Quote
Old 08-08-2012, 09:46 PM   #907
lllRazorlll
Registered User
 
Join Date: Jul 2012
Location: Philadelphia, PA
Posts: 243
My Ride: '00 328i
What kind of USB cable do you need to hook up the computer to the car?
lllRazorlll is offline   Reply With Quote
Old 08-09-2012, 03:12 PM   #908
Kmoy2002
Registered User
 
Join Date: May 2007
Location: Chicago
Posts: 1,011
My Ride: 2002tii, 540i, 330i
Quote:
Originally Posted by lllRazorlll View Post
What kind of USB cable do you need to hook up the computer to the car?
Not sure if you're trolling but did you not even bother to read this thread?
Kmoy2002 is offline   Reply With Quote
Old 08-09-2012, 03:26 PM   #909
Schlag96
Slightly Modded ///Member
 
Schlag96's Avatar
 
Join Date: May 2012
Location: Ventura County, CA
Posts: 821
My Ride: 1999 323i
Quote:
Originally Posted by lllRazorlll View Post
What kind of USB cable do you need to hook up the computer to the car?
The obd connector has a firewire cable on its end and a usb on the end that goes into the comp.
Schlag96 is offline   Reply With Quote
Old 08-09-2012, 07:04 PM   #910
lllRazorlll
Registered User
 
Join Date: Jul 2012
Location: Philadelphia, PA
Posts: 243
My Ride: '00 328i
Okay, thanks! Where is the port in the car located?
lllRazorlll is offline   Reply With Quote
Old 08-10-2012, 09:48 AM   #911
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 2,022
My Ride: BMW 323i Sedan
Top right of the car when your looking into your hood. Round piece that screws off.
__________________

trentcdrums is offline   Reply With Quote
Old 08-10-2012, 09:49 AM   #912
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 2,022
My Ride: BMW 323i Sedan
Or top left. For my 323i 2000 it's top left
__________________

trentcdrums is offline   Reply With Quote
Old 08-10-2012, 12:13 PM   #913
hassmaschine
Registered User
 
Join Date: Sep 2011
Location: Ferndale, WA
Posts: 198
My Ride: '91 325ix
PPPPP means a checksum error. You could try reflashing it in INPA.

Last edited by hassmaschine; 08-10-2012 at 12:14 PM.
hassmaschine is offline   Reply With Quote
Old 08-10-2012, 12:51 PM   #914
lllRazorlll
Registered User
 
Join Date: Jul 2012
Location: Philadelphia, PA
Posts: 243
My Ride: '00 328i
Is this it?


Last edited by lllRazorlll; 08-10-2012 at 12:53 PM.
lllRazorlll is offline   Reply With Quote
Old 08-10-2012, 01:52 PM   #915
mrmaico
Registered User
 
Join Date: Aug 2009
Location: ND
Posts: 254
My Ride: 04 ZHP, 05 R1200 GS
That's it. Newer models have it under the dash and shaped different.
__________________
mrmaico is offline   Reply With Quote
Old 08-10-2012, 05:26 PM   #916
lllRazorlll
Registered User
 
Join Date: Jul 2012
Location: Philadelphia, PA
Posts: 243
My Ride: '00 328i
Sweet, what's the cable called also?
lllRazorlll is offline   Reply With Quote
Old 08-11-2012, 12:57 AM   #917
slocar
Registered User
 
Join Date: Dec 2011
Location: .
Posts: 51
My Ride: 323ci
Search for "Bmw 20 pin adapter"
__________________
slocar is offline   Reply With Quote
Old 08-11-2012, 11:40 AM   #918
lllRazorlll
Registered User
 
Join Date: Jul 2012
Location: Philadelphia, PA
Posts: 243
My Ride: '00 328i
Awesome, I found it. I'll let you guys know how it goes down.
lllRazorlll is offline   Reply With Quote
Old 08-13-2012, 08:56 AM   #919
makecopies
Registered User
 
Join Date: Oct 2007
Location: 1600 Penn. Ave
Posts: 1,807
My Ride: Gods Chariot
I keep getting the msg........Drivers not installed.
But I did install them. What am I doing wrong here?
makecopies is offline   Reply With Quote
Old 08-13-2012, 08:56 AM   #920
makecopies
Registered User
 
Join Date: Oct 2007
Location: 1600 Penn. Ave
Posts: 1,807
My Ride: Gods Chariot
I keep getting the msg........Drivers not installed.
But I did install them. What am I doing wrong here?
makecopies is offline   Reply With Quote
Reply

Tags
bmw scanner, diagnostic tool, error message, pa soft

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use