E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-16-2012, 02:25 PM   #1
RHAGGS
Registered User
 
Join Date: Mar 2012
Location: JERSEY CITY
Posts: 36
My Ride: BMW E 46 2000 323I
Angry Too much fuel consumption

MY E 46 IS ONLY GETTING 16 MPG
CHANGED EVERYTHING ?

AND I GOT A CODE 149 STORED IN SYSTEM

RPM IDLE IS ROUGH
RHAGGS is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-14-2012, 03:19 AM   #2
Brucio325cic
Registered User
 
Join Date: Dec 2011
Location: Fort Lauderdale, FL
Posts: 16
My Ride: 2005 325ci Cabrio
Man...did U get any response or ideas how to fix this. I got 13.3 MPG city!! and the RPM Rufff Idle...

Ive changed my Fuel Filter... I changed my Valve Cover gasket.... I changed all My Intake Rubber Hoses.... and Still!!

Any input would be Highly highly Appreciated. THX
Brucio325cic is offline   Reply With Quote
Old 09-14-2012, 06:27 AM   #3
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
Im getting 14.4 city mpg
Dippinwandy is offline   Reply With Quote
Old 09-16-2012, 03:41 AM   #4
Bandit4077
Registered User
 
Join Date: Feb 2010
Location: San Diego, SF Bay Area
Posts: 106
My Ride: 330i SuperVeloce
fellas, this isn't good, you should check your DISA o ring. get the code boffins on this.
__________________
Some say, that inside his helmet, there is another helmet. All we know is...



Check out my interior: http://forum.e46fanatics.com/showthread.php?t=1055263
Bandit4077 is offline   Reply With Quote
Old 09-16-2012, 12:42 PM   #5
daves325in2012
Registered User
 
Join Date: Mar 2012
Location: Clearwater, Florida
Posts: 165
My Ride: 04 330cic & 00 540i
thermostat stuck open, VANOS, FUEL FILTER all come to mind

check option 5 on the hidden OBDII menu and see what its telling you you should be getting, then calculate what you are actually getting. that will tell you how far off your tuning is usually

TRICK: dividing the hidden ODBII menu's nummber (ie 96 = 9.6) by 235

235(DIVIDED BY)9.6 = MPG

Driving in Clearwater FL, i just got 25mpg ON US19 (congested highway) using 93 octane ethanol free, doing conservative, but not slow driving skills. thats pretty damn good i would only get 22 on shell vpower w/ 10% ethanol before

Ran through a whole tank of it and then divided out miles and gallons.

my ODBII otion 5 said i got 27, but its always reads about 2MPG higher than what I actually get

USE Premium gas too, that will improve miles by 2MPG avg and make the car run smoother.

The ethanol free, however, made the miles go up ANOTHER 2mpg from shell v power 93 w./ 10% ethanol

Last edited by daves325in2012; 09-16-2012 at 12:44 PM.
daves325in2012 is offline   Reply With Quote
Old 10-04-2012, 04:32 PM   #6
aahmed2016
Registered User
 
Join Date: Sep 2012
Location: Jonesboro, GA, USA
Posts: 759
My Ride: 2003 330i ZSP/CP/PP
Quote:
Originally Posted by RHAGGS View Post
MY E 46 IS ONLY GETTING 16 MPG
CHANGED EVERYTHING ?

AND I GOT A CODE 149 STORED IN SYSTEM

RPM IDLE IS ROUGH
Might be from one of those resister in a box performance chips. maybe PO installed it. I would try the thermostat.
aahmed2016 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use