E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 19 votes, 4.74 average. Display Modes
Old 01-23-2012, 03:19 PM   #61
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 7,087
My Ride: F32 M4, E46 M3/325i
Quote:
Originally Posted by forzam View Post
AC what year is your E46? I have an 2004 that runs MS45. So I guess I can't flash to the EU version.
I have a 2001. The tune I flashed was only used from 2003-2005 according to bmwfans.info. If you have MS45, just look through the tunes in the last month of 2005.

Quote:
Originally Posted by stevenluczynski View Post
Could you pm me or post where you got the latest BMW standard tools
Honestly, I don't even remember. I've been up since yesterday figuring everything out. A quick google search points to a torrent on TPB.

I just sent FastHackem a few links that may help you, since the ftp server seems to be down (maybe that's where I got BMW Standard Tools from?). Tell him to forward you the message.
__________________


Quote:
Originally Posted by mjpgolf1 View Post
The e46 M3 is by far the most boring and worst M3 that BMW has made to date.
It's amazing to me that a non M E46 is such a beautiful car but the E46 M has never done much for me.
ac_2007 is offline   Reply With Quote
Old 01-23-2012, 03:29 PM   #62
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 674
My Ride: E60 M5
Quote:
Originally Posted by ac_2007 View Post
I just sent FastHackem a few links that may help you, since the ftp server seems to be down (maybe that's where I got BMW Standard Tools from?). Tell him to forward you the message.
Done.
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Old 01-23-2012, 06:32 PM   #63
mystert
Registered User
 
Join Date: Oct 2008
Location: Huntington Beach, CA
Posts: 370
My Ride: 2003 330Ci
Well its been a couple days and a full tank of gas running the EU3 tune on my 9/2002 330ci. Im not really noticing much of a difference now. I think some of the initial differences that are felt come from the resetting of the adaptation values. Now that they have re-adapted to my driving style its like the same car it was before i tuned it.

If you have headers and use the EU2 tune, this is a great fix for the CEL issue or if you have a SMG M3 and can load the CSL transmission software (including launch control) but for the EU3, not really sure its worth the bang for the buck, other than the top speed limit change and the fact u can tell your friends your running EU spec software.

One thing to note, if you look on the BMWFans.info site, you can see the latest MS43 software for EU3 tune is also the same number for the EU4 tune, at least when you use 9/2002 330ci European Coupe.
__________________

MysterT Huntington Beach, CA
mystert is offline   Reply With Quote
Old 01-23-2012, 09:01 PM   #64
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,408
My Ride: Is Steel Blue<3
how did you guys get past this when updating the Daten files?
__________________
stevenluczynski is online now   Reply With Quote
Old 01-24-2012, 01:32 AM   #65
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 7,087
My Ride: F32 M4, E46 M3/325i
Quote:
Originally Posted by stevenluczynski View Post
how did you guys get past this when updating the Daten files?
[IMG]http:/ 1199.photobucket.com/albums/aa466/stevenluczynskie46/error.jpg[/IMG]
Make sure you're running WinKFP version 5.1.6. Also open up NPV.DAT in Notepad and delete line 2.


I did not have this problem the second time around when installing from BMW Standard Tools 2.5.1.0
__________________


Quote:
Originally Posted by mjpgolf1 View Post
The e46 M3 is by far the most boring and worst M3 that BMW has made to date.
It's amazing to me that a non M E46 is such a beautiful car but the E46 M has never done much for me.
ac_2007 is offline   Reply With Quote
Old 01-24-2012, 05:43 PM   #66
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,408
My Ride: Is Steel Blue<3
Quote:
Originally Posted by ac_2007 View Post
Make sure you're running WinKFP version 5.1.6. Also open up NPV.DAT in Notepad and delete line 2.


I did not have this problem the second time around when installing from BMW Standard Tools 2.5.1.0
so I still cannot get past these errors
Could you Pm me where and witch exact software and guides you used?
Ive tried installing the tools from several different sources and still get this error
__________________
stevenluczynski is online now   Reply With Quote
Old 01-24-2012, 06:02 PM   #67
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 7,087
My Ride: F32 M4, E46 M3/325i
Quote:
Originally Posted by stevenluczynski View Post
so I still cannot get past these errors
Could you Pm me where and witch exact software and guides you used?
Ive tried installing the tools from several different sources and still get this error
The FTP server where I got it from is down.

Google BMW Standard Tools 2.5.1.0, a link comes up from TPB. The file is only about 25mb. I don't want to get in trouble for posting torrents.

Once you have the daten files:
1) Copy files from "SP-Daten-E46\Ecu" to "C:\Ediabas\ECU"
2) Copy files from "SP-Daten-E46\Sgdat" to "C:\EC-APPS\NFS\SGDAT"
3) Follow the instructions here to import daten files into WinKFP (5.1.6)

Honestly, if it doesn't work after this just delete it all from your C drive and start fresh with the newer version of BMW Standard Tools.
__________________


Quote:
Originally Posted by mjpgolf1 View Post
The e46 M3 is by far the most boring and worst M3 that BMW has made to date.
It's amazing to me that a non M E46 is such a beautiful car but the E46 M has never done much for me.

Last edited by ac_2007; 01-24-2012 at 06:04 PM.
ac_2007 is offline   Reply With Quote
Old 01-24-2012, 06:07 PM   #68
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,408
My Ride: Is Steel Blue<3
Quote:
Originally Posted by ac_2007 View Post
The FTP server where I got it from is down.

Google BMW Standard Tools 2.5.1.0, a link comes up from TPB. The file is only about 25mb. I don't want to get in trouble for posting torrents.

Once you have the daten files:
1) Copy files from "SP-Daten-E46\Ecu" to "C:\Ediabas\ECU"
2) Copy files from "SP-Daten-E46\Sgdat" to "C:\EC-APPS\NFS\SGDAT"
3) Follow the instructions here to import daten files into WinKFP (5.1.6)

Honestly, if it doesn't work after this just delete it all from your C drive and start fresh with the newer version of BMW Standard Tools.
Thanks for the help, I really appreciate it!
__________________
stevenluczynski is online now   Reply With Quote
Old 01-24-2012, 09:11 PM   #69
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,408
My Ride: Is Steel Blue<3
Alright i got it working! Ill be testing it out tomorrow!
__________________
stevenluczynski is online now   Reply With Quote
Old 01-25-2012, 10:45 AM   #70
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 7,087
My Ride: F32 M4, E46 M3/325i
Good to hear buddy, now make sure your batt voltage is steady around 14v before you start flashing.
__________________


Quote:
Originally Posted by mjpgolf1 View Post
The e46 M3 is by far the most boring and worst M3 that BMW has made to date.
It's amazing to me that a non M E46 is such a beautiful car but the E46 M has never done much for me.
ac_2007 is offline   Reply With Quote
Old 01-25-2012, 01:04 PM   #71
spencers
Registered User
 
Join Date: Jul 2005
Location: Location, Location
Posts: 1,363
My Ride: 2006 330i sport
Quote:
Originally Posted by mystert View Post
but for the EU3, not really sure its worth the bang for the buck, other than the top speed limit change and the fact u can tell your friends your running EU spec software.
It's not worth the price of free?

You'd notice a greater difference with 93 octane.
__________________
spencers is offline   Reply With Quote
Old 01-25-2012, 05:42 PM   #72
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,408
My Ride: Is Steel Blue<3
Another day another error, I have everything set up but Winkfp is not establishing a connection with my Dme error(2020)
__________________
stevenluczynski is online now   Reply With Quote
Old 01-28-2012, 04:02 PM   #73
jeagolf
Registered User
 
Join Date: Feb 2011
Location: Fort Worth TX
Posts: 100
My Ride: 04 330Ci Vert
I can't get my digi head.exe to work on my MacBook pro. (booted up in xp pro mode only!) everything else works fine but can't start the digihead.exe? Any ideas??
jeagolf is offline   Reply With Quote
Old 01-28-2012, 04:12 PM   #74
forzam
Registered User
 
Join Date: Apr 2007
Location: East Coast
Posts: 374
My Ride: 04 325Ci
Do you mean diaghead.exe? If so try installing Microsoft .NET 2.0 framework.
forzam is offline   Reply With Quote
Old 01-28-2012, 04:16 PM   #75
jeagolf
Registered User
 
Join Date: Feb 2011
Location: Fort Worth TX
Posts: 100
My Ride: 04 330Ci Vert
Quote:
Originally Posted by forzam View Post
Do you mean diaghead.exe? If so try installing Microsoft .NET 2.0 framework.
Yeah sorry darn auto correct!! I do a lot of work with digi and pro tools so my phone has learned digi.

Thanks for reading what I meant to say! I'll try it tonight when I get home.
jeagolf is offline   Reply With Quote
Old 01-28-2012, 04:53 PM   #76
jmejia4
Registered User
 
Join Date: Apr 2008
Location: New Mexico
Posts: 22
My Ride: 330i
Got my DIS and SSS working, if anyone in Albuquerque area needs assistance pm me
jmejia4 is offline   Reply With Quote
Old 01-28-2012, 07:27 PM   #77
jeagolf
Registered User
 
Join Date: Feb 2011
Location: Fort Worth TX
Posts: 100
My Ride: 04 330Ci Vert
Quote:
Originally Posted by forzam View Post
Do you mean diaghead.exe? If so try installing Microsoft .NET 2.0 framework.
That fixed it thanks!!!
jeagolf is offline   Reply With Quote
Old 01-28-2012, 08:38 PM   #78
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,408
My Ride: Is Steel Blue<3
I still cant get the thing to work
I've tried so many times i lost track how many times I've cleared and re-installed Winkfp
I still get an error saying it cannot contact the ecu, I believe it has something to do with the Daten files
__________________
stevenluczynski is online now   Reply With Quote
Old 01-28-2012, 11:04 PM   #79
forzam
Registered User
 
Join Date: Apr 2007
Location: East Coast
Posts: 374
My Ride: 04 325Ci
Can you connect to the ECU using INPA?
forzam is offline   Reply With Quote
Old 01-29-2012, 12:26 AM   #80
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 7,087
My Ride: F32 M4, E46 M3/325i
Quote:
Originally Posted by forzam View Post
Can you connect to the ECU using INPA?
This.

If your Ignition and Battery icons are black in INPA, the device is connecting properly. At least then you can narrow down the problem.

Also, my laptop HDD just went out
So I purchased a new one, partitioned it, and installed XP just for all my programming software.
I'll be redoing this whole install over the weekend, as well as PA Soft.
__________________


Quote:
Originally Posted by mjpgolf1 View Post
The e46 M3 is by far the most boring and worst M3 that BMW has made to date.
It's amazing to me that a non M E46 is such a beautiful car but the E46 M has never done much for me.
ac_2007 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use