E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-01-2012, 05:26 PM   #1
joeysm3
Registered User
 
Join Date: Nov 2011
Location: brooklyn
Posts: 478
My Ride: ///M3 04 SMG
how to bleed smg m3

is there diy guide on how to bleed it i searched everywhere no one seems to have a legit answer
__________________
joeysm3 is online now   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-01-2012, 05:29 PM   #2
E46_330i_Stud
Registered User
 
Join Date: May 2010
Location: Wake Forest, NC
Posts: 1,888
My Ride: 2004 330ci ZHP 6MT
How to bleed what? Coolant? Brake fluid??
__________________


1995 325i 5mt ArcticGrey/Dove - SOLD
2004 330ci ZHP 6MT SilberGrau/Black - SOLD
2001 330i M-Sport 5MT StaulGrau/Grey - SOLD
1992 Accord LX Sedan 275k miles all original - DAILY
2002 Chevy Suburban LT Autoride - TOY HAULER
2005 GMC Sierra 2500HD SLT - RACE TRUCK!
E46_330i_Stud is offline   Reply With Quote
Old 02-01-2012, 06:31 PM   #3
joeysm3
Registered User
 
Join Date: Nov 2011
Location: brooklyn
Posts: 478
My Ride: ///M3 04 SMG
smg hydraulic fluid
__________________
joeysm3 is online now   Reply With Quote
Old 02-01-2012, 06:38 PM   #4
Bemwe_03i
Registered User
 
Join Date: Oct 2010
Location: Cal AB garage
Posts: 1,237
My Ride: 2003.5 E46 M3 smg IR
drive it til it bleeds
__________________
Bemwe_03i is offline   Reply With Quote
Old 02-01-2012, 06:43 PM   #5
joeysm3
Registered User
 
Join Date: Nov 2011
Location: brooklyn
Posts: 478
My Ride: ///M3 04 SMG
Mature answers please.
__________________
joeysm3 is online now   Reply With Quote
Old 02-02-2012, 01:07 AM   #6
fat-marshmellow
Registered User
 
Join Date: May 2009
Location: st paul, minnesota
Posts: 869
My Ride: ///M3 SMG
I believe you can do it the autoenginuity tool...go Google "m3 smg autoenginuity" it should be the m3forum link

Sent from my SGH-T959V using Bimmer App
__________________

ex: 2002 TIAG 325xi (sold), 2007 suzuki gsxr (sold)
current: 2002 carbon black ///M SMG
halogen headlights? want hid projectors? on a budget? maybe i can help! go here!!
http://forum.e46fanatics.com/showthread.php?t=840919
fat-marshmellow is offline   Reply With Quote
Old 02-02-2012, 08:56 AM   #7
dcf
Registered User
 
Join Date: Aug 2007
Location: Illinois
Posts: 763
My Ride: 02 e46 M3 SMG - LSB
AE tool does NOT have the "bleed" function. I know, I tried after I swapped out my gearbox, and no luck getting it to work right. AE will allow you to select each gear with the car motionless, but to do a true bleed, you need the GT1.

Bleeding SMG does not involve opening any bleed screws or anything like that (a la brakes). It is not a "mechanical" DIY. It is a series of functions in the computer where certain valves are opened while the pump runs and stops. It allows the air in the system to work its way back up to the Res. It takes a while for that program in the GT1 to run, but does the job right. You basically need the GT1 computer to do it correctly, there is no other way that I know of to get it done.
dcf is offline   Reply With Quote
Old 02-02-2012, 10:36 AM   #8
mooninite
Registered User
 
Join Date: May 2006
Location: Texas
Posts: 381
My Ride: M3, 325i
From talking to my shop, it is recommended to not replace the hydraulic fluid.

tldr: Don't mess with your SMG fluid.
mooninite is offline   Reply With Quote
Old 02-02-2012, 10:39 AM   #9
dcf
Registered User
 
Join Date: Aug 2007
Location: Illinois
Posts: 763
My Ride: 02 e46 M3 SMG - LSB
Quote:
Originally Posted by mooninite View Post
From talking to my shop, it is recommended to not replace the hydraulic fluid.

tldr: Don't mess with your SMG fluid.
Very good point. I guess the question for the OP is: why do you need to bleed it out?

Unless you are changing out the gearbox or SMG pump setup, there is no need to open up that Hyd. system.
dcf is offline   Reply With Quote
Old 02-02-2012, 11:54 AM   #10
joeysm3
Registered User
 
Join Date: Nov 2011
Location: brooklyn
Posts: 478
My Ride: ///M3 04 SMG
because it is leaking. i filled it to max before and now its missing again... so i think its leaking i filled it up again it was sound of like air (gurgles) when i was filling it to max.
__________________
joeysm3 is online now   Reply With Quote
Old 02-02-2012, 12:15 PM   #11
dcf
Registered User
 
Join Date: Aug 2007
Location: Illinois
Posts: 763
My Ride: 02 e46 M3 SMG - LSB
Are you checking it with the car on or off? Are you sure it is leaking? The difference n the Res. between when the pump has the system charged and when it is unpresurized is very large. Noises in the Res. is not a sign of air in the system, that is how the Res. works

If there is a leak, your concern should not be bleeding, but finding the leak. When there is a leak, generally, it is involving the slave cylinder for the clutch.
dcf is offline   Reply With Quote
Old 02-02-2012, 12:32 PM   #12
joeysm3
Registered User
 
Join Date: Nov 2011
Location: brooklyn
Posts: 478
My Ride: ///M3 04 SMG
the car was off stone cold and i can see the oil on the wires under where u put the fluid. so how do i know if its the slave cylinder because u add fluid another week or 2 its missing.... any suggestion?
__________________
joeysm3 is online now   Reply With Quote
Old 02-02-2012, 03:31 PM   #13
JamaicanBlueE46M3
Registered User
 
Join Date: Sep 2009
Location: Jamaica
Posts: 115
My Ride: E46 M3
It uses Pentosin CHF11S oil, u can use the INPA or GT1 to bleed it. If u have to be adding then it must have a leak somewhere, clean up the area properly and watch and see if it reappears. I would think that if the slave cylinder leaking then maybe it would start to have gear selection issues.
JamaicanBlueE46M3 is offline   Reply With Quote
Old 02-02-2012, 06:28 PM   #14
Mallee
Registered User
 
Join Date: May 2010
Location: Melbourne, Australia
Posts: 400
My Ride: 2002 E46 M3
Quote:
Originally Posted by dcf View Post
You basically need the GT1 computer to do it correctly, there is no other way that I know of to get it done.
+1

When I had an smg pump failure an independent bmw mechanic told me he could replace the pump but I'd need to go to a dealer to get the system bled..

Last edited by Mallee; 02-02-2012 at 10:52 PM.
Mallee is offline   Reply With Quote
Old 02-02-2012, 07:15 PM   #15
joeysm3
Registered User
 
Join Date: Nov 2011
Location: brooklyn
Posts: 478
My Ride: ///M3 04 SMG
but now it is everytime i press the gas pedal it pops back to N im sure it has something to do with the oil missing because it passed the pump test that my mechanic did about a month ago or so..
__________________
joeysm3 is online now   Reply With Quote
Old 02-07-2012, 01:11 PM   #16
sonnydm3
Registered User
 
Join Date: Jan 2008
Location: new york bethpage
Posts: 31
My Ride: 2004 m3
i do repair alot of e46,s u need gt1 software to bleed system ,,
sonnydm3 is offline   Reply With Quote
Old 02-07-2012, 04:48 PM   #17
grkm3
Registered User
 
Join Date: Mar 2006
Location: Long Island
Posts: 1,903
My Ride: Money Pit
Send a message via AIM to grkm3
I used INPA to bleed my system. Make sure you have a high current battery charger connected to your car while the process is running.
__________________
03 Steel Gray M3 - Imola Red Interior - SMGII - Premium - HK Sound
Mods: VFE SC Stage 2, SS Ceramic Coated Stepped Headers, S-Pipe, X-Pipe, TMS Subframe Reinforcement, KWV2 Coilovers, TMS Camber Plates, Powerflex RTAB's, Rogue RSM's, ZCP F/R brakes

Coming Soon: Open to suggestions


Last edited by grkm3; 02-07-2012 at 04:50 PM.
grkm3 is offline   Reply With Quote
Old 02-07-2012, 07:47 PM   #18
turbotoy2791
Registered User
 
Join Date: Dec 2011
Location: nc
Posts: 60
My Ride: 04 m3
You may have air in the line to the pump from the reservoir. If you do you will have to take the line loose and fill it with fluid and tap it with a screwdriver to get the air out then fill it again. Once you have the line full snap it back in the resevoir. My line had air in it a while back. I kept driving the car and it finally locked the tranny in two gears. Had to take the tranny apart to get it out of gears. Also it maybe this line leaking.
turbotoy2791 is offline   Reply With Quote
Old 02-07-2012, 07:53 PM   #19
turbotoy2791
Registered User
 
Join Date: Dec 2011
Location: nc
Posts: 60
My Ride: 04 m3
Take the cap off the reservoir and push the hood button to make the pump run. You should be able to see the fluid get sucked into the accumulator. If the fluid does not get sucked down you have air in the reservoir line. Do the above.
turbotoy2791 is offline   Reply With Quote
Old 02-07-2012, 08:03 PM   #20
joeysm3
Registered User
 
Join Date: Nov 2011
Location: brooklyn
Posts: 478
My Ride: ///M3 04 SMG
yea i think its leaking because i refilled the reservoir and it worked 2 days later i was missing fluid... i have to find out where is it leaking from. if its missing oil it wont let me drive it goes back to N when i press the gas pedal. im guessing its the clutch slave cylinder..
__________________
joeysm3 is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use