E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-09-2014, 05:29 AM   #1
m4martin
Registered User
 
Join Date: Aug 2014
Posts: 37
E46 330d engine swap HELP! Engine has no throttle and dies.

Hi all.
Car is a 2000 e46 330d auto with M57 180hp
1)Original engine all ran ok until head gasket failure.
2)Decided to swap engine.
3)Engine doner vehicle was a 2000 E39 auto with M57 180hp.
4)i listened to doner engine running in E39 perfect before swap.

5) parts transferred with doner engine were:
A)injectors
B)crank sensor
C)cam sensor
D)MAF sensor
E)Oil level Sensor
F)HIgh Pressure Fuel Pump with electrical sensor
G)Fuel Rail with rail pressure sensor.

6) Parts retained from original E46 are:
A) Engine wiring harness
B) Water temp sensor for head
C) Alternator
D) turbo assembly with pressure valve actuator. Turbo rebuilt with new core and VGT vanes all cleaned, and vacuum actuator all checked good.
E) Oil filter assembly
F) Inlet manifold with MAP sensor and swirlflap actuator vacuum solenoid.
G) air con compressor
H) Complete radiator assy with temp sensors and attached electrical bits.
I) Starter motor
J) Everything that was attached to the engine bay rather than the engine.

PROBLEM SYMPTOMS

1) with everything connected, engine starts but very lumpy idle then stops, with no throttle response at all.

2)disconnect vacuum line from EGR Valve, engine starts perfect, runs evenly on six cylinders at 800rpm for approx three seconds then revs drop to about 400rpm, still evenly, but absolutely no response from throttle pedal. Engine will stall eventually from revs too low.

3) oil pressure lights all good, and brand new battery fitted to car.

TRIED
1) cam sensor swap
2)MAF sensor swap
3)all vacuum lines checked and connections validated correct.



I have not yet tried to read any ECU fault codes.
All the electrical parts from both cars were all working fine before the swap,
Why oh why won't it run!!! The mechanical parts should all be good and compatible.


HELP!!!!!!!!!!!!!!!!!!!! Pleeeese!


Sent from BimmerApp mobile app
m4martin is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use