E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 202 votes, 4.99 average. Display Modes
Old 04-03-2012, 02:48 PM   #201
Cretster
Registered User
 
Join Date: Mar 2012
Location: Isle of Man
Posts: 88
My Ride: E90 320D
I don't yet have an OBD bluetooth adaptor anyway for trying out torque. I just want to see if the BT USB device will actually work on this rom first as I've failed every previous time to make any of the 3 I've got work so far.
Didn't want to spend money on an OBD BT adaptor if I cannot get the BT working in respect of Dynavin receiving the stream via a USB adaptor.

I'm actually not expecting them to work this time really if I'm honest, as I think there's something different about the android side of my unit to yours or the other peoples' who've got BT working, but I really really hope to be proven wrong about that!
__________________
Cretster is offline   Reply With Quote
Old 04-03-2012, 03:31 PM   #202
listermint
Registered User
 
Join Date: Mar 2009
Location: Ireland
Posts: 125
My Ride: E46 M3 '02
Okay, I have a reboot issue.

At first i thought it was Poweramp with the problem but it occurs on various things i do. It outwardly appears as if the unit crashes out of memory load even though when i check the keyboard service is the only one running.

Android Side reboots each time. It has happened about 19 times in the last 30 minutes.

This is with 1.22 I have gmail synced and market (play) signed in on wifi.

I though it may have been a sd card issue reading from the card with poweramp but tried another card and the reboot was still there.

Stopped using poweramp and it occurs in Google Navigation also, which leads me to think it may be memory overload. These units have 114Mb ? spare

Mines a D99
listermint is offline   Reply With Quote
Old 04-03-2012, 03:55 PM   #203
m3evolution
Registered User
 
Join Date: Feb 2003
Location: Bay Area
Posts: 265
My Ride: M3
It might be google service frame work and Gmail , Contacts, Calendar trying to sync with the server. Try disabling all sync for all apps and also in shell type vac then sclean to clear out dalvik cache it will auto reboot in about 20 second

Quote:
Originally Posted by listermint View Post
Okay, I have a reboot issue.

At first i thought it was Poweramp with the problem but it occurs on various things i do. It outwardly appears as if the unit crashes out of memory load even though when i check the keyboard service is the only one running.

Android Side reboots each time. It has happened about 19 times in the last 30 minutes.

This is with 1.22 I have gmail synced and market (play) signed in on wifi.

I though it may have been a sd card issue reading from the card with poweramp but tried another card and the reboot was still there.

Stopped using poweramp and it occurs in Google Navigation also, which leads me to think it may be memory overload. These units have 114Mb ? spare

Mines a D99
__________________
Rom and Password are available for download now at: http://m3evolution.webs.com

All version of my ROM is strictly for personal use and not to be commercially distributed.

Best way to contact me is at: m3evolution@gmail.com
Do not PM

Beer via Paypal:
m3evolution is offline   Reply With Quote
Old 04-03-2012, 04:16 PM   #204
listermint
Registered User
 
Join Date: Mar 2009
Location: Ireland
Posts: 125
My Ride: E46 M3 '02
Quote:
Originally Posted by m3evolution View Post
It might be google service frame work and Gmail , Contacts, Calendar trying to sync with the server. Try disabling all sync for all apps and also in shell type vac then sclean to clear out dalvik cache it will auto reboot in about 20 second
disabled all sync no change will see about clearing cache down.
listermint is offline   Reply With Quote
Old 04-03-2012, 11:15 PM   #205
NECTOP
Registered User
 
Join Date: Mar 2012
Location: Spb, Russia
Posts: 41
My Ride: Audi A3 Sportback
m3evolution
I have found an issue with 1.2 and 1.22, when moving application from unit to SD, it gives me an error message but when I press "Move to SD" again it move app to SD card. Maybe you can check what is the problem?
Thanks.

Also I have found that WiFI issue seems to be because of long inactivity WiFi adapter just goes to power saving mode and then just can't reconnect. Is it possible to turn off power saving mode?

Last edited by NECTOP; 04-04-2012 at 02:30 AM.
NECTOP is offline   Reply With Quote
Old 04-04-2012, 03:04 AM   #206
Cretster
Registered User
 
Join Date: Mar 2012
Location: Isle of Man
Posts: 88
My Ride: E90 320D
Still no bluetooth for me on 1.22 sadly. I don't understand this, as I've used one of the same dongles that worked for someone else, but have never been able to make the Dynavin detect it on any rom I have ever tried.

Really really gutting as I badly want to be able to stream music through this, and get a BT OBD adaptor as well.

This is what I have before and after trying to enable BT in the wireless settings:


Then it goes like this for maybe 10 seconds when I try to enable it, before just going back to the first state again:


Currently I've got the USB extension cable running to the glovebox and I'm plugging the BT dongle into that, but I have tried previously to plug directly into the dynavin without this cable to eliminate it as a problem, and the wifi dongle works fine when plugged into this so the cable shouldn't be the issue at all.

Is there ANYTHING that I might be doing wrong or have forgotten etc that would prevent it from recognising the BT dongle?

Don't understand this at all.
__________________
Cretster is offline   Reply With Quote
Old 04-04-2012, 04:30 AM   #207
DeadWinter
Registered User
 
Join Date: Mar 2012
Location: Netherlands
Posts: 12
My Ride: E46 320D 2000
Quote:
Originally Posted by E46Fanatics
The following errors occurred with your submission:

m3evolution has exceeded their stored private messages quota and cannot accept further messages until they clear some space.
Looks like your box is full again M3Evo

I sent a tenner your way for your excellent work. Enjoy

Also downed the R1.221 and R1SS version last night.
I'll try an sent your a PM for the passwords later on when your box is cleared again.

Btw I haven't received my BT Dongle and OBD Adapter kit yet, so I'm unable to test the Bluetooth still...
Looks like the Dutch supplier needs to import one first... I could have done that myself...

Last edited by DeadWinter; 04-04-2012 at 04:44 AM.
DeadWinter is offline   Reply With Quote
Old 04-04-2012, 05:02 AM   #208
Cretster
Registered User
 
Join Date: Mar 2012
Location: Isle of Man
Posts: 88
My Ride: E90 320D
Well, in one last attempt to ensure I have the correct BT hardware (since the 3 BT dongles I have tried so far all look identical) I've just ordered the Logilink BT0004 BT dongle from Amazon that someone had successfully used with the D99.

Really would be grateful if one of you with functioning bluetooth in Android could post up what kernel your system is using though.

You just go into the settings and then find the 'About' section (or something along those lines - I don't have it here right at the momet sorry to see the exact description).

At least if I know the rest of you have a different kernel to stop wasting my money buying more and more bluetooth dongles if the kernel I've got in mine just will never allow BT to work or something!!!

Many thanks.
__________________
Cretster is offline   Reply With Quote
Old 04-04-2012, 05:45 AM   #209
listermint
Registered User
 
Join Date: Mar 2009
Location: Ireland
Posts: 125
My Ride: E46 M3 '02
pm'd
listermint is offline   Reply With Quote
Old 04-04-2012, 06:49 AM   #210
Mattbuyshouses
Registered User
 
Join Date: Jun 2011
Location: Elgin, IL
Posts: 46
My Ride: 2004 330i
m3evolution -
Sent over a token of my appreciation via PayPal this morning.

Keep up the great work!
__________________

Mattbuyshouses
Mattbuyshouses is offline   Reply With Quote
Old 04-04-2012, 08:01 AM   #211
listermint
Registered User
 
Join Date: Mar 2009
Location: Ireland
Posts: 125
My Ride: E46 M3 '02
Cretser please see below




listermint is offline   Reply With Quote
Old 04-04-2012, 08:20 AM   #212
Cretster
Registered User
 
Join Date: Mar 2012
Location: Isle of Man
Posts: 88
My Ride: E90 320D
Aaargh! Exactly the same as mine then:



So I'm at a loss here. We've used the same Rom builds, the same dongles, the same kernels but yours works and mine doesn't.

Granted yours is E46 and mine is an E90 model but as far as I know that's just really pieces of plastic that are different surely, in terms of fitting the dash?! Bottom line is the same Android software, and same BT dongles, but none of mine work.

Any feasible way that this could be a dynavin hardware fault?!?!
__________________
Cretster is offline   Reply With Quote
Old 04-04-2012, 08:28 AM   #213
NECTOP
Registered User
 
Join Date: Mar 2012
Location: Spb, Russia
Posts: 41
My Ride: Audi A3 Sportback
Cretster

maybe dongles are different, because, for example I have found that Belkin Dongles F5D8053 maybe revision 1 to 5 and all has different hardware in it! So maybe the same sutiation with Bluetooth. The sape of the dongle and id's are the same but different hardware in it!
NECTOP is offline   Reply With Quote
Old 04-04-2012, 09:14 AM   #214
DeadWinter
Registered User
 
Join Date: Mar 2012
Location: Netherlands
Posts: 12
My Ride: E46 320D 2000
Quote:
Originally Posted by NECTOP View Post
Cretster

maybe dongles are different, because, for example I have found that Belkin Dongles F5D8053 maybe revision 1 to 5 and all has different hardware in it! So maybe the same sutiation with Bluetooth. The sape of the dongle and id's are the same but different hardware in it!
I must agree on that.
I have the same issue with a WIFI dongle I originally bought to get my mediaplayer on WIFI. The specs stated I had to get this specific dongle, which I did.... and guess what... It didn't work.

Luckily now I have a dynavin unit with which this WIFI dongle worked first time round. (mind you the dongle that came with the unit doesn't work for me. Haven't tried it with M3Evo's roms yet though.)

To get to the point: the dongle may have the same type number but there are usually multiple revisions so actual hardware differences.

I have looked at several BT dongles, which outside appearance look all exactly the same, but are different HW inside. May just be 1 revision apart, but kills the use of that BT dongle on this unit for now.

When I get mine in I'll start testing and let you know the result and exact HW specs of the dongle.
DeadWinter is offline   Reply With Quote
Old 04-04-2012, 09:19 AM   #215
NECTOP
Registered User
 
Join Date: Mar 2012
Location: Spb, Russia
Posts: 41
My Ride: Audi A3 Sportback
DeadWinter
You knew English better then me, your explanation is much better, but you understand what I ment )
Anyway, I have also ordered Belkin WiFi from eBay, it looks like it's revision 5, also I have ordered noname small BT unit from eBay it looks exectly like one that was posted here at antoher thread. I'll report if it will work with Dynavin.
NECTOP is offline   Reply With Quote
Old 04-04-2012, 09:59 AM   #216
Cretster
Registered User
 
Join Date: Mar 2012
Location: Isle of Man
Posts: 88
My Ride: E90 320D
That's quite a valid point actually.

Plus, yes I've tried 3 different ones, but only 1 was the "same" as a dongle confirmed as working (by Listermint).
I had of course bought a sabrent one too, but got defrauded by the amazon seller who sent me a cheap generic one.

The 3 I have tried all pretty much look the same and are those tiny =D shaped ones, albeit I bought one of them from the ebay link posted on here from the same seller. You're right though that just because it was the same seller and has the same appearance that it actually is the same piece of kit.

Like I mentioned though I've ordered the Logilink one now that is also confirmed as working, and at least I'll know then that it's not just a cheap generic one, as the design/shape/styling is totally different!

I'm not optimistic that will work either, and starting to worry I'll never have it working for OBD/Torque etc at this rate. No-one's fault here of course, and I'm not even sure if this is just android itself being weak in terms of compatibility, or Dynavin not doing their work correctly to ensure it will work for people. I guess for the most part Android will either be in a phone or tablet that already has specific bluetooth hardware, so no need for Android builds usually to cater for tons of different possible hardware/driver variations on a device like that?

Would be great if there was some way of loading in a driver pack or something to increase compatibility for such things.

Anyway, once the new Logilink dongle turns up I'll advise if it works or not but I have a sneaky feeling that isn't going to work either. Again, I hope I'm proven wrong (and it's not often I say that!).



I think any info about specific working hardware like this ought to be collated into the first post of this thread or rather the Android general one, then it's a good reference point for anyone trying to get the bloody things working without masses of searching etc.
__________________
Cretster is offline   Reply With Quote
Old 04-04-2012, 12:08 PM   #217
col panic
Registered User
 
Join Date: Jan 2012
Location: austin
Posts: 18
My Ride: E46 M3
Navigon V2.5.1 is working with this rom!!! I've been trying for months to get any version of navigon to work on this thing and it finally is. Awesome work M3evolution! Beer money sent.

Last edited by col panic; 04-04-2012 at 12:15 PM.
col panic is offline   Reply With Quote
Old 04-04-2012, 03:33 PM   #218
NeedMe
Registered User
 
Join Date: Apr 2012
Location: Rotterdam
Posts: 2
My Ride: BMW E39 528i Touring
Hi m3evolution,

I tried to pm you for the password for over 3 days now but didnt get any response.....message box full ..?
would like to test both firmware on my E39 D99....
guess i have to try pm you for a few more days then.....
NeedMe is offline   Reply With Quote
Old 04-04-2012, 04:18 PM   #219
diddy0071
Registered User
 
Join Date: Mar 2012
Location: Woodland, CA
Posts: 31
My Ride: 2001 E53
Ok. How long does the reboot last? I flashed 1.22 onto my Dynvin. It said eject sd reboot drive safe. Here I am 45 minutes later and No reboot. Help??
diddy0071 is offline   Reply With Quote
Old 04-04-2012, 04:36 PM   #220
al-djazair
Registered User
 
Join Date: Mar 2012
Location: Switzerland
Posts: 48
My Ride: E46 E34 E30
Quote:
Originally Posted by diddy0071 View Post
Ok. How long does the reboot last? I flashed 1.22 onto my Dynvin. It said eject sd reboot drive safe. Here I am 45 minutes later and No reboot. Help??
Just pull out the SD, turn your Dynavin off and on
__________________
'01 E46 330xi
'94 E34 525i
'87 E30 325iX
2 x '86 E30 323i sold for parts
al-djazair is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use