E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-04-2012, 05:28 PM   #1
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Car stalls at idle...

I recently purchased a 2004 330ci. It runs and drives great but it has stalled on me twice sitting at red lights. It starts right back up and drives with no issues. Any idea what could cause this?
Flaboy239 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-04-2012, 05:59 PM   #2
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
I suppose it's possible this car has never in its life received a DME software update. I had a problem with this back in 2004 shortly after I bought my car. A software update resolved the issue. You might contact a dealer and see if they have any record of an update being performed. It's also possible you have an actual maintenance problem but that would require some diagnostics to get to the bottom of things.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 04-04-2012, 06:07 PM   #3
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
The car was tuned by Active Autowerke. Not sure if that means anything. Idk what dme means. I'm new to the bimmer world.
Flaboy239 is offline   Reply With Quote
Old 04-04-2012, 06:18 PM   #4
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
The DME is basically the engine computer. If Active tuned it then you need to talk to them. Is the car stock otherwise? What air filter is in the car?
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 04-04-2012, 06:24 PM   #5
PNWDiego
Registered User
 
Join Date: Mar 2012
Location: PNW
Posts: 72
My Ride: 328ci
check for codes in the computer, that'll give you a clue as to where/what
PNWDiego is offline   Reply With Quote
Old 04-04-2012, 06:26 PM   #6
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
No it's far from stock. The previous owner took it to active and dropped $25k on it. I'm not going to list it all, there's too much. There's a couple threads where I list most of it. Maybe I'll run it through a scanner to see if any codes come up.
Flaboy239 is offline   Reply With Quote
Old 04-04-2012, 06:34 PM   #7
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
Oh, it's that car, the one with the SC'er and too many other mods to list. Yeah, check for codes but you'll still likely want to talk to Active for troubleshooting advice. Could be the tune, could be the MAF, could be any number of things. If you have an oiled air filter (such as K&N), it may have contaminated the MAF. Might want to try some CRC MAF sensor cleaner to see if that helps.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump

Last edited by TxZHP04; 04-04-2012 at 06:36 PM.
TxZHP04 is offline   Reply With Quote
Old 04-04-2012, 06:39 PM   #8
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
It had AA headers on it and was tuned for the headers and no cats. The dealership hat to put the stock manifolds and cats back on it in order to legally sell it. I thought maybe that could have something to do with it. I need to get the headers on ASAP.
Flaboy239 is offline   Reply With Quote
Old 04-04-2012, 08:38 PM   #9
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
I don't know that it's impossible but it seems highly improbable that stalling at idle is related to the header switch.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 04-06-2012, 03:13 AM   #10
YOLO89
Registered User
 
Join Date: Apr 2012
Location: Tampa, FL
Posts: 138
My Ride: Hooptie
I too have the same issue it even stalled on me while making a turn. I've ran it for codes and haven't found anything. Mine isn't modded either but let me know if you ever figure out what the issue may be...
YOLO89 is offline   Reply With Quote
Old 04-07-2012, 12:44 PM   #11
fatboyx9
Registered User
 
Join Date: Feb 2012
Location: US
Posts: 54
My Ride: 325Ci 330i
I have a 325Ci and dies occassionally while backing up, has dies a few times while pulling out in first. I cleaned the MAF sensor with CRC cleaner. It's a 5 speed. Still trying to figure this out.
fatboyx9 is offline   Reply With Quote
Old 04-07-2012, 02:13 PM   #12
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
For those of you without engine mods and no stored codes, try cleaning your ICV.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 04-07-2012, 04:07 PM   #13
fatboyx9
Registered User
 
Join Date: Feb 2012
Location: US
Posts: 54
My Ride: 325Ci 330i
Replaced my ICV.
fatboyx9 is offline   Reply With Quote
Old 04-07-2012, 04:24 PM   #14
xixixi
Banned User
 
Join Date: Aug 2009
Location: St Louis, MO
Posts: 3,008
My Ride: 01 330x-xi
It's your maf or an intake leak
xixixi is offline   Reply With Quote
Old 04-07-2012, 04:38 PM   #15
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
Quote:
Originally Posted by fatboyx9 View Post
Replaced my ICV.
Have you scanned for codes? Checked fuel trims? I only suggested ICV if these other things didn't pan out.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 04-07-2012, 04:39 PM   #16
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Now my check engine light is on. I'll scan it Monday and see what pops up.
Flaboy239 is offline   Reply With Quote
Old 04-07-2012, 04:42 PM   #17
xixixi
Banned User
 
Join Date: Aug 2009
Location: St Louis, MO
Posts: 3,008
My Ride: 01 330x-xi
maf or intake leak, get a cigar and start blowing!
xixixi is offline   Reply With Quote
Old 04-07-2012, 04:44 PM   #18
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
That makes sense because sometimes at idle my rpms will get a little erratic for a few seconds. All signs point to intake or vacuum leak.
Flaboy239 is offline   Reply With Quote
Old 04-07-2012, 04:46 PM   #19
xixixi
Banned User
 
Join Date: Aug 2009
Location: St Louis, MO
Posts: 3,008
My Ride: 01 330x-xi
5 dollars please! This is a test you can do, hammer the throttle until you get to a corner, mash on the brakes. I bet that thing dies GL man
xixixi is offline   Reply With Quote
Old 04-07-2012, 05:06 PM   #20
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Check is in the mail...
Flaboy239 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use