E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-06-2012, 05:45 AM   #1
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Squeaky supercharger pulley

I got an AA sc kit and the pulley squeaks like crazy. It didn't do this when I bought the car a week ago. When it's cold it's really bad. It gets better when it warms up but doesn't go away. It's very annoying. Any suggestions on the best way to fix this? I don't want to just start spraying **** on it and making a mess or possibly do more damage.
Flaboy239 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-06-2012, 06:26 AM   #2
pilot1ner
Registered User
 
Join Date: Oct 2006
Location: palm sings ca
Posts: 187
My Ride: e46
Are you sure its the supercharger pulley and not another pulley? I remember mine did the same thing but it wasnt the supercharger being that it didnt have any bearings.
pilot1ner is offline   Reply With Quote
Old 04-06-2012, 07:14 AM   #3
bobm3
Senior Eurowerkz Member
 
bobm3's Avatar
 
Join Date: Jun 2002
Location: bklyn
Posts: 12,714
My Ride: 2003m3smg
i think you may have to

Quote:
Originally Posted by Flaboy239 View Post
I got an AA sc kit and the pulley squeaks like crazy. It didn't do this when I bought the car a week ago. When it's cold it's really bad. It gets better when it warms up but doesn't go away. It's very annoying. Any suggestions on the best way to fix this? I don't want to just start spraying **** on it and making a mess or possibly do more damage.
adjust the belt .. that is what happen to my s/c had the same noise..... it is a easy fix....you should call aa just to confirm on what i said...
bob
__________________
bobm3 is offline   Reply With Quote
Old 04-06-2012, 07:31 AM   #4
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,377
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
There is adj. on the back of the s/c for the belt and holding of the S/C.
TrippinBimmer is offline   Reply With Quote
Old 04-06-2012, 09:37 AM   #5
332xi
Registered User
 
Join Date: Jul 2008
Location: haymarket, va
Posts: 142
My Ride: too fast e46/330xi
plus 1 on the belt. it sounds like it's too loose. either adjust like trip said or find a size smaller belt for your pulley.
332xi is offline   Reply With Quote
Old 04-06-2012, 01:56 PM   #6
joshzhp
Registered User
 
Join Date: Feb 2008
Location: CA
Posts: 289
My Ride: ZHP--Stock
Easy to see if the adj. is installed and tight
joshzhp is offline   Reply With Quote
Old 04-06-2012, 02:15 PM   #7
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Anyone got a pic of where I can adj the tension or is it obvious?
Flaboy239 is offline   Reply With Quote
Old 04-06-2012, 06:38 PM   #8
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Here's the squeak. Hopefully the video works.

Nm, couldn't get it to work...

Last edited by Flaboy239; 04-06-2012 at 06:41 PM.
Flaboy239 is offline   Reply With Quote
Old 04-09-2012, 11:34 AM   #9
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
It appears to be the lower idler pulley that's attached to the supercharger mounting bracket. There appears to be some surface rust. I'm going to take it apart and clean/lube it to see if it helps.
Flaboy239 is offline   Reply With Quote
Old 04-09-2012, 04:24 PM   #10
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Well that wasn't it. That pulley was in good shape. While the belt was loose I checked the tensioner pulley and it seemed fine also. It's def coming from the drivers side. What the hell is it?? It's very loud and very annoying.
Flaboy239 is offline   Reply With Quote
Old 04-09-2012, 04:56 PM   #11
joshzhp
Registered User
 
Join Date: Feb 2008
Location: CA
Posts: 289
My Ride: ZHP--Stock
PM sent

Last edited by joshzhp; 04-09-2012 at 04:58 PM.
joshzhp is offline   Reply With Quote
Old 04-09-2012, 05:28 PM   #12
joshzhp
Registered User
 
Join Date: Feb 2008
Location: CA
Posts: 289
My Ride: ZHP--Stock
Problem solved.
joshzhp is offline   Reply With Quote
Old 04-09-2012, 05:41 PM   #13
Flaboy239
Registered User
 
Join Date: Apr 2012
Location: Fort Myers, FL
Posts: 213
My Ride: 2004 330ci
Easy fix. Thanks bro
Flaboy239 is offline   Reply With Quote
Old 11-27-2013, 07:13 PM   #14
DylanFulton7
Registered User
 
Join Date: Oct 2012
Location: Barrie, ON
Posts: 119
My Ride: 545i/6
Sorry to bring this back from the dead... What was the fix? I'm having the same squeaking and it's driving me mad!
__________________


"Speed has never killed anyone. Suddenly becoming stationary, that's what gets you."
- Jeremy Clarkson

Supercharged 328Ci - SOLD
C32 AMG - SOLD
E53 X5 - SOLD
DylanFulton7 is offline   Reply With Quote
Old 11-29-2013, 11:21 AM   #15
Viral@ActiveAutowerke
Sponsor
 
Viral@ActiveAutowerke's Avatar
 
Join Date: Nov 2008
Location: Miami, Florida
Posts: 1,154
My Ride: E46 M3
Quote:
Originally Posted by DylanFulton7 View Post
Sorry to bring this back from the dead... What was the fix? I'm having the same squeaking and it's driving me mad!
You would have to try adjusting the turn buckle on the back of the blower it has a bit of play with it which should help stop the belt squeal. If you have any questions please feel free to contact me directly via E-Mail at Viral@activeautowerke.com
__________________
Viral Vahia
Active Autowerke | 9940 SW 168 Terrace Miami, Florida 33157
www.activeautowerke.com | viral@activeautowerke.com
Phone: 305.233.9300 Ext. 232 | Fax: 305-253-8921
Viral@ActiveAutowerke is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use