Preparing my e46 for boost. would like some advise - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum

Forced Induction Forum
Discuss supercharging, turbocharging and even nitrous and water injection here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-20-2012, 04:09 PM   #1
silver46
Registered User
 
Join Date: Apr 2012
Location: bountiful
Posts: 34
My Ride: United States
Preparing my e46 for boost. would like some advise

Have a 2004 BMW M3 vert 100k + miles

Am purchasing a VF SC kit and am going to upgrade it to the latest stage.

My car is having a strange intermittent power issue sometimes it feels really fast other times it bogs and or is super slow feels like a 40-50 hp loss. I can get it on my Dyno to verify when i have time.

also it hunts for idle sometime. I have cleaned the maf etc seams to help for a bit. one other thing it has a bad rattle during cold start for a few sec.

Am not super familure with this platform yet so a little advice will help and yes i have searched lol

I am planning on adjusting the valves as well as replacing the gaskets for the Vanons very soon.
silver46 is offline   Reply With Quote
Old 04-20-2012, 04:11 PM   #2
AMG-ETR
Registered User
 
Join Date: Mar 2006
Location: New York
Posts: 2,292
My Ride: S54B32 On Boost
Send a message via MSN to AMG-ETR
check your coils - would also be good to do inspection II before your S/C install.
__________________


AMG-ETR is offline   Reply With Quote
Old 04-20-2012, 04:13 PM   #3
silver46
Registered User
 
Join Date: Apr 2012
Location: bountiful
Posts: 34
My Ride: United States
Great didnt even think of that. Ill just purchase some new ones. I think it recently had the fuel pump replaced tho not sure on the filter or even the brand of fuel pump.
silver46 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-20-2012, 04:14 PM   #4
funkboy316
Registered User
 
Join Date: Jun 2008
Location: san antonio texas
Posts: 1,268
My Ride: 2003 M3 vert
Sounds like a vanos problem to me
__________________

2003 TiAg HPF stage 2.5 SMG M3 vert
funkboy316 is offline   Reply With Quote
Old 04-20-2012, 04:19 PM   #5
silver46
Registered User
 
Join Date: Apr 2012
Location: bountiful
Posts: 34
My Ride: United States
would it be just the seals as the common issue or is there a way to resolve if its the actual vanos unit itself? Thanks.
silver46 is offline   Reply With Quote
Old 04-20-2012, 05:38 PM   #6
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,066
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
Whatever it is, get it nailed down before you put on the kit.
__________________
aggieE46 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 07:04 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.