E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-16-2013, 08:36 PM   #41
spdracr137
Registered User
 
Join Date: Nov 2009
Location: az
Posts: 22
My Ride: 323i
Quote:
Originally Posted by SeanC View Post
Interestingly enough, I had a single misfire code on that same cylinder. Had to replace the fuel pump, and no more misfires.
This happened to me too. I replaced, ccv, disa, plugs, tried swaping coils/injectors, checked for vacuum leaks and it ended up being my fuel pump. Doesn't make any sense to me but my pump died one day and after replacing it, the missfire never came back. Still have no idea how that caused only a single cylinder missfire but it did.
spdracr137 is offline   Reply With Quote
Old 04-24-2015, 12:49 AM   #42
kezzzer
Registered User
 
Join Date: Apr 2015
Location: Santa Barbara
Posts: 3
My Ride: E46
same issue

i have the exact same issue and i put a new pack and plug in there, yet once it warms up a bit it does start to misfire. i have the C110 diagnostic tool for bmw and i can tell you he was correct as in once you reset/ erase the code the car does run better for a few mins before it does it again. i was going to replace the wiring loom thinking it maybe has a bad wire inside but if any of your was fixed by a new fuel pump then i will be chacking the pressure for sure as well as the piston pressure. will let you all know but it is a wierd fault, how did you put it?? the computer does not reset and it runs fine after..but it does
kezzzer is offline   Reply With Quote
Old 04-24-2015, 12:52 AM   #43
kezzzer
Registered User
 
Join Date: Apr 2015
Location: Santa Barbara
Posts: 3
My Ride: E46
as i noticed on mine at this point you are wrong !!! the car DOES seem to say its reset now run ok coz thats exactly what happens. i believe it may be a fuel pump issue but will test pressure
kezzzer is offline   Reply With Quote
Old 04-27-2015, 10:07 PM   #44
kezzzer
Registered User
 
Join Date: Apr 2015
Location: Santa Barbara
Posts: 3
My Ride: E46
same issue

same cylinder also. tried trading packs plugs and injectors but no good as same fault next step compression test. interesting side note for you though as i read a few of these posts i tried new things as they were posted and found a video on youtube that shows if the rings look bad they may not be as its a thing with these cars so ordered the X66p upper engine cleaner just in case.
As i said.... a side note last time i started it 2 days ago after moving injectors i noticed i could not hear the pump under the seat but the cover was on. can't you normally hear it anyhow??
Stumped
kezzzer is offline   Reply With Quote
Old 06-22-2016, 07:32 PM   #45
412ZHP
Registered User
 
Join Date: Aug 2015
Location: Pittsburgh
Posts: 11
My Ride: 2003 330i ZHP
Same cylinder 5 misfire problem. If I clear it will come back, sometimes along with misfires 4 or 6, but I had Carsoft 6.5 connected and it indicated a cylinder 5 misfire first. First replaced 5 and 6 cylinder coils and plugs, as these were throwing codes first, didn't help. When I rev past 3500-4000 at a standstill, on the way back down to idle I hear a strange tapping sound with rpm dips, evens out after 10 seconds or so. When driving up a hill, the vehicle will not exceed 4000 rpm even when floored, then it enters a limp mode nearly stalling while returning to idle. I hear a sort of whirling around my air distribution equalizer, just changed out the 6 o rings on that. Inspected all intake boots, replaced throttle body gasket, cleaned throttle body and ICV, cleaned MAF, replaced DISA o ring and inspected it by holding my thumb over the hole, the DISA flap held in place and seemed to function properly. Replaced CCV.

Next on my list would be fuel pump, any other suggestions?

Thanks for your help in advance!
Tony
412ZHP is offline   Reply With Quote
Old 06-22-2016, 08:10 PM   #46
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 19,193
My Ride: 330CiC, M5, X5
http://forum.e46fanatics.com/showthread.php?t=1052977

http://forum.e46fanatics.com/showthr...1#post16833498

http://forum.e46fanatics.com/showthread.php?t=870338
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 06-22-2016, 08:43 PM   #47
412ZHP
Registered User
 
Join Date: Aug 2015
Location: Pittsburgh
Posts: 11
My Ride: 2003 330i ZHP
The DME is one area I didn't check, I'll do some diagnosing when I get off work. Looks like a blast!

Thanks for the suggestions
Tony
412ZHP is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use