E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-10-2012, 08:34 AM   #1
shathiso morima
Registered User
 
Join Date: Mar 2012
Location: Botswana,Gaborone
Posts: 15
My Ride: Bmw E46 318I
Exclamation E46 318I 2000 Model wont start!!!

Hello Guys,Im having a promblem with my E46 318i,the other day i was driving and after travelling over 350km the rev counter started moving up and down real fast until the car shut off on its own,at the workshop i found out that no 2 and 3 cylinders had no spark at all.I then changed the coil with a second hand one and the problem was still there,i checked the fuses in the ECU box and they look all fine!please help could this be the ECU?
shathiso morima is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-10-2012, 08:57 AM   #2
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,858
My Ride: '99 328i 1.04646 mu
I'm no expert, but I'd suggest that first you tell us more about your car. Is it automatic (I assume)? How many miles? What all did they check at the workshop?

You had two cylinders not firing but said you changed 'a' coil...I assume you meant both of them, is that correct?

Since you used 'used' coils, one simple test is to move the coils to other cylinders and see if you get the same cylinders misfiring or not...that would at least confirm whether it's the used coils that are an issue or something else.

Also, because they were numbers 2 & 3, I'd think that that might stop you. Also, sorry, but I don't even know, but I think you might be a four-cylinder, is that right? Sorry...as I said, I don't know everything.

Getting codes read is really important too...get the obdII codes and search for them here using advanced/title search.

Many things can stop your car. You didn't say if you were cranking or not...very important for us to know that also.

It almost sounds like you just ran out of gas--our fuel level gauge is run by a fuel level sender under the rear seat and it often fails to read accurately...and it could be as simple as that...and because it could be that simple, might be something a shop might miss...as stupid as that sounds. They're so 'into' finding issues, that they can pass right by the basics...and I see this here all the time. Guys with bad batteries, or running out of gas, seeing similar symptoms to those with 'expensive' problems thinking that must be it.

Start with the basics...and gas is a pretty important one!

Anyway, that's a start for you and I hope it helps!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 03-10-2012, 09:16 AM   #3
shathiso morima
Registered User
 
Join Date: Mar 2012
Location: Botswana,Gaborone
Posts: 15
My Ride: Bmw E46 318I
Thanx bro,Ok my car is an E46 318i Manual 2000 model,Its a 4 cyclinder with 157000km done,i also tested the fuel pump with a new one and there was no difference,I tried to connect to the Computer but it couldnt connect,i also removed no 2 and 3 cable and tested it on 1 coil socket and they worked just fine so the cables work just fine.The car cranks normaly and engine runs for two seconds then shuts off!!please help!!

Last edited by shathiso morima; 03-10-2012 at 09:18 AM. Reason: Typing error
shathiso morima is offline   Reply With Quote
Old 03-10-2012, 09:25 AM   #4
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,858
My Ride: '99 328i 1.04646 mu
So you're sure you have a lot of fuel? Had you maybe filled up recently at a different petrol station? Just trying to make sure you don't skip over this basic and throw tons of money and time at it to no avail...I've seen this happen a lot here.

That it's not connecting to the computer is curious...could just be a plug issue, but I don't know.

Have you checked the fuses in the e-box under the hood (assuming that's where it is on your car).

Also, spaghettidecoder.com will have TISs for you to check and will give you wiring diagrams/fuse numbers to doublecheck.

It'll be tough for us without codes, you know...they'll all be guesses, I'm pretty sure, and as I said, hate seeing guys toss money away on a hope and a prayer...though it sounds like you might need both...unless, again, it's just low gas. I assume you saw plenty of gas when you swapped out the fuel pump.

GL! Sorry I can't guess any better!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 03-10-2012, 09:33 AM   #5
shathiso morima
Registered User
 
Join Date: Mar 2012
Location: Botswana,Gaborone
Posts: 15
My Ride: Bmw E46 318I
Hey bro i have half tank,i think i wil have to double check the fuses and also i was wondering if the camshaft position sensor could cause the Ecu not to send the sparks or what..i wil post videos on youtube in 3hours
shathiso morima is offline   Reply With Quote
Old 03-11-2012, 08:15 AM   #6
shathiso morima
Registered User
 
Join Date: Mar 2012
Location: Botswana,Gaborone
Posts: 15
My Ride: Bmw E46 318I
Bmw E46 318i won't start

Hello Guys,Im having a problem with my E46 318i Manual 2000 model, Its a 4 cylinder with 157000km done ,the other day i was driving and after travelling over 350km the rev counter started moving up and down real fast with horrible sounds from the engine until the car shut off on its own, at the workshop no 2 and 3 cylinders had no spark at all.I changed the coil with a second hand one and the problem was still there,i checked the fuses in the ECU box and they are fine! Please help could this be the ECU? I also replaced the fuel pump with a new one and there was no difference, I connected the car to the Computer but it couldn’t connect to the ECU,i also removed no 2 and 3 cable and tested it on 1 coil socket and they worked just fine so the cables work just fine. The car cranks normally and engine runs for two seconds then shuts off!!please help!! i have half tank and also i was wondering if the camshaft position sensor could cause the ECU not to send the sparks or what..I recorded this video 10min after the car stoped,its on facebook i couldn’t upload on YouTube im sorry.
shathiso morima is offline   Reply With Quote
Old 03-11-2012, 08:39 AM   #7
Mickle207
Registered User
 
Join Date: Dec 2011
Location: Amsterdam
Posts: 74
My Ride: E46 318Ci
Have you checked whether you have a faulty Mass Airflow sensor?
Mickle207 is offline   Reply With Quote
Old 03-11-2012, 08:51 AM   #8
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,858
My Ride: '99 328i 1.04646 mu
...might as well keep everything in one thread, OP, so you don't cover the same ground over and over.

It's okay to bump your own thread after it's fallen off the radar.
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 03-11-2012, 08:53 AM   #9
Mickle207
Registered User
 
Join Date: Dec 2011
Location: Amsterdam
Posts: 74
My Ride: E46 318Ci
Oh this is a double post.....
Mickle207 is offline   Reply With Quote
Old 03-11-2012, 09:08 AM   #10
shathiso morima
Registered User
 
Join Date: Mar 2012
Location: Botswana,Gaborone
Posts: 15
My Ride: Bmw E46 318I
Oh thnx for the advise,yes i tried unplugin the Air Flow Sensor bt nothing changed
shathiso morima is offline   Reply With Quote
Old 07-06-2012, 04:31 PM   #11
shathiso morima
Registered User
 
Join Date: Mar 2012
Location: Botswana,Gaborone
Posts: 15
My Ride: Bmw E46 318I
Talking Solved!!

Ecu was burnt Real Bad!!!
shathiso morima is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use