E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-16-2012, 10:57 PM   #1
xphiledan
Registered User
 
Join Date: Oct 2010
Location: East Hanover, NJ
Posts: 70
My Ride: 01 330i, 89 325i
Angry Bought a supercharged E46, got ripped off - need help getting the car running

I find a 2001 330i 5MT with an Active Autowerks Rotrex C30 kit on craigslist 30 mins from my house. Test drove the car. Owner tells me full maintenance history. He says no problems except for an SES that shows up every couple years or so - just need a MAF cleaning.

I buy the car, couple days later P0172 P0175 SES codes appear (Bank 1 & 2 running rich). I clear the codes and clean the MAF. A few days later, the weather hits 100F - SES reappears and the car goes into limp mode. Refuses to rev over 2k-2.5k. I park the car, come back later in the day when temp drops below 85 and the car drives fine with no codes for the next few days when the temp is in the 70s. Behavior occurs again as soon as temp hits 90F. It throws additional misfire codes. I call the PO - he says he's never seen the limp mode issue.

I install a new MAF. Same problem. Car does not like warm temperatures. Some days are better than others. I encounter a new code P1603 (Control Module Self Test, Torque Monitoring).

After searching the forums, I come across a surprise. I come across a thread describing the very same issues that I have. I look at the signature, same mods, same color... I look at the town and the screen name. GOD DAMN IT. The PO is on this forum, and created a thread 2 years ago with the same problem. He's had at least 4 shops look at the car with no results. Each shop says it's a problem with the supercharger, but can't identify the problem.

He listed all of his troubleshooting steps
- replaced vanos w new seals
- replaced head unit, black box, sensors,
- cleaned ICV, DISA
- checked O2 sensors
- looked for vacuum leaks
- replaced all the clamps
- scanned with GT1
- checked battery
- checked engine to chassis ground strap
- checked Alternator
- replaced valve cover
- smoke test & repaired small leaks
- checked w UV light
- replaced vortech fmu

At this point, there's nothing I can do with regards to the previous owner. I'm primarily concerned with trying to figure out what to do with this car. Unfortunately, I sold my previous daily driver, so I'm a bit stuck. I need help with trying to get this machine running reliably.

So I have 3 options:
- pull the supercharger, return the car to stock
- fix the running rich issue
- get rid of the car

Does anyone know of any issues with supercharger uninstalls? Aside from the airbox / ecu, are there any parts I need to acquire?

Do you think he's caused any damage to the engine/cats by driving the car with this problem for the past 2 years for over 15,000+ miles?

Limp mode issues aside, I like this car. Body and interior is clean. I'm inclined to wanting to keep this car. Unfortunately, I just spent a decent amount of money getting new tires and brakes.

My intention for this post is to not seek vengeance, and I will not post the previous owner's screen name/info. Nor am I saying anything bad about the AA kit. I just need help getting out of my sucky situation. Thanks much.

Last edited by xphiledan; 06-18-2012 at 11:27 AM.
xphiledan is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-16-2012, 11:49 PM   #2
mtnbound
Town Clown
 
Join Date: Nov 2002
Location: Yay Area
Posts: 15,071
My Ride: 330Ci Vert, 325iT
Well, if it's this guy, you may want to check that your A pillar isn't leaking as well. After all of those problems with the supercharger, he actually then posted it for sale, so it's clearly not beyond him to hide the full truth.

http://forum.e46fanatics.com/showthr...197&highlight=

Given all of those problems, I'd definitely return everything back to stock.
__________________
**********************
Bay Area Top Dropper
Orient Blue 330 Ci Vert
**********************
mtnbound is offline   Reply With Quote
Old 06-17-2012, 12:29 AM   #3
Dreikraft
Registered User
 
Join Date: Jun 2008
Location: Alaska :(
Posts: 688
My Ride: slow m3
yo utry calling the shop to make sure the head unit was actually replaced?
Dreikraft is offline   Reply With Quote
Old 06-17-2012, 12:42 AM   #4
mestupmonkydude
Modded ///Member
 
mestupmonkydude's Avatar
 
Join Date: Jul 2008
Location: Oregon, WI
Posts: 676
My Ride: 328i
Take it to Maximum PSI I bet they could figure it out.
mestupmonkydude is offline   Reply With Quote
Old 06-17-2012, 07:55 AM   #5
xphiledan
Registered User
 
Join Date: Oct 2010
Location: East Hanover, NJ
Posts: 70
My Ride: 01 330i, 89 325i
i'll pay a visit to the guys at maximum psi. tks.
xphiledan is offline   Reply With Quote
Old 06-17-2012, 09:46 AM   #6
02black330ci
Registered User
 
Join Date: Mar 2005
Location: ^^ E46FANATICS ^^
Posts: 1,814
My Ride: spaceship
Yes, Maximum PSI man, I am sure they will figure it out.
__________________






02black330ci is offline   Reply With Quote
Old 06-17-2012, 11:12 AM   #7
jacobs323i
Registered User
 
Join Date: Jul 2008
Location: saint paul
Posts: 786
My Ride: blown 323i
What a lying piece of ****!!! You know where he lives and payback is a dish bestcserved cold!
jacobs323i is offline   Reply With Quote
Old 06-17-2012, 11:48 AM   #8
STORMER
Registered User
 
Join Date: Sep 2009
Location: Canada
Posts: 1,050
My Ride: AA SC 98 M3
I feel your pain hope you can get it figured out
__________________


360+rwhp

AA Stage 2, Arp2000, Underdrive Pulley, M50 Manifold, Cat Delete, Supersprint Exhaust, M5 Clutch w/ Lightweight Flywheel, Euro Fan, FK Coilovers, AEM Boost Gauge, Zhp Knob, Stoptech Brakes, R1 Rotors

Quote:
Originally Posted by Sweetness View Post
You sir, just thread jacked the sh!t out of OP.
STORMER is offline   Reply With Quote
Old 06-18-2012, 12:29 AM   #9
MSpired
Registered User
 
Join Date: Aug 2002
Location: Los Angeles, CA, USA
Posts: 4,060
My Ride: HPF Stage 2.5 e46 M3
Send a message via AIM to MSpired Send a message via MSN to MSpired Send a message via Yahoo to MSpired
Have the ignition coils been replaced? I don't see that listed as something that the fawkface PO changed. I would change the fuel filter also if it has never been replaced.
__________________
MSpired is offline   Reply With Quote
Old 06-18-2012, 11:24 AM   #10
eeleaj
Registered User
 
Join Date: Aug 2007
Location: san bernardino
Posts: 132
My Ride: Boost 325xi
If I were you I would post the PO info so others don't deal with him anymore. Maybe get him banned or something. It probably doesn't matter to him anymore as he probably doesn't want an e46 anymore. But you got served a bad deal with invisible bandaids all over it
__________________
eeleaj is offline   Reply With Quote
Old 06-18-2012, 11:29 AM   #11
Zak@ActiveAutowerke
Sponsor
 
Join Date: Apr 2012
Location: Miami FL
Posts: 58
My Ride: '94 325is
Those codes make it sound like a software issue.

If you can get to Mike @ Maximum PSI he should be able to help. I can work with him to get the software sorted out.
__________________

Software Engineer
www.activeautowerke.com
Zak@ActiveAutowerke is offline   Reply With Quote
Old 06-18-2012, 11:34 AM   #12
xphiledan
Registered User
 
Join Date: Oct 2010
Location: East Hanover, NJ
Posts: 70
My Ride: 01 330i, 89 325i
i just sent the po a letter informing him that i found his thread with a prepaid ups envelope for him to send me any shop records.

i don't think he's planning on getting another bmw. please don't flame him. it's not going to help me, and at this point, i just need the car to run.

mtnbound was correct, this was the po's thread
http://forum.e46fanatics.com/showthread.php?t=739197

i already saved a copy of his original thread in case he chooses to delete his posts, but i think it would still be useful to have his information on the board.

sent an email to active autowerke and maximum psi this morning with my situation. aa as usual was very prompt in responding back - they are convinced it's a air leak, but i'm not too sure considering the po's work. hopefully maximum psi will get back to me soon to book an appt to look at the car this week.
xphiledan is offline   Reply With Quote
Old 06-18-2012, 11:35 AM   #13
xphiledan
Registered User
 
Join Date: Oct 2010
Location: East Hanover, NJ
Posts: 70
My Ride: 01 330i, 89 325i
Quote:
Originally Posted by Zak@ActiveAutowerke View Post
Those codes make it sound like a software issue.

If you can get to Mike @ Maximum PSI he should be able to help. I can work with him to get the software sorted out.
Thank you Zak. I have always been impressed with the level of support AA offers to the community.

I'm hoping it's a software issue as well considering it looks like all the hardware was checked out.

Last edited by xphiledan; 06-18-2012 at 11:41 AM.
xphiledan is offline   Reply With Quote
Old 06-18-2012, 01:52 PM   #14
xphiledan
Registered User
 
Join Date: Oct 2010
Location: East Hanover, NJ
Posts: 70
My Ride: 01 330i, 89 325i
Talked to Maximum PSI on the phone today, bringing the car in next Mon 6/25. Will post updates.

Thanks everyone for the help.
xphiledan is offline   Reply With Quote
Old 06-18-2012, 02:40 PM   #15
STORMER
Registered User
 
Join Date: Sep 2009
Location: Canada
Posts: 1,050
My Ride: AA SC 98 M3
Quote:
Originally Posted by xphiledan View Post
Talked to Maximum PSI on the phone today, bringing the car in next Mon 6/25. Will post updates.

Thanks everyone for the help.
This sounds to me like the best course of action especially after reading po thread. Looks like he never did actually take it into them.

Hope all goes well.
__________________


360+rwhp

AA Stage 2, Arp2000, Underdrive Pulley, M50 Manifold, Cat Delete, Supersprint Exhaust, M5 Clutch w/ Lightweight Flywheel, Euro Fan, FK Coilovers, AEM Boost Gauge, Zhp Knob, Stoptech Brakes, R1 Rotors

Quote:
Originally Posted by Sweetness View Post
You sir, just thread jacked the sh!t out of OP.
STORMER is offline   Reply With Quote
Old 06-18-2012, 02:48 PM   #16
bwallace530
Registered User
 
Join Date: Jan 2011
Location: Oregon
Posts: 1,866
My Ride: 325
Wow I read that old thread seems like the guy really screwed you hope you get it all figured out and doesn't cost a ton.
bwallace530 is offline   Reply With Quote
Old 06-18-2012, 02:53 PM   #17
Crestwood1001
Registered User
 
Join Date: Apr 2012
Location: Pa
Posts: 418
My Ride: 2001 325xi
Gotta look at the bright side to man, if it turns out to be a relatively simple fix that I'm sure these guys can figure out, all the vital parts of the car have be checked out / replaced recently so hopefully you will end up a suck ride!
Crestwood1001 is offline   Reply With Quote
Old 06-18-2012, 03:29 PM   #18
boostedisbetter
Registered User
 
Join Date: Mar 2011
Location: FL
Posts: 1,611
My Ride: 2000 Integra
Quote:
Originally Posted by crestwood1001 View Post
gotta look at the bright side to man, if it turns out to be a relatively simple fix that i'm sure these guys can figure out, all the vital parts of the car have be checked out / replaced recently so hopefully you will end up with a sick ride!
+1
__________________
boostedisbetter is online now   Reply With Quote
Old 06-18-2012, 08:28 PM   #19
Andrew@Activeautowerke
Sponsor
 
Join Date: Nov 2011
Location: Miami FL
Posts: 51
My Ride: 135 Fbo+meth & E85
Op Im sorry to hear about your situation, hopefully we can get to the bottom of this and get you into the car you intended to purchase in the first place !

With Zak and Mike on top of it I'm sure it won't be long
__________________

Email:AFish@ActiveAutowerke.com |Phone:305-233-9300 Ext:227 |Web: www.ActiveAutowerke.com

Authorized Dealer Of | Stop Tech | Brembo | KW Suspensions | Jrz Suspensions | BC Wheels | BC Suspensions | Strasse Forged Wheels | Michelin Tires

Last edited by Andrew@Activeautowerke; 06-18-2012 at 08:29 PM.
Andrew@Activeautowerke is offline   Reply With Quote
Old 06-18-2012, 08:43 PM   #20
pawelgawel
Registered User
 
Join Date: Nov 2010
Location: This is LONDON??
Posts: 919
My Ride: 330CI
op, not many people would act like this in your situation. Props to you for being mature and above the slimes.
hopefully the seller is honest and provides you the records and this problem is fixed asap...




Sent from my SGH-I727R using Bimmer App
pawelgawel is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use