E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-25-2012, 08:46 AM   #1
Wickedly
Registered User
 
Join Date: Jun 2010
Location: New Jersey - Kinnelon
Posts: 846
My Ride: BMW 2003 325i
Transmission emergeny

Good morning everyone ,

Just drove for about 2hours to go to court this Morning and going up and down hills my transmission light came on, lost power and wouldn't go up hills. I could barely drive about 45-55mph and if I try to drive any faster the car will shake sort of like looking for a jump of power . I know in the manual for automatic transmission It says to just turn the car off for a couple of minute and then turn it back on , and I did that and the light has gone off. I'm still haven't drive back yet but I'm scared that it won't be safe, just the drive here was very rough. What do you guys recommend I do? I never had this issue before, my car has 111k miles and no transmission fluid has been done. And is a 2003 325i . Also my engine check like has turn on . I haven't had time to take it to read the codes. I don't know if I should tow my car to the dealer around my house or just towed it to my house? Or just try to drive it with my emergency light .

Thank you very much
__________________
-------------------BMW AW---------------------
Wickedly is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-25-2012, 09:05 AM   #2
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
time to change the transmission fluid and filter see if that fixes it. hope its just low on transmission fluid.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 06-25-2012, 09:08 AM   #3
Drewfus2101
Registered User
 
Join Date: Jan 2009
Location: N/A
Posts: 626
My Ride: N/A
I would disconnect the battery for an hour first, and see what happens. Even better, if you can get it scanned with INPA, it will give you real BMW codes and let you clear or reset them.
Drewfus2101 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use