E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-14-2012, 12:29 PM   #1
graemma1
Registered User
 
Join Date: Jul 2012
Location: newcastle UK
Posts: 2
My Ride: bmw 330ci
bmw 330ci cut out today

A few days ago the battery warning light started to flicker on the dash board, I assumed this is likely to be related to the alternator failing. I started the car today and it stalled which has never happened before but restarted first time. i then went to the local shop and back without any problems. 1 hour later i went out in the car and managed to get 200 metres and the car felt as tho there was no acceleration as if no fuel and cut out and would not restart. So now ive had to leave the car until i get it recovered. I can hear the fuel pump and there is 1/4 of a tank of petrol but it wont fire at all. Whilst on the side of the road i swapped the fuel pump and horn relay but made no difference. Any ideas. Camshaft/crankshaft sensor or the could it still be the fuel pump even tho i can hear it or is there something else it could be.
graemma1 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-15-2012, 02:01 PM   #2
graemma1
Registered User
 
Join Date: Jul 2012
Location: newcastle UK
Posts: 2
My Ride: bmw 330ci
UPDATE, i recovered car today, using a bit easy start into the maf sensor the car fired straight away and ran for around 1 minute then cut out and would not start again. So i removed the fuel pump only to find the tank was empty but i had just put fuel in that same day. i then removed the pump from the other side of tank and found the other side of the tank to be full. For some reason the secondary pump isnt pumping fuel to the other side and when i recovered on back of lorry some fuel must have spilled over onto the other side. Is this likely to just have failed or is there something else that could be causing the problem
graemma1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use