E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 11-21-2012, 03:24 PM   #41
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
Okay would either one thro a check engine light ?
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 12-15-2012, 12:21 AM   #42
DrkSide_RbL
Registered User
 
Join Date: Dec 2008
Location: San Francisco
Posts: 124
My Ride: 99' 328i Sport Sedan
Send a message via AIM to DrkSide_RbL
Quote:
Originally Posted by 03E40sick View Post
Okay would either one thro a check engine light ?
a bad throttle body will throw a check engine light and usually eml+traction control lights.
__________________
DrkSide_RbL is offline   Reply With Quote
Old 02-15-2013, 01:54 PM   #43
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
i am still having the same problem and i am getting so frustrated, i dont know what to do anymore
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 02-17-2013, 01:15 PM   #44
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
Quote:
Originally Posted by 03E40sick View Post
i am still having the same problem and i am getting so frustrated, i dont know what to do anymore
Thats how I feel bro. And theres at least 3 more members here that also feel like this...
Dippinwandy is offline   Reply With Quote
Old 02-18-2013, 12:13 PM   #45
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
one of the guys that works at bmw , told me that it could the DME module
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 02-18-2013, 12:36 PM   #46
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
Thats not good... I still think that one of the wires that goes to the icv might be dead.
Dippinwandy is offline   Reply With Quote
Old 02-18-2013, 12:44 PM   #47
Bluzzer
Registered User
 
Join Date: Jul 2012
Location: N/A
Posts: 44
My Ride: E46 328Ci
Had the same issue. I drive with cold air kit. I found out it was one of the hoses after the filter there have losen op so it took air in after the filter..
Put i back together and i have driven without EML since
Bluzzer is offline   Reply With Quote
Old 02-18-2013, 12:45 PM   #48
GolfingDuck
Registered User
 
Join Date: Oct 2012
Location: Manchester, UK
Posts: 129
My Ride: 540 & 330Ci M Sport
Aren't different headers a known cause of an EML on some cars?
GolfingDuck is offline   Reply With Quote
Old 02-19-2013, 04:40 PM   #49
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
Quote:
Originally Posted by GolfingDuck View Post
Aren't different headers a known cause of an EML on some cars?
I didn't know that plus I have aftermarket headers ..
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 06-18-2013, 04:11 PM   #50
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
any updates ???
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 10-29-2013, 10:07 AM   #51
endat
Registered User
 
Join Date: Sep 2013
Location: fvghfbxvhj
Posts: 6
My Ride: hjvbfvk
I am in the same boat as you guys.. EML has been happening periodically for months (only when I cruise).. I have rebuilt or replaced new everything that is associated with this problem (and then some). No result.

I stopped caring why it does this, and I am getting used to just driving in limp mode.. also looking into how to disable this EML stuff because in my case, the car runs perfectly well. I cut off the BMW's funding (after $hundreds in parts for nothing).

Last edited by endat; 10-29-2013 at 10:08 AM.
endat is offline   Reply With Quote
Old 11-11-2013, 01:15 PM   #52
DPREZ-E46
Registered User
 
Join Date: Jun 2013
Location: Orange County
Posts: 4
My Ride: E46
Post White Smoke

Hi All,
quick question, yesterday I was driving my bimmer E46 325Ci coupe, interstate 5 San Diego southbound and getting close to Encinitas the car started to throw bunch of white smoke from the back pipe, and I noticed that it happens only when I push the gas and the gauge is at 80 miles. Does anyone know what it may be? I'll appreciate the feed back...
DPREZ-E46 is offline   Reply With Quote
Old 11-26-2013, 10:12 PM   #53
anacondatcu
Registered User
 
Join Date: Feb 2010
Location: Ft Worth, Texas
Posts: 57
My Ride: 2000 328i
I was having a problem getting the DSC then EML light which would come on while trying to accelerate mostly on highway or when using cruise control and car would try to work harder to keep same speed up inclines. It would severly decrease power and if over 55mph would not accelerate at all until i took foot off the gas and let lights clear after a second or 2.

I had codes for Idle speed controller and thermostat and both replaced, thermostat because it actually was bad, but still got same codes and same problem with brand new parts.

Anyway went around to multiple dealers and shops not getting anywhere...kept getting told to replace both parts again. Found a shop that actually looked for something else after telling them both parts were new and they found that a connector pin inside the DME had been bent into another pin. bent pin was for ICV and the pin it was contacting was for thermostat.

My suggestion would be if you've already replaced ICV then to look for wiring issues. check the connectors that actually plug into the ICV for damaged, burnt or shorted pins or wires. At one point my headlights would repeatedly flash on and off while driving at night and this ended up being a burnt pin in the TAILLIGHT bulb housing connector so it seems that weird things can happen with our electronics.

link to my thread with image
http://www.e46fanatics.com/forum/sho...d.php?t=855987
anacondatcu is offline   Reply With Quote
Reply

Tags
325i, emission, eml, error code

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use