E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-24-2003, 02:34 AM   #1
XscoreX
Registered User
 
Join Date: Dec 1969
Location: Greenville, sc
Posts: 513
My Ride: the dirt devil
Send a message via AIM to XscoreX
I'm screwed, need expert help

ok so i was hooking up my dreamcast to headrest tv and im a dumb ass and didnt disconnect the battery,i dont know what the hell i did but i think i fried the computer or something, basically all of the indicators on the dash like, temp. trip mileage, mpg, high beams, etc etc, are gone, the headlights will flash high but the indicator light doesnt come on, it still shows mileage &oil change info though, thats it.the cluster gauges work fine . the car drives fine but im afraid the computer might not be sending the engine the right info or something, I dunno, i just dont want to screw up my car.anyone have a suggestion on what might be wrong and if its going to be real expensive to fix, this sucks I just got laid off for the 2nd time this year all i need is a 6k repair bill. thanks
__________________


XscoreX is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-24-2003, 02:38 AM   #2
WarSong
Obey my dog
 
WarSong's Avatar
 
Join Date: Mar 2003
Location: Costa Mesa, CA
Posts: 2,628
My Ride: 2007 Audi A4 3.2Q
Send a message via ICQ to WarSong Send a message via AIM to WarSong Send a message via MSN to WarSong
maybe it's just a fuse? i hope it's something simple like that.
__________________
WarSong is offline   Reply With Quote
Old 06-24-2003, 02:45 AM   #3
XscoreX
Registered User
 
Join Date: Dec 1969
Location: Greenville, sc
Posts: 513
My Ride: the dirt devil
Send a message via AIM to XscoreX
nope i went through & checked all the fuses, it was weird it also made my left headlight go out but I took the bulbs out to check & when i put them back in they worked. weird.
__________________


XscoreX is offline   Reply With Quote
Old 06-24-2003, 08:25 AM   #4
Blazin e46
Registered User
 
Join Date: Oct 2002
Location: Avenel New Jersey
Posts: 295
My Ride: 323Ci
Send a message via AIM to Blazin e46
Look again, a problem like this , 4 times outta 5 is a fuse. I did the same thing back in my last car, connected the PS2, and it blew a fuse.

Good luck
__________________
BLaZiN e46
Blazin e46 is offline   Reply With Quote
Old 06-24-2003, 08:45 AM   #5
328cidriver
Registered User
 
Join Date: May 2003
Location: Tampa, FL
Posts: 51
My Ride: 2000 328ci w/ M pack
Send a message via AIM to 328cidriver
My Advice, based solely on my experience with my car, the electrical systems/networks/cables -- whatever you wanna call it -- SUCK MONKEY A$$ --



my advice to you would be to lube your bung hole and take it to BMW and ask them -- get ready for a butt raping party bud --



i just got mine today from bmw
328cidriver is offline   Reply With Quote
Old 06-24-2003, 09:23 AM   #6
vinnymac
St. Louis BMW Fanatic
 
Join Date: Dec 1969
Location: Saint Louis, Missouri
Posts: 7,155
My Ride: 2011 335is
Send a message via AIM to vinnymac
You man have shorted out the instrument cluster...that's around $500 to replace and a dealer or BMW shop has to do that to sync the odometer.
vinnymac is offline   Reply With Quote
Old 06-24-2003, 11:33 AM   #7
XscoreX
Registered User
 
Join Date: Dec 1969
Location: Greenville, sc
Posts: 513
My Ride: the dirt devil
Send a message via AIM to XscoreX
man i hope its only $500, my sister lives across the street from the BMW plant in s.c. and both my mom & sister drive convertible e36s and they found a guy named gunther, i cant remember the name of his shop but he has a shop and builds custom bmw race engines & stuff like that, apparently he is supposed to be really really good and check this out he only charges $35 an hour for labor! so hopefully I can get out of this without too much pain.
__________________


XscoreX is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use