E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-03-2012, 10:37 AM   #1
Oregon Eric
Registered User
 
Join Date: Jan 2012
Location: Gresham, OR USA
Posts: 3
My Ride: 2003 M3 Convertable
A little trouble putting the top up

I have a 2003 M3 convertable. The top has been down for over a week while it sat in the garage not been driven. When I started the engine the red light by the vert top up/down button was blinking. I press the vert top up button, the red light stayed on like normal. But, the top went up SLOWLY, moving up, them stopping, moving up,then stopping, which took forever! This continued till it was all the way up and locked. Anyone have this problem? Any ideas would be great. thanks.

Last edited by Oregon Eric; 08-03-2012 at 01:08 PM.
Oregon Eric is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-05-2012, 12:42 AM   #2
cityjohn
Registered User
 
Join Date: Nov 2007
Location: Los Angeles
Posts: 2,412
My Ride: 2001 M3
Sounds like you might need to add hydraulic fluid to the pump.
__________________
cityjohn is offline   Reply With Quote
Old 08-08-2012, 06:18 AM   #3
illestminimike
Registered User
 
Join Date: Jan 2012
Location: West Covina CA
Posts: 4,038
My Ride: Project Drama
Could also be a low battery.
__________________
-2005 SMG ZCP Coupe
-1967 Mini Cooper
illestminimike is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use