E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-10-2012, 05:13 AM   #1
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
Thumbs down official limping me crazy

Hey guys so my 330 is driving me crazy. It goes into limp mode when I'm usually going mph+ and throws a p1620 and a p1500 codes but not all the time people where saying maf or map? Idk is just driving me crazy. Anyone know or can point me in the right direction?
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-10-2012, 09:18 AM   #2
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
Ttt
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 08-10-2012, 06:06 PM   #3
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
Bump
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 12-12-2013, 08:38 PM   #4
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
plz anyone still driving me nuts somewhat i think it may have to do with the battery? idk i have replaced the idle air control valve
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 12-13-2013, 01:29 AM   #5
2003silver330i
Registered User
 
Join Date: Feb 2012
Location: N. Las Vegas, NV
Posts: 1,592
My Ride: 03 BMW 330i
The code P1620 has to do with a bad thermostat. Replace it with a genuine OEM thermostat. Concerning the P1500 code I see that you are using a K&N CAI which could be contributing to the P1500 code. If it was my car the first thing I would do is clean the MAF sensor and MAF connector with a cleaner specifically made for the MAF sensor. Next I would clean the connector to the ICV. If none of that stuff clears the code then remove the K&N CAI and put the stock air filter box back in and clean the MAF sensor one last time.
__________________
The 2 happiest days of a BMW owner's life is the day they buy it and the day they sell it.
BMW (Broke My Wallet)


Last edited by 2003silver330i; 12-13-2013 at 01:44 AM.
2003silver330i is offline   Reply With Quote
Old 12-13-2013, 01:37 AM   #6
FooFighter94
Registered User
 
Join Date: Feb 2012
Location: Morgantown, WV
Posts: 276
My Ride: 2001 325Cic
Quote:
Originally Posted by 2003silver330i View Post
The code P1620 has to do with a bad thermostat. Replace it with a genuine OEM thermostat. Concerning the P1500 code I see that you are using a K&N CAI which could be contributing to the P1500 code. If it was my car the first thing I would do is clean the MAF sensor and MAF connector with a cleaner specifically made for the MAF sensor. Next I would clean the connector to the ICV. If none of that stuff clears the code then remove the K&N CAI and put the stock air filter box back in and clean the MAF sensor one last time.
This^
Often times, CAIs which need to be oiled regularly cause MAF problems. I have heard of the oil gunking up the MAF and even destroying it. Never used one so can't say for sure.
__________________
WVU Mountaineer
-2001 325Ci Convertible Slushie
-Orient Blue Metallic
-Koni Yellows, Otherwise hella stock
FooFighter94 is offline   Reply With Quote
Old 12-13-2013, 01:45 AM   #7
2003silver330i
Registered User
 
Join Date: Feb 2012
Location: N. Las Vegas, NV
Posts: 1,592
My Ride: 03 BMW 330i
If none of those suggestions work then you most likely have a wiring issue.
__________________
The 2 happiest days of a BMW owner's life is the day they buy it and the day they sell it.
BMW (Broke My Wallet)

2003silver330i is offline   Reply With Quote
Old 12-13-2013, 07:13 PM   #8
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
Quote:
Originally Posted by 2003silver330i View Post
If none of those suggestions work then you most likely have a wiring issue.
well i am using a light weight battery the maf is as clean as a wistle and thermo was changed about 4 months ago and i have had this issue longer. some people were saying it might be the batt?
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 12-13-2013, 08:08 PM   #9
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 4,653
My Ride: 328i, XC70
The battery can cause limp mode if voltage is too low.
Did you use a generic code reader to scan?

The one reason why I would ever take my car to the dealer is
for diagnosis. It doesn't cost too much and it can save you head ache.

You posted this over a year ago. How often does the car go into limp mode?
__________________
lszlszx is offline   Reply With Quote
Old 12-14-2013, 12:18 AM   #10
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
Quote:
Originally Posted by lszlszx View Post
The battery can cause limp mode if voltage is too low.
Did you use a generic code reader to scan?

The one reason why I would ever take my car to the dealer is
for diagnosis. It doesn't cost too much and it can save you head ache.

You posted this over a year ago. How often does the car go into limp mode?
yeah just a generic code reader. i have been having it off ona dn on but just recently it got worse but it always happens if i keep the throttle steady on a certain speed so its annoying as hell on the freeway lol
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 12-14-2013, 01:15 AM   #11
2003silver330i
Registered User
 
Join Date: Feb 2012
Location: N. Las Vegas, NV
Posts: 1,592
My Ride: 03 BMW 330i
Quote:
Originally Posted by spikester550 View Post
yeah just a generic code reader. i have been having it off ona dn on but just recently it got worse but it always happens if i keep the throttle steady on a certain speed so its annoying as hell on the freeway lol
Bear with me I'm just throwing some ideas out there. Have you tried clearing the codes and unplugging the MAF to see if the car still goes into limp mode?
__________________
The 2 happiest days of a BMW owner's life is the day they buy it and the day they sell it.
BMW (Broke My Wallet)

2003silver330i is offline   Reply With Quote
Old 12-19-2013, 09:06 AM   #12
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,091
My Ride: '06 330CiC, '03 M5
Might want to check toward the end of this thread - http://forum.e46fanatics.com/showthr...ighlight=p1500

The person had intermittent P1500 and after a long time chasing it, turned out it appeared the 12V MAF supply wiring had a break in it. He also has CAI as well.

I see you have a lot of mods on your car, so not sure if and why the wire broke on that car. I know all about the trunk wiring harness breaking at the hinge location, but the MAF wiring should not have a lot of movement and should not break, but maybe the German wiring was not annealed enough and constant heat and vibration cause fractures in the wiring??

Just something to consider.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 01-04-2014, 09:08 PM   #13
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
official limping me crazy

So I did some research cause I was also getting terrible idle rpms. So I cleaned the mad careful and now Im starting to get maf codes so I'm guessing my maf is takin a dump. When I unplug the maf everything works well no idle or 1500 codes so I'm thinking it the maf and the wires? The battery seems to be tight and in good order. If anyone else has any other suggestions don't hesitate =]

Thx guys


Sent from BimmerApp mobile app
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 01-04-2014, 09:54 PM   #14
Weste46
Registered User
 
Join Date: Dec 2011
Location: Westfield, IN
Posts: 662
My Ride: 2001 330ci
Re: official limping me crazy

Swap back to your OE air box before anything. I had constant limp mode with P1500, unplugging MAF stopped limp mode. I ended up replacing my ICV and MAF, same codes. Finally swapped back to OE air box, never came back-until a few days ago when I put my CAI back on to check... definitely the intake in my case, and mine is an Apexi Power filter which is a dry filter.
__________________

Koni STR.T, poly RTABs, headers, SSK.
Three Pedals, ZSP.
Weste46 is offline   Reply With Quote
Old 01-13-2014, 09:26 PM   #15
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
I can't put the oe air box on cause I'm supercharged. There is no room lol. What is a good way to test the maf or the wires for the maf?


Sent from BimmerApp mobile app
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 01-15-2014, 05:36 AM   #16
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
bump if someone has an idea
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 01-19-2014, 06:51 AM   #17
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
someone?
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..

Last edited by spikester550; 01-19-2014 at 06:52 AM.
spikester550 is offline   Reply With Quote
Old 01-24-2014, 03:22 AM   #18
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
=\


Sent from BimmerApp mobile app
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Old 05-05-2014, 11:45 PM   #19
spikester550
Registered User
 
Join Date: Oct 2008
Location: Pasadena
Posts: 1,004
My Ride: 330ci, 86.5 hardbody
Send a message via AIM to spikester550
This week I'm going to throw money at the maf and the wiring harness since it seems that a wire or two looks exposed. Should I just replace the wires or cut back and shrink wrap? Money is not a problem I want it done right.
__________________
MODS
ESS TX2, 3.38 Diff, K&N CAI, 19" LM's, UUC TSE3,
30 LED AE, OEM MT2 Front & Rear,
CF CSL Trunk, Black Kidney Grills, Smoked Corners,
Painted Reflectors, M3 Steering Wheel,
ZHP Shift Knob, Clutch Stop, Shark Injector,
15mm Spacers, 3k DDM HID Fogs, OEM M3 Hood,
Coilovers, UUC Sways, and many more..
spikester550 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use