E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > Australia

Australia
Check out other E46Fanatics members rides in the Enthusist Directory!

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-18-2012, 12:35 AM   #1
RonaldoFC
Registered User
 
Join Date: Aug 2011
Location: Melbourne, Australia
Posts: 53
My Ride: BMW 323Ci
Exclamation E46 323Ci idle problem/error code help

Hey guys,

So i was driving home last night and i stopped at a set of lights and i noticed my car started to idle very rough i could feel the shaking. When i went to accelerate it felt like it just didnt want to go it was revving but wasnt accelerating like normal.

Anyway i scanned it for error codes this morning and got the following results:

202 Lambda Regulation Bank 1 Post Cat
203 Lambda Regulation Bank 2 Post cat
151 Lambda Post Cat Bank 2 Max Limit
154 Lambda Pre Cat Bank 2 Min Limit
241 Misfire Cyl 4
242 Misfire Cyl 5
243 Misfire Cyl 6


Im pretty new to the whole diagnostic thing so any help making sense of all this would be greatly appreciated. Would i be correct in assuming the O2 sensors are the cause of the misfire codes?? Pleaseee help!
RonaldoFC is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-18-2012, 01:23 AM   #2
selien
davconelectric gaycar maker
 
selien's Avatar
 
Join Date: Dec 2010
Location: Sydney
Posts: 2,297
My Ride: 330CI
misfire could be a spark plugs, coil packs, might be MAF but with 3 misfire codes, maybe vac leak?
__________________
109 in a 50 Zone - WIN

selien is offline   Reply With Quote
Old 08-18-2012, 02:49 AM   #3
RonaldoFC
Registered User
 
Join Date: Aug 2011
Location: Melbourne, Australia
Posts: 53
My Ride: BMW 323Ci
thanks for the reply ye i thought it might be a vac leak but i wouldnt know how to test for it? any suggestions or am i better off just taking it to a mechanic?
RonaldoFC is offline   Reply With Quote
Old 08-19-2012, 01:40 AM   #4
Commando
Registered User
 
Join Date: Sep 2011
Location: WA
Posts: 184
My Ride: '02 325Ci Manual
I think the lambda sensors are reacting to the misfires rather than causing them. Also the lambda sensors have very little (if any) influence when you are accelerating or moving the throttle.

Vacuum leaks is a good call but wouldn't all the plugs report problems? Depends where the leak is I guess. Soapy water 'painted' around the manifold will make the idle change when you get the right spot.

MAF, Fuel pump, fuel filter/regulator, DISA flap.

Last edited by Commando; 08-19-2012 at 01:42 AM.
Commando is offline   Reply With Quote
Old 08-19-2012, 05:11 PM   #5
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,010
My Ride: Rules1 & 2: S T F U!
^ should add CPSs to that list
__________________
E46 Coupe is offline   Reply With Quote
Old 12-23-2012, 10:28 AM   #6
Bmwtay
Registered User
 
Join Date: Dec 2012
Location: Vancouver Canada
Posts: 7
My Ride: 2000 323CI E46
I just had the problem with my 323CI... My idle was erratic, I had loss of power, I noticed I was burning a bit of oil... I replace the PCV valve + hoses + spark plugs... Fixed everything! At a shop parts and labour cost me 800... Hope this helps.
Bmwtay is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use