E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-22-2012, 09:45 PM   #1
imagine-02
Registered User
 
Join Date: Mar 2012
Location: WI
Posts: 30
My Ride: 330i
My Kosei's wont fit

I just got some new Kosei k1's from Tire Rack and the center bore doesn't seem to fit.
Do they just go on super tight or something? I tried wiggling and pushing a little and it still wouldn't go on all the way.

imagine-02 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-22-2012, 10:15 PM   #2
Lemonsqr
Registered User
 
Join Date: Sep 2003
Location: Chicago, IL
Posts: 3,133
My Ride: 2001 TiAg 330i
Do you have much rust/corrosion on the hub? Do the Koseis have a centering ring? maybe it needs to be removed?
__________________
Lemonsqr is offline   Reply With Quote
Old 08-23-2012, 07:19 PM   #3
tock172
Beachtown Bill Collector
 
tock172's Avatar
 
Join Date: Jan 2011
Location: San Diego
Posts: 2,905
My Ride: '99 Techno Violet M3
Have you resolved this issue?
__________________


1999 Techno Violet Metallic BMW M3
2005 Audi B6 S4 quattro 6MT
2004 BMW 330i
1986 BMW 535i

tock172 is offline   Reply With Quote
Old 08-24-2012, 09:19 AM   #4
imagine-02
Registered User
 
Join Date: Mar 2012
Location: WI
Posts: 30
My Ride: 330i
Resolved.
I think it was a combination of rust build up on my car and paint build up in the center bore of the wheels.
Funny thing is, both driver sides went on hard and both passengers sides went on super easy.
When I say hard, I don't mean it was really that hard. They just had to be "sucked" on by tightening the lug bolts.
So it's all good now.

255/40-17 Star Specs handle pretty darn good btw. Loving this square setup so far.
imagine-02 is offline   Reply With Quote
Old 08-24-2012, 11:59 AM   #5
tock172
Beachtown Bill Collector
 
tock172's Avatar
 
Join Date: Jan 2011
Location: San Diego
Posts: 2,905
My Ride: '99 Techno Violet M3
Quote:
Originally Posted by imagine-02 View Post
Resolved.
I think it was a combination of rust build up on my car and paint build up in the center bore of the wheels.
Funny thing is, both driver sides went on hard and both passengers sides went on super easy.
When I say hard, I don't mean it was really that hard. They just had to be "sucked" on by tightening the lug bolts.
So it's all good now.

255/40-17 Star Specs handle pretty darn good btw. Loving this square setup so far.
Awesome to hear everything worked out. I will be ordering a set of these in the next 2 weeks, and I have a set of 4 255/40R17 Star Specs sitting in my garage waiting to be shredded at the next autocross
__________________


1999 Techno Violet Metallic BMW M3
2005 Audi B6 S4 quattro 6MT
2004 BMW 330i
1986 BMW 535i

tock172 is offline   Reply With Quote
Old 08-24-2012, 12:32 PM   #6
mbnz230
Registered User
 
Join Date: May 2008
Location: Boston, MA
Posts: 212
My Ride: 2004 BMW 325ci
at first glance, i thought the pic was of a speaker
mbnz230 is offline   Reply With Quote
Old 08-24-2012, 01:27 PM   #7
Lemonsqr
Registered User
 
Join Date: Sep 2003
Location: Chicago, IL
Posts: 3,133
My Ride: 2001 TiAg 330i
Quote:
Originally Posted by imagine-02 View Post
Resolved.
I think it was a combination of rust build up on my car and paint build up in the center bore of the wheels.
Funny thing is, both driver sides went on hard and both passengers sides went on super easy.
When I say hard, I don't mean it was really that hard. They just had to be "sucked" on by tightening the lug bolts.
So it's all good now.

255/40-17 Star Specs handle pretty darn good btw. Loving this square setup so far.
glad you figured it out. do you park on the street? the side towards the street might get more salt spray when cars go by in the wintertime.....
__________________
Lemonsqr is offline   Reply With Quote
Old 08-24-2012, 01:30 PM   #8
simsima325
'a certain moderator'
 
simsima325's Avatar
 
Join Date: Feb 2001
Location: Hyattsville, MD
Posts: 37,788
My Ride: Honda Civic
Kosei
__________________
-Brendan
simsima325 is offline   Reply With Quote
Old 08-24-2012, 04:14 PM   #9
imagine-02
Registered User
 
Join Date: Mar 2012
Location: WI
Posts: 30
My Ride: 330i
I don't park on the street but the previous owner might have. I haven't had the car very long.

On stock sport suspension, the 255/40-17 StarSpecs rub a tiny bit in the rear on some bumps. No fender rolling of any kind done yet.

Can't wait to autocross with these next month!




Last edited by imagine-02; 08-24-2012 at 04:15 PM.
imagine-02 is offline   Reply With Quote
Old 08-24-2012, 05:22 PM   #10
e30mike
Registered User
 
Join Date: Nov 2006
Location: Sacramento, California
Posts: 186
My Ride: 325i
Lookin good!
__________________
e30mike is offline   Reply With Quote
Old 08-24-2012, 05:32 PM   #11
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,805
My Ride: M54B30
looks nice. cleaning the hub of corrosion should always be done. wire-wheel the sh!t out of it.

so you're tracking the car. beefier sway bars? sway bar mounting tabs reinforced? oil pump nut... addressed?

oh ... and there's something on your roof! CAUTION! MPG, center of gravity, WEIGHT may be affected! YMMV!
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 08-24-2012, 05:44 PM   #12
tock172
Beachtown Bill Collector
 
tock172's Avatar
 
Join Date: Jan 2011
Location: San Diego
Posts: 2,905
My Ride: '99 Techno Violet M3
We have like the same exact car. Only I have the black headlamp trim and a few more scrapes and dings than you. But soon we'll have the same autocross wheel setup, cool!

And as Mango said, take off the rack. It's not going to do anything but hinder your performance at autocross. When I autocross, I take EVERYTHING out of the car that doesn't need to be there. Spare tire, jack, etc. You will notice that my car has a 'slicktop' in my sig photo.
__________________


1999 Techno Violet Metallic BMW M3
2005 Audi B6 S4 quattro 6MT
2004 BMW 330i
1986 BMW 535i


Last edited by tock172; 08-24-2012 at 05:51 PM.
tock172 is offline   Reply With Quote
Old 08-24-2012, 09:38 PM   #13
imagine-02
Registered User
 
Join Date: Mar 2012
Location: WI
Posts: 30
My Ride: 330i
The roof rack gets taken off while tracking it. I mtn bike and snowboard, so it comes in handy, especially when you need to get a 50" tv home and all you have is a car.

Sway bars, coilovers, reinforcements, oil pump problem... are all in the plans. Just don't have the cash or time to do everything at once.
Also doesn't help when I have two project cars that need a lot of work and money invested. A 2g DSM drag project and an e30 spec racer project.

Wow, we do have the same car. Looks like we both have a primer painted fog light piece too. By slicktop do you mean no sunroof? I don't have one of those fancy things either.

Last edited by imagine-02; 08-24-2012 at 09:40 PM.
imagine-02 is offline   Reply With Quote
Old 08-24-2012, 09:42 PM   #14
choxor
Registered User
 
Join Date: Nov 2010
Location: Atlanta, GA
Posts: 4,453
My Ride: JDM
Looking good. Glad you got it sorted.
__________________
choxor is offline   Reply With Quote
Old 08-24-2012, 09:56 PM   #15
tock172
Beachtown Bill Collector
 
tock172's Avatar
 
Join Date: Jan 2011
Location: San Diego
Posts: 2,905
My Ride: '99 Techno Violet M3
Quote:
Originally Posted by imagine-02 View Post
The roof rack gets taken off while tracking it. I mtn bike and snowboard, so it comes in handy, especially when you need to get a 50" tv home and all you have is a car.

Sway bars, coilovers, reinforcements, oil pump problem... are all in the plans. Just don't have the cash or time to do everything at once.
Also doesn't help when I have two project cars that need a lot of work and money invested. A 2g DSM drag project and an e30 spec racer project.

Wow, we do have the same car. Looks like we both have a primer painted fog light piece too. By slicktop do you mean no sunroof? I don't have one of those fancy things either.
Cool stuff. Do you have pics of the e30? I love e30s. I constantly find myself browsing craigslist. I will eventually break down and buy one as I have previously owned 2 e28s.

Yup, I lost the original fog lamp surround at autocross when I nailed an apex cone. And by slicktop I meant I have nothing mounted on top. You have no sunroof? That is awesome. I would love to have a sunroof delete
__________________


1999 Techno Violet Metallic BMW M3
2005 Audi B6 S4 quattro 6MT
2004 BMW 330i
1986 BMW 535i

tock172 is offline   Reply With Quote
Old 08-24-2012, 10:05 PM   #16
imagine-02
Registered User
 
Join Date: Mar 2012
Location: WI
Posts: 30
My Ride: 330i
It's nothing much to look at, but I like it.
Here's the only good pic of it I have access to right now.


I'm tearing the whole thing apart to repaint it and fix minor rust problems before I start the actual building for SpecE30.
imagine-02 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use