E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-24-2012, 12:46 PM   #1
328redleather
Registered User
 
Join Date: Aug 2011
Location: Queens
Posts: 233
My Ride: 328ci white/red
popping noise from front end! help!!!

well i have a 2000 328ci 5 speed with 90k. I've recently installed tein ss coilovers on my car and replaced the sway bar end links. now i have noticed a popping noise coming from the front end when i turn. the noise only happens every so often(maybe i will hear it 10-15 time a day) i am wondering if i need new cab? i ask around and called a few shops that said it could be a tie rod? could that be right? also a shop had said with the tein coils there needs to be a washer between the strut and top hat and that could be making the noise? please help idk what it could be, this weekend I'm going to tare the car apart and start looking.

thanks for reading my long post, just wanted to give as much info as possible.
__________________


2000 328ci alpine white on tannin red leather
328redleather is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-24-2012, 01:04 PM   #2
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,940
My Ride: '94 325iC & '00 323i
You need to revisit all of the stuff you did. Something is wrong. I have to wonder when people do stuff and then post, "I did stuff and now something is wrong, what should I look for?" Without question, you should look for what you did, then look at the stuff that is nearby.
jdstrickland is offline   Reply With Quote
Old 07-24-2012, 01:06 PM   #3
328redleather
Registered User
 
Join Date: Aug 2011
Location: Queens
Posts: 233
My Ride: 328ci white/red
it didn't start doing this till about 2 months after the coils were installed. so idt its related. everything it tight
__________________


2000 328ci alpine white on tannin red leather
328redleather is offline   Reply With Quote
Old 07-24-2012, 03:54 PM   #4
The_Don
Registered User
 
Join Date: Feb 2006
Location: Temecula, CA
Posts: 551
My Ride: 2001, 325Ci
My initial guess is that it may be the tie rods, as well. They can undergo a bit more stress after coilovers are installed, and as a result wear out more quickly. I don't know the details of your particular set up, but I know that I needed to get adjustable tie rods for mine to compensate for the lowering and preload to the sways.
__________________
- UUC Stg. 1 LTW Flywheel - UUC SSK + DSSR - UUC TM +TME - UUC Rear Adjustable Control Arms - UUC Swaybarbarians - AST Sportline II -
- RE Underdrive Pullys - RE FCABs - BMW Performance Control Arms - Shark Injector - EMP High Flow Water Pump - TMS Adjustable Endlinks - K&N CAI -
- M3 Motor Mounts -

For Sale
The_Don is offline   Reply With Quote
Old 08-29-2012, 09:23 AM   #5
Custom3
Registered User
 
Join Date: Sep 2005
Location: Dirty Jersey
Posts: 5,435
My Ride: HellRot 330CI
When the coilovers drop the front height of your car youll need to get shorter sway bar end links. Did you install the shorter end links or the original length ones?? Wrong size could cause the popping noise you hear when turning after using it for a while. Also I had the same problem but in my case it was the front reinforcement plate bolts that have gotten lose. I tighten the bolts and the noise went away. Click on the link below to see a pic of the plate Im talking about...

http://www.ecstuning.com/BMW-E46-330...rame/ES128604/
Custom3 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use