E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-09-2012, 03:13 PM   #1
CH715
Registered User
 
Join Date: Feb 2012
Location: Preston UK
Posts: 20
My Ride: BMW 325CI
Traction control light and eml

Hi Guy

Any Idea why I have randomly started getting a Traction control light and EML on the dash problem is intermittent only on some drives. When I restart the car the lights clear and the car drives fine.

Cant think what it could, few months ago I had the Traction control, Brake light and ABS and that turned out to be a wheel speed sensor that I changed.

Any ideas what this could be? last work I had done to the car was Clutch and flywheel job.

Could it possibly be a bad battery? not sure how long its been in there.

Your help would be really appreciated as iv spent alot of money on this car as it is.

BMW 325CI 2001 msport 146k
CH715 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-26-2012, 09:14 AM   #2
Lordray
Registered User
 
Join Date: Mar 2012
Location: Atlanta
Posts: 6
My Ride: 2005 325Ci
I had a similar situation last week. I lost power accelerating off a red light. Brake (in yellow), traction, and eml lights came on and rpms were just hovering around 1500. I restarted the car while still rolling and now it's been fine ever since.

Throttle body?
Disa?
ICv?

Anyone know if one of these (or something else) is fixing to die on me?
Lordray is offline   Reply With Quote
Old 09-26-2012, 10:46 AM   #3
Mctwist77
Registered User
 
Join Date: Apr 2010
Location: USA
Posts: 172
My Ride: '99' BMW 323i
Yeah your car is in limp mode. It's telling you something is wrong and your car is limiting its performance to prevent you from damaging it more. You should go to an Indy or autozone and have them check your engine codes. Usually it has to do with the throttle body but then again it could be anything.
__________________
Photobucket
BMW 323I 5 Speed
Mctwist77 is offline   Reply With Quote
Old 09-26-2012, 11:12 AM   #4
Zchild
Registered User
 
Join Date: Mar 2006
Location: Columbia, Maryland
Posts: 1,803
My Ride: 2000 BMW 3XXi ZSP
+1; start with checking your intake boots to make sure they are connected and without any holes. Next I would look at cleaning the throttle body and idle control valve. ust my two and a half cents worth...
__________________
V/R Zachary Pullins Sr.
National Capital Chapter BMWCCA
NCC Member Recognition Chairman
NCC High Performance Driving School Back-Up Registrar
NCC Auto-X BOD Liaison
DIY Senior Committee Coordinator
2006 E90 325Xi & 2000 E46 3XXi
" Vision without resources is just hallucination"
Zchild is offline   Reply With Quote
Old 09-28-2012, 01:23 PM   #5
DrkSide_RbL
Registered User
 
Join Date: Dec 2008
Location: San Francisco
Posts: 123
My Ride: 99' 328i Sport Sedan
Send a message via AIM to DrkSide_RbL
throttle body may have gunk and is getting stuck. Clean the flaps very well and while youre in there, clean the idle control valve also.

Sent from my SAMSUNG-SGH-I727 using Bimmer App
__________________
DrkSide_RbL is offline   Reply With Quote
Reply

Tags
dsc, eml, traction control light

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use