E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-10-2012, 11:43 PM   #1
J&D
Registered User
 
Join Date: Sep 2012
Location: Sacramento
Posts: 2
My Ride: E46
o2 Sensor/Check Engine Light

Hello all,

I have a 330ci with 102,000 miles. My check engine light came on. Dealership said it was a o2 sensor and replaced it at a high price. A few months later check engine light came back on. I had another shop look at it for free and they said it was an o2 sensor. I've been diving it for a few months now and the light turns of and on. I finally had time to DIY and replaced the o2 sensor with the BOSCH sensors and cleared the code but the check engine light came. I ran the code and it came up with P2240 & P2237 codes. The same codes I had before I replaced the o2 sensor. What could I be doing wrong? Any help would be appriciated. Thanks!

Last edited by J&D; 09-12-2012 at 08:27 PM.
J&D is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-02-2012, 01:45 AM   #2
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
Did you ever get this fixed, i have the same codes.
a32axo is offline   Reply With Quote
Old 10-02-2012, 09:12 PM   #3
J&D
Registered User
 
Join Date: Sep 2012
Location: Sacramento
Posts: 2
My Ride: E46
Nope, check engine light still turn on and off.
J&D is offline   Reply With Quote
Old 10-02-2012, 09:30 PM   #4
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
Did you trying fixing the problem? I'm thinking dme update but not 100 percent sure.

Last edited by a32axo; 10-02-2012 at 09:31 PM.
a32axo is offline   Reply With Quote
Old 10-02-2012, 09:33 PM   #5
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
Bump for some help!!!'
a32axo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use