E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-19-2012, 12:55 PM   #1
apmanzojr
Registered User
 
Join Date: Sep 2012
Location: californiA
Posts: 11
My Ride: 323I
Loosing Power?

Hi Guys

I was driving my car today 1999 323i E46 auto and I have noticed that when I am stepping on the accelator that especially when it passed the second gear that I felt like I have no torque power it drives okay and the engine seems like there is nothing work however but it felt like something is not right.. I noticed also that when I am accelerating the MPG meter is always high and when I am slowing down and even I letting my foot off the gas I noticed that the MPG meter is still going up especially my tachometer is going to normal RPM and the MPG even it goes up again up to 20 and goes back down to zero.

Hi Guys
I was driving my car today 1999 323i E46 auto and I have noticed that when I am stepping on the accelator that especially when it passed the second gear that I felt like I have no torque power it drives okay and the engine seems like there is nothing work however but it felt like something is not right.. I noticed also that when I am accelerating the MPG meter is always high and when I am slowing down and even I letting my foot off the gas I noticed that the MPG meter is still going up especially my tachometer is going to normal RPM and the MPG even it goes up again up to 20 and goes back down to zero.

Sorry if it is confusing it's my first time that I have experience this with this car and it's hard to explain. I did changed the spark plugs last week and use bosch I have learned that it should be NGK I am thinking of changing it back to NGK this week. I wonder if this is the cause of it any ideas what is ist?


but there were no check engine light in my car


Thanks
apmanzojr is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-19-2012, 01:11 PM   #2
Mctwist77
Registered User
 
Join Date: Apr 2010
Location: USA
Posts: 172
My Ride: '99' BMW 323i
If you just got the car I would recommend doing all the basic maintenance first then you can look to see where you are getting the bogging down.

Does this happen when the AC is off or just when its on?
__________________
Photobucket
BMW 323I 5 Speed
Mctwist77 is offline   Reply With Quote
Old 09-19-2012, 02:14 PM   #3
apmanzojr
Registered User
 
Join Date: Sep 2012
Location: californiA
Posts: 11
My Ride: 323I
Cool thanks, I did some maintenance on it I did changed the oil, filters, air filtes and spar plugs it was running okay yesterday, I just noticed it today when I am driving it, I did talked to one of the person in Pelican Parts and he told me that it could be the crankshaft sensor is failing I don't have any check engine line on and one think I noticed is when I am accelerating and when I am letting go of the gas pedal, the MPG meter is still on high it goes down and goes back up again up to 20 even the I don't have my foot on the pedal and it goes down again it ist probably crankshaft issue?
apmanzojr is offline   Reply With Quote
Reply

Tags
check engine, power, torque

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use