E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-19-2010, 01:21 PM   #1
shady1013
Registered User
 
Join Date: Sep 2010
Location: Virginia
Posts: 10
My Ride: 99 323I BMW
99 323I running rough at idle and stalls

Ok i am having issues with my e46 (99 323I) at start up idle it is really rough codes read misfire and i replaced the spark plugs, fuel filter and i still dont know what to do. the lights on my dash show check engine, an orange triangle with an ! and a circle around it, my break is on with ABS. I am lost on my next move it makes a clicking sound by the engine every once in a while and exhaust sputers every few seconds. i can answer any other questions just ask, the next thing i was looking at was cleaing my idle control valve but i wasnt sure if that would fix it.
shady1013 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-19-2010, 01:26 PM   #2
ALPIN3
Registered User
 
Join Date: Nov 2005
Location: CA
Posts: 4,092
My Ride: E46 M3 & E46 323i
Fuel pump perhaps. Common issue.
__________________
ALPIN3 is offline   Reply With Quote
Old 09-19-2010, 04:15 PM   #3
shady1013
Registered User
 
Join Date: Sep 2010
Location: Virginia
Posts: 10
My Ride: 99 323I BMW
if it is the pump any way i can check it? and if i was to replace is it just the pump or do i need the whole assembly?
shady1013 is offline   Reply With Quote
Old 09-19-2010, 04:26 PM   #4
mack89
Registered User
 
Join Date: Jan 2009
Location: Texas
Posts: 2,335
My Ride: '02 TIAG 330i 5spd
CEL and DSC+ABS+brake, huh?
Well DSC+ABS+brake light is not related to engine system. You have defective speed wheel sensors.

For rough idle & stall issue, I'd check MAF sensor and vacuum leak. Vacuum leak can cause rough idle, but it has to be huge leak to stall the engine. So my money's on MAF sensor.
And yeap, misfire codes are most likely caused by bad MAF sensor, less likely caused by spark plugs/ignition coils.

Here's the quick diagnosis

a) Start the car in the morning, check the RPM. Needle should go up to 1200-1500rpm right after the ignition and 7-800rpm on idle.
If the engine starts up so weakly and rpm needle won't go over 1k then makes rough idle in 2 minutes, most definitely MAF sensor.


OEM MAF sensor goes around $350-400, freaking expensive
But you have alternative option. Hyundai Sonata 2.5L model uses same MAF sensor, but much cheaper. $150ish. Check this thread for more info
http://forum.e46fanatics.com/showthr...hlight=hyundai


Quote:
Originally Posted by shady1013 View Post
if it is the pump any way i can check it? and if i was to replace is it just the pump or do i need the whole assembly?
And fuel pump won't give you SES code. You might notice symptoms when the fuel pump is failing, but it's hard to notice just like power steering pump. They just tend to fail without warning sign, weird symptoms, etc.
__________________

Last edited by mack89; 09-19-2010 at 04:29 PM.
mack89 is offline   Reply With Quote
Old 09-19-2010, 07:01 PM   #5
ALPIN3
Registered User
 
Join Date: Nov 2005
Location: CA
Posts: 4,092
My Ride: E46 M3 & E46 323i
Quote:
Originally Posted by mack89 View Post
And fuel pump won't give you SES code. You might notice symptoms when the fuel pump is failing, but it's hard to notice just like power steering pump. They just tend to fail without warning sign, weird symptoms, etc.
That's not entirely true. Just from personal experience, when my fuel pump died, the car went into limp mode, and threw a misfire CEL code as well. If the engine is starved of fuel, a code will pop up.
__________________
ALPIN3 is offline   Reply With Quote
Old 09-19-2010, 07:26 PM   #6
shady1013
Registered User
 
Join Date: Sep 2010
Location: Virginia
Posts: 10
My Ride: 99 323I BMW
well i replaced the fuel pump relay and you can hear the pump make noise when you turn on the car.
shady1013 is offline   Reply With Quote
Old 09-19-2010, 09:24 PM   #7
johnnysacco
Registered User
 
Join Date: Nov 2006
Location: Ft Lauderdale
Posts: 21
My Ride: 2000 323i
I had a similar problem in my 323i. Turned out to be a bad ignition coil.
johnnysacco is offline   Reply With Quote
Old 09-19-2010, 10:01 PM   #8
Solidjake
Zero. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 23,045
My Ride: 2002 330i
Clean your MAF first.
Solidjake is offline   Reply With Quote
Old 09-19-2010, 10:04 PM   #9
crazyafghanguy
Registered User
 
Join Date: Dec 2007
Location: Aliso Viejo, CA
Posts: 1,152
My Ride: E46 M3
check coils
__________________

01 M3
Black/Black 6 Speed
Style 95
Amber All Around
Ac Schnitzer Muffler
ZCP Brake Upgrade
crazyafghanguy is offline   Reply With Quote
Old 09-19-2010, 10:13 PM   #10
ace_of_hearts
Registered User
 
Join Date: Feb 2007
Location: MD
Posts: 25
My Ride: M3
Quote:
Originally Posted by crazyafghanguy View Post
check coils
+1

Misfire codes are usually caused by either coils or spark plugs.

Since you haven't mentioned changing the coils.

Here is a DIY to check coils:

ace_of_hearts is offline   Reply With Quote
Old 09-24-2010, 05:50 PM   #11
shady1013
Registered User
 
Join Date: Sep 2010
Location: Virginia
Posts: 10
My Ride: 99 323I BMW
Ok after extensive work cleaning and trial and error i found a hole in my Rubber Boot the connects my MAF to something well it cost me 62$ at the dealership. but solved all my issues thanks for the help and hope this helps anyone having the same issues.
shady1013 is offline   Reply With Quote
Old 09-24-2010, 05:51 PM   #12
Solidjake
Zero. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 23,045
My Ride: 2002 330i
Buy it online...
Solidjake is offline   Reply With Quote
Old 09-24-2010, 06:29 PM   #13
Spartan E46
Registered User
 
Join Date: Aug 2010
Location: Michigan
Posts: 17
My Ride: 2000 323i
Had the same set of issues. Check the condition of your battery and/or charging systems. A weak battery / insufficient power can wreak havoc on the electronics in your vehicle. Replacing my battery took care of all the issues I was having.

Nevermind - just saw you had the problem fixed. I usually try to rule out the battery whenever I get multiple lights/sets of codes.

Last edited by Spartan E46; 09-24-2010 at 06:31 PM.
Spartan E46 is offline   Reply With Quote
Old 04-23-2011, 05:25 AM   #14
mikechen1212
Registered User
 
Join Date: Apr 2011
Location: Millbrae
Posts: 1
My Ride: US
Hey, was your problem something like this?



I'm having a misfiring problem with a tapping noise. Thanks!
mikechen1212 is offline   Reply With Quote
Old 02-05-2014, 09:19 PM   #15
racer55000
Registered User
 
Join Date: Feb 2013
Location: florida
Posts: 1
My Ride: m3
please let me know what you determined the problem was?
racer55000 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use