E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-30-2012, 02:46 PM   #1
sabreuk
Registered User
 
Join Date: Aug 2012
Location: uk
Posts: 37
My Ride: 323ci vert
grrrr help! eml and asc+t light on :(

hey up guys been having an issue with the vert went to use it for a long drive to go on holiday with and had a check of the coolant forund that it was brown sludgy goo instead of green coolant removed all the coolant pipes and cleaned them out and power washed the rest of the system out to try and get the gundge out.

i also found the top rad hose had been tampered with finding the bleed screw that should of been there a bolt thats beenshoved in the hole. and the rubber o rings that seal the pipe had been bodged also, by what i mean by that is the rubber o ring out the cap was used in the pipe on the t stat housing and the rad cap was being sealed by copper greese so its had probs in the past with the cooling.

the previous owners needs a kicking big time.

i do think the tranny oil cooler is leaking which is causing the sludge rather than head gasket but i need to get that checked, the problem ive now got is........................

got new o rings today to replace the one i had left in the top rad hose and found that the lil pipe is also got a chip out of the recess the o ring sits in so i need a new pipe, got it all back together and put water in to run it up to check for leaks and see if the new o rigns are going to work, which they didnt the little pipe is leaking still so im ordering a new pipe tomoz.

got the car warm, had the air filter box off to get access to see if the pipes where leaking then went to give it some revs to pressureize the system etc to find it coughing and spluttering the EML light and ASC+T light is on on the dash, now idling its fine ticks over lovely give it some revs and its missing and i started to get a squeaky fan belt when it was trying to rev and steam coming from the rear of the engine from under the cabin filter area on the firewall if that makes sense. ive done a video which im attaching so you guys can have a hear of what it sounds like, the pulsing revs is the car not the accelerator being used.


__________________
UBIQUE

EVERYWHERE
sabreuk is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-30-2012, 07:43 PM   #2
sabreuk
Registered User
 
Join Date: Aug 2012
Location: uk
Posts: 37
My Ride: 323ci vert



any ideas on this guys any help appreciated.
__________________
UBIQUE

EVERYWHERE
sabreuk is offline   Reply With Quote
Old 08-31-2012, 12:12 PM   #3
sabreuk
Registered User
 
Join Date: Aug 2012
Location: uk
Posts: 37
My Ride: 323ci vert
right bit of an update ive got 3 fault codes stored bringing the eml light on .

1. P1622 MAP COOLING THERMOSTAT CONTROL CIRCUIT ELECTRICAL
2. P0505 IDLE CONTROL SYSTEM
3. P0101 Mass or Volume Air Flow Circuit Range/Performance Problem

my question now is, are these 3 problems masked as 1 main fault or do i have 3 seperate issues to contend with?

also has anybody had these 3 fault codes before in one go and what was the fix?

i also have the asc+t light still on is this related to the above fault codes?

any help would be greatly appreciated at this point. thanks craig
__________________
UBIQUE

EVERYWHERE
sabreuk is offline   Reply With Quote
Old 09-02-2012, 03:35 PM   #4
sabreuk
Registered User
 
Join Date: Aug 2012
Location: uk
Posts: 37
My Ride: 323ci vert
UPDATE:

well had a good bash at the cooling system today :-/ well the fault codes i got have cleared them selfs after a good degunge of the whole system wow it was messy but ive got pretty much 90% cleaned out, im going to finish flushing the rest of the crap out tomoz when the engine is cold again so if it isnt already blown dont blow the head gasket.

well im actualy stumped with these symptoms its showing signs of a head gasket and showing signs that it isnt :-/

right ive obviously got oil in my coolant which is going around the entire system and blocked the whole lot. i dont however have water in my oil in the sump side of things??????
im not overheating the temp gauge is holding steady at half way on the gauge despite the cooling system from what i can tell has been cooling off the heater matrix in the cab of the car?????
im not getting any water out the exhaust except condensation off the cat due to not driving it in a week
ive now got good flow and has been thoroughly flushed out by various methods to get the oil out the system and like i said im 90% there just need a few flushes and it will be a sparkly fresh cooling system again

ive taken the tranny lines off the cooler at the bottom of the rad and that looks good no contamination at all in there so im stumped where the oil is coming from?????????/

ive spoken to the previous owner and asked if he knew of any cooling probs when he sold me the car and he said no
i asked if himself or his mrs has topped the coolant up with oil accidentaly thinking they might have done that he said no so maybe its an old issue that hasnt been fixed or flushed properly from the previous previous owner.
so im going to pressure test the system see if the cylinders are holding the pressure, im also going to sniff test the cooling system see if im getting exhaust gas in the system and im going to do a coolant pressure test to see if the system holds pressure.

my question now is, is there any other way oil can get in to the cooling system through an engine oil cooler or something which i dont know about?

this is my first german car so im on a very steep quick learning curve AGAIN lol
__________________
UBIQUE

EVERYWHERE
sabreuk is offline   Reply With Quote
Old 09-07-2012, 03:08 PM   #5
sabreuk
Registered User
 
Join Date: Aug 2012
Location: uk
Posts: 37
My Ride: 323ci vert
hey up guys question CODE P0505 is the air idle control valve or am i wrong.

got all the coolant system flushed out and all is good so far but i now keep getting this p0505 code. also has someone got a pic of where its located please thanks craig .
__________________
UBIQUE

EVERYWHERE
sabreuk is offline   Reply With Quote
Old 09-14-2012, 09:23 AM   #6
sabreuk
Registered User
 
Join Date: Aug 2012
Location: uk
Posts: 37
My Ride: 323ci vert
UPDATE AGAIN

well just sent car to an indipendant beemer garage and stuck the car on his computer and read the fault codes and found that

P0505 CODE IS ELECTRONIC THROTTLE BODY FAILURE STICKY/SIEZED

the generic p0505 code says idle air control system.

so if you get this fault code the chances are its the throttle body component thats failed. so that is getting fixed once a new throttle body is ordered.
also found my passenger occupancy sensor has failed but the previous owner has removed the bulb from the dash so theres a bypass system being put in and the bulb replaced.
also he is working on my passenger seat issue which he reakons is an easy job to sort so he can sort that aswell and my passenger mirror which turns out to be the completely wrong mirror for my car.

so from here got a bit of a bill to pay, a car being fixed and a chat with the previous owner for being a twat and hiding the airbag issue grrrrrrrrrrrrrrrrrrrrr!!!!!!!!!!!!!!!!!!!
__________________
UBIQUE

EVERYWHERE
sabreuk is offline   Reply With Quote
Old 09-21-2012, 07:26 PM   #7
sabreuk
Registered User
 
Join Date: Aug 2012
Location: uk
Posts: 37
My Ride: 323ci vert
well had a phone call today from the garage and ive just been lumped with a 300 bill so far upto today and the possibility of it being more by time i pick the car back up tuesday its had the electronic throttle body changed, the passenger seat occupancy bypass sensor fitted, the air bag light put back in the dash, a new passenger mirror due to the one i had being the wrong mirror apparantly, a new mirror switch as mine was not working anyway and the mechanic is now on with fixing my passenger problem which he thinks is down to the wing mirror and switch not activating the memory seat settings or something :-/

anyway he was supposed to call me monday to give me prices and quotes etc but just went ahead and fixed everything nearly so happy in a way but not happy in a way either but hey ho, so that leaves the rear bumper and parking sensors to sort and the dash then everything will be working and as it should be, so big thanks to the previous owner for being a cheap git and not sorting these probs out before selling it to me, ill also take credit for being a mong and not finding these faults before i bought the car in the first place well the ones i didnt know about anyway

so tuesday ill get it back and hopefully will last a bit longer than it has
__________________
UBIQUE

EVERYWHERE
sabreuk is offline   Reply With Quote
Old 09-21-2012, 09:28 PM   #8
Vandyinc
Registered User
 
Join Date: Aug 2010
Location: Goose Creek, SC
Posts: 136
My Ride: 2000 323 Cic
Thanks for the update.
__________________
Done:FCABs, OFHG, CCV, Cooling Sytem refresh, Coolantsnitch. Yet to do:Transmission fluid & filter, Shocks & Struts, VCG
Vandyinc is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use