E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-23-2012, 01:56 PM   #1
Xanthoxx
Registered User
 
Join Date: Apr 2004
Location: Owasso Oklahoma
Posts: 48
My Ride: 04 BMW 330CI
e46 M3 Limp Mode after Euro Headers

So I installed my euro headers this weekend with a new CRT from Custom Performance Innovations, 200 Cell Cats and EGT bung.

I was very careful to install the 02 sensors properly, the two side by side at rear of valve cover, A, the furtherst right is bank 1-3 precat, the other is 4-6 precat. The Post cat 02s on the side of the engine, along with the EGT were removed from the harnes and routed down the right side of engine. Everything is tucked away safe from heat.

I finally finished and anxiously fired it up, and to my dismay, rough idle. I restarted car 5 time to get the check engine codes.

No 02 errors........

1b69 Engine coolant temp
1b90 fuel control bank 1
1b91 fuel control bank 2
1bcd warmup misfire cyl 1
1bce warmup misfire cyl 2
1bcf warmup misfire cyl 3
1bd5 warmup misfire multiple cyl

This is all so far.......but it results in massive limp mode.

Any thoughts?
__________________
- Xanthoxx

Last edited by Xanthoxx; 05-29-2013 at 11:51 PM.
Xanthoxx is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-23-2012, 06:16 PM   #2
HakenTT
OEM ///Member
 
Join Date: Aug 2009
Location: gross deutsches reich USA
Posts: 520
My Ride: 323i with S54
you switched the 02 plugs. You plugged bank 1 into bank 2 and other way around.
HakenTT is offline   Reply With Quote
Old 09-23-2012, 06:20 PM   #3
Xanthoxx
Registered User
 
Join Date: Apr 2004
Location: Owasso Oklahoma
Posts: 48
My Ride: 04 BMW 330CI
I just pulled it all apart again to make sure... Plug A at rear right of valve cover, the far outside one closest to driver is bank one and it is in my long header, cyl 1-3. Additionally they can only be swapped at the header since the plugs are different on the car harness. But to ensure I unhooked and removed both, and ran "A" to the long header to ensure before hooking up the second.

The reason I say this is there is a 1 on the A harness (shown on black plastic, hard to see) on far right rear, that should correspond to bank 1.

Still limped.
__________________
- Xanthoxx

Last edited by Xanthoxx; 09-23-2012 at 08:00 PM. Reason: .
Xanthoxx is offline   Reply With Quote
Old 09-23-2012, 09:38 PM   #4
Xanthoxx
Registered User
 
Join Date: Apr 2004
Location: Owasso Oklahoma
Posts: 48
My Ride: 04 BMW 330CI
Picture Wrong

Ok so I swapped my precat o2s and the car stayed out of limp mode while driving around the block.

Apparently the picture I used has the precats swapped but it is still odd that the wire marked 1 is for the short header rear bank cyl 4-6. dunno:
__________________
- Xanthoxx
Xanthoxx is offline   Reply With Quote
Old 09-23-2012, 09:53 PM   #5
vonbimmer
Registered User
 
Join Date: Jun 2012
Location: Reno
Posts: 21
My Ride: 01' E46 M3
I have a sensor diagram if you'd like a copy just shoot me a PM with your email. I had trouble sorting this out too, but dodged the limp mode.
vonbimmer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use