E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-26-2012, 06:48 AM   #1
Wilba83
Registered User
 
Join Date: Sep 2012
Location: Barrow in Furness
Posts: 6
My Ride: Bmw323i
Water problems

hi all got a problem I hit a puddle last nite which killed my engine managed to get it running but it wnt rev over 2500 to 3000 rpm and wnt do over 10 mph any ideas what I have done. I've been told a blown air hose or a cat sensor. Any help would be great thanks
Wilba83 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-26-2012, 06:55 AM   #2
TArse
Registered User
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 680
My Ride: 03 330xi, 87 325is
Any codes?
TArse is offline   Reply With Quote
Old 09-26-2012, 06:57 AM   #3
Wilba83
Registered User
 
Join Date: Sep 2012
Location: Barrow in Furness
Posts: 6
My Ride: Bmw323i
What codes bud
Wilba83 is offline   Reply With Quote
Old 09-26-2012, 07:31 AM   #4
paraklas
OEM ///Member
 
paraklas's Avatar
 
Join Date: Jan 2006
Location: Cyprus
Posts: 5,954
My Ride: ESS TS2 320ci
Check engine light on?
Possibly ruined the MAF, easy fix, go read the fault codes if any
Or hydrolocked your engine, expensive fix
__________________
http://www.argyrides.eu/makeyourownsig.jpg
paraklas is offline   Reply With Quote
Old 09-26-2012, 08:06 AM   #5
deanthedude1977
Registered User
 
Join Date: Apr 2012
Location: southampton-uk
Posts: 64
My Ride: bmw e46 325i sport
Is the EML light on if so get the codes read--might pay you to take off maf sensor and clean then try again after refitting
__________________
deanthedude1977 is offline   Reply With Quote
Old 09-26-2012, 09:33 AM   #6
Wilba83
Registered User
 
Join Date: Sep 2012
Location: Barrow in Furness
Posts: 6
My Ride: Bmw323i
We're will I get these codes from coz eml light is on.
Wilba83 is offline   Reply With Quote
Old 09-26-2012, 09:40 AM   #7
deanthedude1977
Registered User
 
Join Date: Apr 2012
Location: southampton-uk
Posts: 64
My Ride: bmw e46 325i sport
You need a code reader or take car somewhere that will read the codes for you--i bought a code reader from ebay works fine.
Any bmw dealer will do 4u but cheaper to take to independant bmw specialist--they will charge u an hours albor probably--it only takes 5 min tho..
I will send you the link if u want it--that will only tell you whats wrong-it wont fix your problem.
Im guessing water has gone through ur intake and either broke or made ur Maf sensor dirty--lots of posts on here how to clean maf sensor--very easy and is what i would do first.
__________________
deanthedude1977 is offline   Reply With Quote
Old 09-26-2012, 09:46 AM   #8
Wilba83
Registered User
 
Join Date: Sep 2012
Location: Barrow in Furness
Posts: 6
My Ride: Bmw323i
Thanks bud
Wilba83 is offline   Reply With Quote
Old 09-26-2012, 09:47 AM   #9
rd5150
Registered User
 
Join Date: Jun 2010
Location: ohio
Posts: 55
My Ride: 325i
most autoparts stores will read codes for free
rd5150 is offline   Reply With Quote
Old 09-26-2012, 09:56 AM   #10
deanthedude1977
Registered User
 
Join Date: Apr 2012
Location: southampton-uk
Posts: 64
My Ride: bmw e46 325i sport
not here in the Uk they dont
__________________
deanthedude1977 is offline   Reply With Quote
Old 09-26-2012, 10:19 AM   #11
dknightd
Registered User
 
Join Date: Jul 2012
Location: upstate NY
Posts: 1,075
My Ride: 2002 330 cic
My guess would be you got water in an electrical connection that is making your car think something is wrong. When your car computer thinks something is wrong it goes into limp home mode. See if your air cleaner is wet - it if is you might just need to dry or replace it. Disconnect electrical connections to all sensors, see if there is water inside, if so dry and apply dielectric grease. Likely you problem will go away when the car gets dry. You can let it do that itself, or speed the process along if needed.
dknightd is offline   Reply With Quote
Old 09-27-2012, 01:09 AM   #12
TArse
Registered User
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 680
My Ride: 03 330xi, 87 325is
Quote:
Originally Posted by Wilba83 View Post
What codes bud
Like the others said. If you have a check engine light on, go to a dealership (unless you can find a code reader elsewhere) get the the codes read, then report back with the codes.
TArse is offline   Reply With Quote
Old 09-28-2012, 05:38 AM   #13
Wilba83
Registered User
 
Join Date: Sep 2012
Location: Barrow in Furness
Posts: 6
My Ride: Bmw323i
Thanks lads got it running now all okay just got tapping noise now
Wilba83 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use