E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-26-2012, 08:44 AM   #1
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Question DSC, RDC, Brake light all on at the same time

I know this isn't the first thread with this kind of problem but none of the ones I read had a solid answer to what causes these lights to come on all at once. Plus there is a bunch of mixed "magical" fixes for it.

OK, so driving 40mph, straight road, go over a very small bump, and BAM all three lights at the same time. Park, turn off car, restart, lights are still on. The car drives just fine so no limp mode action going on.

I will scan with PA Soft when I get home tonight, but until then, any ideas?

Heres a pic (sorry glare):
[IMG][/IMG]
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-26-2012, 08:53 AM   #2
Lividevil
Registered User
 
Join Date: Mar 2012
Location: Fairfax, VA. USA
Posts: 39
My Ride: 2000 323i
Could be a number of issues, get scanned and report back
Lividevil is offline   Reply With Quote
Old 09-26-2012, 12:29 PM   #3
illestminimike
Registered User
 
Join Date: Jan 2012
Location: West Covina CA
Posts: 4,038
My Ride: Project Drama
I'm gonna say steering angle position sensor. Is your alignment off? I had the same problem. Still read the codes. Try not to drive to much, otherwise the lights will stay on permanently.
__________________
-2005 SMG ZCP Coupe
-1967 Mini Cooper
illestminimike is offline   Reply With Quote
Old 09-26-2012, 04:27 PM   #4
soccerTOOLsu
Registered User
 
Join Date: Sep 2005
Location: Seattle
Posts: 38
My Ride: 325i '02
Have you adjusted your steering wheel position lately?

I adjusted mine to remove seats and the lights came on. After a week I readjusted the steering wheel position again and the lights came off.

I think its probablly a bad wire connection to the Steering Angle Position Sensor if not the sensor.
soccerTOOLsu is offline   Reply With Quote
Old 09-26-2012, 07:15 PM   #5
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Quote:
Originally Posted by soccerTOOLsu View Post
Have you adjusted your steering wheel position lately?

I adjusted mine to remove seats and the lights came on. After a week I readjusted the steering wheel position again and the lights came off.

I think its probablly a bad wire connection to the Steering Angle Position Sensor if not the sensor.
No I haven't, not in a really long time, like a year.
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Old 09-26-2012, 07:20 PM   #6
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Exclamation Codes Read

OK, so I read the codes with PA Soft. Under the ABS module I have (2) errors.

Red: (Fault Currently Present) 5E43 [24131] Steering Angle Sensor Internal
Yellow: (Fault Not Currently Present) 5E5C [24156] RPA Push Button Error

Codes won't clear when I try to clear them!

So now what?

__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944

Last edited by FastHackem; 09-26-2012 at 07:21 PM.
FastHackem is offline   Reply With Quote
Old 09-26-2012, 07:54 PM   #7
illestminimike
Registered User
 
Join Date: Jan 2012
Location: West Covina CA
Posts: 4,038
My Ride: Project Drama
Get an alignment. It'll fix itself. I had the same problem. Trust me, do it ASAP! It'll get a lot worse and a lot more things will go wrong.
__________________
-2005 SMG ZCP Coupe
-1967 Mini Cooper
illestminimike is offline   Reply With Quote
Old 09-27-2012, 07:09 AM   #8
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Quote:
Originally Posted by illestminimike View Post
Get an alignment. It'll fix itself. I had the same problem. Trust me, do it ASAP! It'll get a lot worse and a lot more things will go wrong.
I will definitely try this first since I still have been needing to do this since I changed the shocks and struts (~4000 miles ago). I mean, the car tracks normally but I'm sure it needs one after messing with suspension components.

If I have to change the sensor, I will go ahead and do the steering coupler and FCABs while I'm at it.
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Old 09-28-2012, 04:15 PM   #9
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Bump. Going to get alignment tomorrow. Any other guesses at what would cause this?
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Old 09-29-2012, 09:28 PM   #10
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Got an alignment today. Toe was off on all 4 corners. Lights are still on.....

Sent from my Nexus S 4G using Bimmer App
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Old 09-29-2012, 09:35 PM   #11
illestminimike
Registered User
 
Join Date: Jan 2012
Location: West Covina CA
Posts: 4,038
My Ride: Project Drama
Now have someone reset the codes. Or try disconnecting your battery with the wheel straight. That might work.
__________________
-2005 SMG ZCP Coupe
-1967 Mini Cooper
illestminimike is offline   Reply With Quote
Old 09-30-2012, 03:36 PM   #12
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Unplugged battery for 10 minutes, touched the pos to ground . Lights still on. Tried to clear codes in PA Soft and reset the ABS module. Lights still on. Same errors as before. Drove around some today also.

Looks like I will be changing out a steering sensor soon.....

Sent from my Nexus S 4G using Bimmer App
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944

Last edited by FastHackem; 09-30-2012 at 03:37 PM.
FastHackem is offline   Reply With Quote
Old 09-30-2012, 04:19 PM   #13
illestminimike
Registered User
 
Join Date: Jan 2012
Location: West Covina CA
Posts: 4,038
My Ride: Project Drama
Yup. Change it out.
__________________
-2005 SMG ZCP Coupe
-1967 Mini Cooper
illestminimike is offline   Reply With Quote
Old 10-01-2012, 12:45 PM   #14
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Bump. Does anyone think a recalibration via GT1 would be worthwhile?
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Old 11-10-2012, 10:35 PM   #15
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
Smile Update

I loaded up DIS cleared the codes and the lights turned off. Took her for a drive and before I could get out of my neighborhood, the lights all came back on.

Then, I loaded up DIS again, calibrated the sensor (match sensor - DIS Term), cleared codes again, went for a drive, VIOLA lights are OFF and stayed off. I will update this if they come back on next week.
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use