E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-27-2012, 09:53 PM   #1
JTripper
OEM ///Member
 
JTripper's Avatar
 
Join Date: Sep 2012
Location: Brooklyn
Posts: 596
My Ride: 325ci
Is it normal for the oil light to.......

i'm whipping around an 02 325ci (just got her-still in my 2nd week goin on 3rd with her)
Thing is: my oil light comes on for 14 seconds, after the car is started, and doesnt come back on for the duration of the trip! Is that normal or should i worry? i've checked my oil levels and they're good, the oil is clean.. i did my O/C myself... everything was irie! i must say that I noticed the oil light thing from the first time i test drove the car... i made the dealer add 2qts. (it was low righ then n there when i checked it on their lot)
JTripper is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-27-2012, 10:06 PM   #2
cityjohn
Registered User
 
Join Date: Nov 2007
Location: Los Angeles
Posts: 2,496
My Ride: 2001 M3
Quote:
Originally Posted by JTripper View Post
Is that normal or should i worry?
Completely normal. It is the consistent behavior of a failed oil level sensor. Easy to replace at your next oil change.
__________________
cityjohn is offline   Reply With Quote
Old 09-27-2012, 10:17 PM   #3
JTripper
OEM ///Member
 
JTripper's Avatar
 
Join Date: Sep 2012
Location: Brooklyn
Posts: 596
My Ride: 325ci
IRIE!!! thanks much John and i'll look out for that part in advance!!! how far deep into car is the sensor, if you know? i'm a cheap bastard with acces to $$$ lol! Irather do it MYSELF!!!
JTripper is offline   Reply With Quote
Old 09-27-2012, 10:25 PM   #4
cityjohn
Registered User
 
Join Date: Nov 2007
Location: Los Angeles
Posts: 2,496
My Ride: 2001 M3
Two screws hold it into the bottom of the oil pan, and an electrical connector snaps onto it.
__________________
cityjohn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use