E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-29-2012, 12:48 PM   #1
mattfarrington
Registered User
 
Join Date: Jan 2012
Location: Londonderry
Posts: 278
My Ride: 04 325xi
HELP! Engine Misfire?!

So this morning my brother and I installed Turnermotorsport SS brake lines. All went well.

When I was driving the car home from his shop, it feels like the engine is misfiring like a mother ****er.
The car is INCREDIBLY jerky.
Almost as if the throttle body is opening and closing 100%-0% constantly.

No check engine light.. sadly.

But i have no idea what it could be. It's new.

Also, when in neutral, and I step on it, it struggles A LOT to get any rpm gain.

I'm thinking limp mode, but why?!
mattfarrington is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-30-2012, 03:25 PM   #2
mattfarrington
Registered User
 
Join Date: Jan 2012
Location: Londonderry
Posts: 278
My Ride: 04 325xi
Having an Indy shop do the work.

My DISA valve blew on me, so he is ordering one tomorrow for me, and it's $280 installed.

Was shooting codes for Bank 1 and 2 lean.

He said he can hear it rattling around.
mattfarrington is offline   Reply With Quote
Old 09-30-2012, 11:02 PM   #3
Beamer Creamer
Registered User
 
Join Date: Sep 2012
Location: Canada
Posts: 270
My Ride: 2005 bmw m3
Get spark checked first. I dont think limp mode misfires. May have to get shop with better scan tool to make sure each cyl. Firing correct. Of course that sucks. Try disconnect your battery for awhile. Might reset prob? Check all fuses for fun quickly with test light. I cant think of a nything in brake electrical that would do that even if unhooked for some reason
Beamer Creamer is offline   Reply With Quote
Old 10-01-2012, 04:00 PM   #4
mattfarrington
Registered User
 
Join Date: Jan 2012
Location: Londonderry
Posts: 278
My Ride: 04 325xi
Got a call earlier, the Valve is replaced, runs much better. But...
My fuel pump shit the bed. It's putting out 20psi, where it should be putting out 50psi.

He's doing that at cost of the pump for me. Nice guy.
mattfarrington is offline   Reply With Quote
Old 10-01-2012, 04:00 PM   #5
mattfarrington
Registered User
 
Join Date: Jan 2012
Location: Londonderry
Posts: 278
My Ride: 04 325xi
Got a call earlier, the Valve is replaced, runs much better. But...
My fuel pump shit the bed. It's putting out 20psi, where it should be putting out 50psi.

He's doing that at cost of the pump for me. Nice guy.
mattfarrington is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 11:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use