E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-21-2012, 08:39 PM   #1
417xku
Registered User
 
Join Date: Feb 2012
Location: Atlanta
Posts: 4
My Ride: 330i
Horn Won't Work (M3 Steering Wheel Conversion)

I recently did a conversion on my 330i from a sport steering wheel to a M3 steering wheel w/paddle shifters. The shifters work and the cruise control works. However, the horn and the volume buttons do not work. Does anyone know if this is something which can be fixed by a module or wiring harness? The horn fuse is fine and I do not hear any clicking when the horn is pressed (don't hear the relay).
417xku is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-21-2012, 09:35 PM   #2
fauchpj
Registered User
 
Join Date: May 2006
Location: Birmingham
Posts: 67
My Ride: 2003 540i/6
I would take the airbag back out and double check all of the connections.
fauchpj is offline   Reply With Quote
Old 02-21-2012, 09:36 PM   #3
Bostonbeast
Registered User
 
Join Date: Feb 2011
Location: South Florida
Posts: 239
My Ride: 2000 328i
Pop out your airbag and just recheck to see if all of your wiring is plugged in properly. Also disconnect your battery to prevent your airbag light from going off in case if you accidentally disconnect it.
Bostonbeast is offline   Reply With Quote
Old 02-21-2012, 09:37 PM   #4
Bostonbeast
Registered User
 
Join Date: Feb 2011
Location: South Florida
Posts: 239
My Ride: 2000 328i
Quote:
Originally Posted by fauchpj View Post
I would take the airbag back out and double check all of the connections.
Lol beat me to it.
Bostonbeast is offline   Reply With Quote
Old 02-21-2012, 09:56 PM   #5
417xku
Registered User
 
Join Date: Feb 2012
Location: Atlanta
Posts: 4
My Ride: 330i
Quote:
Originally Posted by fauchpj View Post
I would take the airbag back out and double check all of the connections.
Quote:
Originally Posted by Bostonbeast View Post
Pop out your airbag and just recheck to see if all of your wiring is plugged in properly. Also disconnect your battery to prevent your airbag light from going off in case if you accidentally disconnect it.
Ok. Thanks. I'll take it out this weekend and check all the connections. I'll let ya know what I find.
417xku is offline   Reply With Quote
Old 09-24-2012, 07:56 PM   #6
Thotfulspot
Registered User
 
Join Date: Apr 2011
Location: Chicago
Posts: 212
My Ride: 2003 330Xi
Did you find a solution? I swapped from the 4 spoke to a M Sport and cruise and horn works but volume doesn't. Looking at Realoem it looks like there is an extra cable on the 4 spoke.
Thotfulspot is offline   Reply With Quote
Old 09-29-2012, 10:52 PM   #7
Thotfulspot
Registered User
 
Join Date: Apr 2011
Location: Chicago
Posts: 212
My Ride: 2003 330Xi
No extra cable on the 4 spoke. We pulled the wheel all the way off and can get everything but the volume and track buttons. Anyone have a clue or can point me at someplace with information.
Thotfulspot is offline   Reply With Quote
Reply

Tags
steering wheel conversion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use