E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-19-2013, 03:47 PM   #1
DOB2009
Registered User
 
Join Date: Oct 2005
Location: OC-So Cal
Posts: 953
My Ride: 325i
Is this problem I am experienced the Vanos seal?

So let me just say the most noticeable symptom that just happened. When stopped to pull out today in my e46 (01 325i has about 83k miles) The RPM almost stalled out going to about 800rpm, then jumped up to about 1800, dipped back down, back up again, then leveled out around 800 and stayed.

The other really annoying problem I have is when going slow through my complex over speed bumps, when it's time to accelerate again the RPMs just inconsistently rev up/down until I give it a lot of gas.

It makes me look like an asshole to my neighbors every day like I keep tapping the gas pedal as I drive by to rev it up.

Is this the Vanos seal? If so what can I expect to pay to fix it trying to take the last expensive route as possible.

-Finally if anyone knows anyone in Southern Orange County, CA who can fix this for a fair price let me know. Thank you guys.
DOB2009 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-19-2013, 03:50 PM   #2
VALMONT
The De46vil's Army
 
VALMONT's Avatar
 
Join Date: Oct 2002
Location: So Cal
Posts: 24,602
My Ride: 325Ci, Passat
Send a message via AIM to VALMONT Send a message via MSN to VALMONT
when did/have you replaced the cam position sensors?
__________________
VALMONT is offline   Reply With Quote
Old 07-19-2013, 03:53 PM   #3
DOB2009
Registered User
 
Join Date: Oct 2005
Location: OC-So Cal
Posts: 953
My Ride: 325i
Quote:
Originally Posted by VALMONT View Post
when did/have you replaced the cam position sensors?
I don't think I've had them replaced ever, but the car has had a lot of work done over the years extensive list. If it was done it was about 2 years ago. Is this the sensor you're speaking of: http://www.ebay.com/itm/BMW-E39-E46-...d39eec&vxp=mtr

Thanks for quick reply.
DOB2009 is offline   Reply With Quote
Old 07-19-2013, 04:24 PM   #4
VALMONT
The De46vil's Army
 
VALMONT's Avatar
 
Join Date: Oct 2002
Location: So Cal
Posts: 24,602
My Ride: 325Ci, Passat
Send a message via AIM to VALMONT Send a message via MSN to VALMONT
there are 2.

one on the intake side and one on the exhaust side.

when my intake one went bad, I had issues like yours and they got progressively worse.

also check your plugs and coils, damn coils cause more problems than anything.

or... you could have a vacuum leak, usually the intake elbow?
__________________
VALMONT is offline   Reply With Quote
Old 07-19-2013, 04:28 PM   #5
peytonracer4
:D
 
peytonracer4's Avatar
 
Join Date: Jan 2010
Location: Valparaiso, IN
Posts: 6,410
My Ride: '00 328i
Is this problem I am experienced the Vanos seal?

Vacuum leak possibly
__________________
choose to click or forever hold your peace ;)
peytonracer4 is online now   Reply With Quote
Old 07-19-2013, 04:37 PM   #6
DOB2009
Registered User
 
Join Date: Oct 2005
Location: OC-So Cal
Posts: 953
My Ride: 325i
Quote:
Originally Posted by VALMONT View Post
there are 2.

one on the intake side and one on the exhaust side.

when my intake one went bad, I had issues like yours and they got progressively worse.

also check your plugs and coils, damn coils cause more problems than anything.

or... you could have a vacuum leak, usually the intake elbow?
Thanks actually I just did plugs/coils not long ago and it made a HUGE difference. I used to have a Gruppe M intake, then spent almost $1000 in smog related repair to pass I am back to OEM intake without the snorkel (does that make a difference)?

Also are these two sensors pretty straight forward to replace? I think I may order them, that would be awesome if thats all I had to do.
DOB2009 is offline   Reply With Quote
Old 07-19-2013, 06:13 PM   #7
peytonracer4
:D
 
peytonracer4's Avatar
 
Join Date: Jan 2010
Location: Valparaiso, IN
Posts: 6,410
My Ride: '00 328i
Is this problem I am experienced the Vanos seal?

What difference did coils and plugs make?
__________________
choose to click or forever hold your peace ;)
peytonracer4 is online now   Reply With Quote
Old 07-19-2013, 06:37 PM   #8
DOB2009
Registered User
 
Join Date: Oct 2005
Location: OC-So Cal
Posts: 953
My Ride: 325i
Quote:
Originally Posted by peytonracer4 View Post
What difference did coils and plugs make?
For me the RPMs were just more consistent after, it felt more sluggish before with less power. Actually plugs I did twice in a row with little difference, it was the coils that really helped the next time I did them together.
DOB2009 is offline   Reply With Quote
Old 07-19-2013, 06:43 PM   #9
CharlzO
Registered User
 
Join Date: Feb 2012
Location: Upstate NY
Posts: 642
My Ride: 2000 328ci
Quote:
Originally Posted by DOB2009 View Post
Also are these two sensors pretty straight forward to replace? I think I may order them, that would be awesome if thats all I had to do.
Haven't done the exhaust side myself, but the intake was pretty simple. 15 mins or so if I remember right.
CharlzO is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 07:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use